Notifications
teltersat
teltersat
Group: Registered
Joined: January 10, 2019
Eminent Member
2
I have a Seasonic 750W PSU installed in it already as part o...

In forum Thunderbolt Windows eGPU

7 months ago
RX Vega 64 w/ Windows: Crash on long idle time

In forum Thunderbolt Windows eGPU

7 months ago
TB3 Active cable performance

In forum PSU, Fans & Cables

7 months ago
I recently swapped my RX580 to a Vega 64 and it works like a...

In forum What gear should I buy?

7 months ago
I have encountered this problem myself (i.e. for seconds at ...

In forum GPU, Monitor & Peripherals

7 months ago
Perhaps there was an update indeed - my Mantiz was consider...

In forum Thunderbolt Enclosures

8 months ago
@eightarmedpet the fan wasn't noisy, but the PSU was! There ...

In forum Thunderbolt Enclosures

8 months ago
Do you have any other ports (maybe USB) that you can test? I...

In forum Thunderbolt Enclosures

8 months ago
I would love to see your use case for that riser card (what ...

In forum Thunderbolt Enclosures

8 months ago
Not sure that's how it should work. the GPU in your laptop w...

In forum GPU, Monitor & Peripherals

8 months ago
I would love to see the 5700 XT performance once drivers sta...

In forum What gear should I buy?

8 months ago
Yeah this is what I wanted to confirm. Thanks!

In forum BootCamp eGPU Setup

9 months ago
Question for those with stock AMD drivers in their 2016+ Mac...

In forum BootCamp eGPU Setup

9 months ago
Windows 10 1903 w/ TB3 on a Macbook Pro = Glitches and annoy...

In forum BootCamp eGPU Setup

9 months ago
Audio issues with Thunderbolt enclosure

In forum Thunderbolt Windows eGPU

10 months ago
If you're running bootcamp, when you connect the eGPU enclos...

In forum Thunderbolt Windows eGPU

10 months ago
Traditionally air should be pushed inwards, but there's not ...

In forum Thunderbolt Enclosures

10 months ago
yeah, that was the right orientation! thanks!

In forum Thunderbolt Enclosures

10 months ago
My Mantiz Venus is a bit hot after an overhaul

In forum Thunderbolt Enclosures

10 months ago
There are three big caveats that I've noticed when using thi...

In forum BootCamp eGPU Setup

11 months ago
Good point! I forgot that panel is TB3-only...

In forum BootCamp eGPU Setup

11 months ago
I've just managed to resolve this by: Updating the MZ-0...

In forum Thunderbolt Windows eGPU

12 months ago
I really liked the Mantiz Venus MZ-02, as it comes with a wh...

In forum What gear should I buy?

12 months ago
Benchmark software for Build Guides

In forum Pro Applications

12 months ago
2017 15" Macbook Pro RP560 + RX [email protected] (Mantiz Venus...

In forum External GPU Builds

12 months ago
That's what I've been fearing, and sadly I only have one TB3...

In forum Thunderbolt Windows eGPU

12 months ago
Have you tried using the BootCampDrivers.com drivers? (heh) ...

In forum BootCamp eGPU Setup

12 months ago
It's something I thought, but my MBP works fine with it, no ...

In forum Thunderbolt Windows eGPU

12 months ago
How are you connecting the 5k to your laptop? Through the eG...

In forum BootCamp eGPU Setup

12 months ago
[HELP] TB3 Link dying/restarting: Lenovo T470s + Mantiz Venu...

In forum Thunderbolt Windows eGPU

12 months ago
I got this without a clean install, only removing the RP560 ...

In forum BootCamp eGPU Setup

1 year ago
Black screen after testing hot-plugging? Try a DisplayLink a...

In forum Thunderbolt Windows eGPU

1 year ago
Windows 10 Bootcamp w/ Mantiz Venus MZ-02 + RX580

In forum BootCamp eGPU Setup

1 year ago
I tried the bootcampdrivers.com drivers (ugh) and now it wor...

In forum BootCamp eGPU Setup

1 year ago
@itsage I was trying this yesterday but never got an error 1...

In forum BootCamp eGPU Setup

1 year ago
Sorry, forgot to add that I wanted to do this under Windows ...

In forum BootCamp eGPU Setup

1 year ago
 of  2