troywright
troywright
Group: Registered
Joined: April 10, 2017 7:06 am
Eminent Member
2
The firmware issue can be fixed by uninstalling the Intel Th...

In forum GPU, Monitor & Peripherals

1 year ago
I have similar results. On the left is my CalDigit 2m a...

In forum PSU, Fans & Cables

1 year ago
My Aorus 1080 is plugged into my external 27inch display, wh...

In forum Thunderbolt Enclosures

1 year ago
I have the Aorus 1080 and a 144hz monitor. The manual for ...

In forum Thunderbolt Windows Setup

2 years ago
Wow 10 hours is rough. For me it's about 10-20 seconds. Ma...

In forum Thunderbolt Enclosures

2 years ago
I bought mine a few weeks ago from eBay UK and paid for ship...

In forum Thunderbolt Enclosures

2 years ago
Thanks 🙂 Correct. I now have the Aorus Gaming Box 1080 and ...

In forum Builds

2 years ago
2 small things to add as I also have this laptop. The eGPU w...

In forum Thunderbolt Enclosures

2 years ago
[EU (DE)] FS:€350 ONO PowerColor DevilBox eGPU

In forum For Sale / Wanted

2 years ago
Thanks for your help! Downgrading did the trick. New picture...

In forum Thunderbolt Enclosures

2 years ago
I tried as well with my old XPS15 and I also get the same me...

In forum Thunderbolt Enclosures

2 years ago
NVM20. I wonder if it's the laptop having problems. I'll t...

In forum Thunderbolt Enclosures

2 years ago
New 8th gen intel HP Spectre x360. No idea which controller ...

In forum Thunderbolt Enclosures

2 years ago
I get an error when i try unfortunately.  Also, for t...

In forum Thunderbolt Enclosures

2 years ago
2017 15" HP Spectre x360 MX150 + [email protected] (Powerco...

In forum Builds

2 years ago
The UK is still part of the EU, and it is available in Ger...

In forum Thunderbolt Enclosures

2 years ago
For anyone in Europe (specifically Germany)  it looks like i...

In forum Thunderbolt Enclosures

2 years ago
I currently have a DevilBox but would much prefer a RazerCor...

In forum Thunderbolt Enclosures

2 years ago
Should work fine. Normally if the power supply says 110V - 2...

In forum Thunderbolt Enclosures

2 years ago
good to see you got it up and running eventually! 

In forum Builds

2 years ago