error 12 - 2019 13" MacBook Pro (Win10 20H2) + RTX 3060 Ti (Razer Core X)
 
Notifications
Clear all

error 12 - 2019 13" MacBook Pro (Win10 20H2) + RTX 3060 Ti (Razer Core X)  

  RSS

(@alan_c)
New Member
Joined: 9 months ago
 

Hi all, I recently got a EVGA  rtx 3060ti and I was planning to make an egpu build for bootcamp gaming on my 13" Macbook Pro 2019. But I kept getting stuck on code 12. At the moment, I've only tried hotplugging method +win10 20H2 through all the ports but didn't get any result from it. I've read some of the latest forum saying that nvidia cards are simple plug-and-play but it currently doesn't seem like to me. I'm planning to try the efi method next with either an internal partitioned disk or usb drive. Is there other recommended methods for nvidia egpu bootcamp setups?

Model: 13" macbook pro 2019 (touchbar)

Processor: i7 -8559u 

GPU: EVGA ultra rtx 3060 ti

EGPU enclosure: razer core x

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 6 years ago
 

@alan_c, I have been using my 2019 13-in MacBook Pro with many different versions of Windows 10 and Windows 11. The one utility I use is apple_set_os v0.5 EFI boot loader. Give it a try and see if that helps getting your RTX 3060 Ti eGPU going.

 

LinkedIn | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 Gigabyte Z590i Vision D [11th,6C] + RTX 3060 Ti @ 32Gbps-TB4 (Gigabyte Gaming Box) + Win11 [build link]  


ReplyQuote
(@jahn_reddit)
New Member
Joined: 8 months ago
 

I have the same issue with this same build

 

2019 13” MacBook Pro Touchbar intel i5 8gb Ram 

Running with Asus XG Station Nvidia RTX 3060ti 

Having issues with Code 12 and have tried a few different versions of windows as well as efi boots.

 

Perhaps are there any steps i’ve missed? 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
glaurossi
(@glaurossi)
New Member
Joined: 8 months ago
 

I'm trying to make the Blackmagic eGPU work with the same mac model. In fact, it worked once, then it stopped working, and now it doesn't want to work anymore. I managed to get past error 12, now I'm on error 31 lol (This device is not working properly because Windows cannot load the drivers required for this device.)

What method are you guys trying?

MacBook Pro (13-inch, 2019, Two Thunderbolt 3 ports)
Iris Plus Graphics 645
Blackmagic eGPU (RX580)
Monterey 12.1
Bootcamp Windows 10 21H2
AOC Agon 165hz Monitor
Dell P2214H Monitor


ReplyQuote
SA.Damon
(@sa-damon)
New Member
Joined: 8 months ago
 

As described, I am a user of a late 2019 MacBook Pro User and just recently got myself a eGPU for enhanced gamming and video editing experience. I bought a razer core x chroma with a 3080 Ti founders edition hoping it to work.

Unfortunately, the GPu booted up but it had the error code 12 on it. I've tried the deleting method and manually installing the Nvidia drive; I've also tried the hack flags method as well as some other changing, down grading, and fixing of the system, yet the message just pops up. I really wish if someone could help me and solve for this.

 

Thanks for the help!

Intel Core i9 9th Gen, Radeon Pro 5600m, Razer Chroma X with Nvidia 3080 Ti FE, 32 GB Ram, 2 TB SSD


ReplyQuote
SA.Damon
(@sa-damon)
New Member
Joined: 8 months ago
 

For addition info: My system currently is in 1903, it could recognize my graphics card by providing it as 3080 Ti but the lack of resource was still shown despite the methods attempted. The PCI slot was 1 with 130 threads. Hope this may or may not help in clarifying my situation.

Intel Core i9 9th Gen, Radeon Pro 5600m, Razer Chroma X with Nvidia 3080 Ti FE, 32 GB Ram, 2 TB SSD


ReplyQuote
(@frank_saralegui)
New Member
Joined: 5 months ago
 

@sa-damon, any fix to this. Did you try the DDU method? 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
bootz
(@bootz)
Trusted Member
Joined: 5 years ago
 
Posted by: @glaurossi

I'm trying to make the Blackmagic eGPU work with the same mac model. In fact, it worked once, then it stopped working, and now it doesn't want to work anymore. I managed to get past error 12, now I'm on error 31 lol (This device is not working properly because Windows cannot load the drivers required for this device.)

What method are you guys trying?

This is the exact situation I'm in with the Aorus Gaming Box (1070 model) with a dual mini 3060 Ti! The 1070 worked like a dream for years. I'm wondering if it has something to do with the number of video outputs?

iMac 4k 2015 - 21.5" (iGPU only)
i5-5675R @ 3.10 GHz
8 GB RAM
Aorus Gaming Box 1070 via TB3 > TB2 adapter
...also 1 successful session with 3060 Ti, honest!: /> Windows 10.0.17134


ReplyQuote