[GUIDE] Mac: solving eGPU error 12 in Windows 10
 
Notifications
Clear all

[Solved] [GUIDE] Mac: solving eGPU error 12 in Windows 10  

 of  22
  RSS

Frédéric Robert
(@frederic_robert)
New Member
Joined: 2 months ago
 

Thanks a lot for grouping my post with this one. I went on the bootcampdriver website and installed the latest windows 10 radeon drivers and it all seems to be working now.  Only thing i need to be carefull with is the thunderbolt port i'm using for the egpu. Apprently those are not interchangeable...

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

Mini i5 liked
ReplyQuote
Frédéric Robert
(@frederic_robert)
New Member
Joined: 2 months ago
 

Hi it's me again
I'm still facing a tiny issue (which is a lot less of a bother than the error 12 and if necessary i could live with it xD)
I installed the latest amd bootcamp driver which made it possible to have both the radeon gpu and my nvidia egpu to be recognized by windows and solved the error 12 pb
However if i try to use the amd software i get the following message "The version of AMD Radeon Softawre you have launched is not compatible with your currently installed graphics drivers. Please check your system for other versions of Radeon Software that may currently be installed. A factory reset of your Radeon Software installation is recommended"
As stated before prior to installing the bootcamp amd drivers i was running on the nvidia drivers for the egpu and on standard windows drivers for the system so the bootcamp ones were the first geniun amd drivers i installed meaning there are no other versions of the software and/or drivers running...
If anyone has an idea as to why i have this error and / or how i can get rid of it...
Thanks a lot

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
AstroGreaser
(@astrogreaser)
New Member
Joined: 1 month ago
 

Hi everyone,

I finally managed to get a graphics card to use with my MacBook Pro 16" (2019, base model) and Razer Core X. From reading different posts here and on Reddit, and watching different YouTube videos (although never with the same exact setup) I thought it should be Plug and Play as it seems to be the case for most Nvidia users, but that didn't turn out to be true.

Long story short: I'm getting error 12!

I was expecting all sorts of "minor" problems, from Bluetooth not working to start-up freeze, but not the infamous error 12. Especially since it is mentioned so many times that it is a lot more common with AMD cards which is probably why most guides are for troubleshooting systems with AMD cards (like the suggested HackFlags 0x600 Registry Edit).

What I tried so far:

My first approach was to hot-plug the eGPU in the top right port (PCIe x4) while using the most recent Windows 10 build (21H1) and all recommended updates as of October 27. Even though it played the sound, it didn't give any visual cues of recognizing the graphics card or installing any drivers, not even after waiting for 5 minutes (as recommended in different guides). After installing the most recent Nvidia drivers (496.49) manually, it showed the RTX 3080 in the device manager, but with the yellow badge and error 12. What I tried to solve the problem:

  • restarting without eGPU plugged in and hot-plugging it again
  • restarting with eGPU plugged in (no freeze but still error 12)
  • deactivating and reactivating the eGPU
  • deactivating PCIe x16 (dGPU) and PCIe x8 (left ports)
  • using it on the top left port while deactivating PCIe x16 (dGPU) and PCI x4 (right ports)
  • booting with the modified apple_set_os.efi found here
  • booting while plugged in the left port, then switching to the right port and vice versa

After all these attempts failed, I installed the recommended Windows 10 (19H1, V1) from TechBench and deactivated automatic updates. When hot-plugging the eGPU again it did recognize it and installed the drivers, but after the mandatory restart still showed error 12. Manually installing the most recent Nvidia drivers and deactivating PCIe controllers didn't solve the issue.

I know every case is different, but there are just too many guides, some of which are outdated while others don't mention the 16" model or are specifically for AMD cards. Am I missing something? At this point, it seems more feasible to get an AMD eGPU to work due to the many available workarounds, custom drivers, etc.

Has anyone experienced similar issues, ideally with a similar build? Any help is appreciated!

Laptop: MacBook Pro 16" (2019 - Intel Core i7, 16GB Memory, Radeon Pro 5300M)
eGPU: Razer Core X + GeForce RTX 3080 (Gigabyte VISION)


ReplyQuote
Juan Garzon
(@juan_garzon)
New Member
Joined: 1 month ago
 

HI, everyone....

I will appreciated if someone knows how to fix "no audio output device is installed" in mac book pro 2012 high sierra with windows 10 already installed ,I tried this solution for error 12 but did not work, because in my situation show me code 10 ,also I installed all the updates of bootcamp ,but still the same diagnostic ,more over trying to connect an external display through the firewire ,do not works ,when I am in mac os platform works but in windows nothing happens...any help or guide will be appreciated ...thanks Crying  

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 5 years ago
 

@juan_garzon,  pls see audio fix at https://egpu.io/forums/builds/2016-MacBook-13-tb-akitio-thunder3-evga-gtx-1060-6gb/#post-2614

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M.2 (ADT-Link R43SG) + Win10 1803 // compares M.2 vs TB3 performance inc unoptimized H-CPU BIOS [build link]  


ReplyQuote
Juan Garzon
(@juan_garzon)
New Member
Joined: 1 month ago
 

@nando4, Thanks..to  your tip I fixed the audio ...do you know how to fix the firewire connection in a MacBook pro 2011 with windows 10 ,to connect an external display...? in mac works but in windows nothing...however thanks for your help... Cool  

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Daler Fatykhov
(@daler_fatykhov)
New Member
Joined: 1 month ago
 

@astrogreaser, same prob but on 3060 with aorus gaming box, please help anyone.

how to resolve code 12 issue?

 

mpb 16 2019 + aorus gaming box GTX 3060 (not working setup)


ReplyQuote
rolandoblomblando
(@rolandoblomblando)
Active Member
Joined: 1 month ago
 

@astrogreaser, I am having similar issues and also tried pretty much everything too, it's so frustrating. I was considering doing a reinstall to windows 10 1903 v1 like you mentioned. The fact that it didn't work for you makes me doubt it will work for me. I have a 2020 iMac with i5 3.3ghz Pro 5300 and I have been trying to get a 3060 ti to work in a Razer Core X. I can't even believe how much of a disaster it's been. 

I would also like to echo your sentiment about there being too many guides and it being very hard to sift through what might be relevant to me or not. Sometimes I spent an hour or more on a particular intervention only to find that it was outdated or not relevant to my situation.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
rolandoblomblando
(@rolandoblomblando)
Active Member
Joined: 1 month ago
 

@edwardblake, After reading quite a bit on these forums, it is starting to become clear to me that some Nvidia RTX gpu might have issues in some cases with the most recent iMacs over Boot Camp. Furthermore, I feel like this is really not addressed in any formal way here on egpu.io, perhaps understandably so as it seems that most people are able to use Nvidia RTX cards without issue. I don't know if it's something specific to certain card models or maybe something specific to certain Mac models, but there is definitely something going on here...

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Dima Novosad
(@dima_novosad)
Active Member
Joined: 3 weeks ago
 

Hello guys, I am trying to get 6800XT working on Windows. I just got it working on Mac with a simple OS update. How can I get it to work on Windows 10 Pro? I see it in the device manger but it's throwing Code 12 at me. I tried to follow few guides on here but I have to say people don't know how to write them at all. It's like oh yea I got it working and here is a link to another post and then to anther and it never ends! You never know what they did in the first place to get it to work at all. Absolutely bonkers!

Anyways, I tried disabling those PCI Root devices whatever it's not working still code 12. I disabled 5500m and tried running without it and it just goes over to integrated graphics. My next attempt tomorrow will be to install automate-eGPU EFI. I don't have a flash drive so waiting for that. Does anyone here has the same 2019 macbook pro and was able to get anything working in Bootcamp? if you did I need to know how you did it exactly without having me redirected. Please don't reply here if you don't know what you are talking about! I am going to get it working one way or another.

Thanks!

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 6800 XT @ 32Gbps-TB3 (Razer Core X Chroma) + Win10 1903V1 [build link]  

ReplyQuote
 of  22