[GUIDE] MacBook Pro: solving eGPU error 12 in Windows 10
 

[Solved] [GUIDE] MacBook Pro: solving eGPU error 12 in Windows 10  

 of  4
  RSS

(@wesbeyrent)
New Member
Joined: 4 months ago
 

I'm running a mid-2014 MacBook Pro (Intel Iris only iGPU).  I have only been able to avoid Error 12 by running Windows 10 build 1511.

Is there any way I can run a newer build without Error 12?  I've done everything recommended in this forum including buying and running nando's DIY eGPU Setup 1.35, but I get the "can't install on a GPT formatted drive" problem, so I gave up on that route.

EDIT: I reinstalled Windows using build 1607 and everything is still working. Even better, actually! I can finally stream VR to my Oculus Quest now. 

This post was modified 4 months ago

Mid-2014 MacBookPro11,2 w/Intel Iris iGPU only (ugh)
Sonnet Breakaway 550 with XFX Radeon RX 580
Bootcamp Windows 10 v1607


ReplyQuote
(@charles_lee_1)
Active Member
Joined: 4 months ago
 

Sorry I know this topic comes up quite a lot but for my set up I just can't get the eGPU to work in Bootcamp.  I tried all the methods stated in these guides but the closest I've ever go to is having Windows finally recognising my eGPU, only to have the dreaded error 12 persisting here no matter what PCIe controller I disable or trying different TB3 ports.  Can the lords of eGPU (i.e. the great members who contribute to this forum) help this noob out?

 

P.S. I know it's a stretch but is this new card a bit too challenging to be supported now since I hardly see anyone using it?  Also will macOS 10.15.1 help out since I should be able to use it in macOS then?

2018 15″ MacBook Pro i9-8950HK/Radeon Pro 560X dGPU/32GB RAM/2TB SSD; Radeon RX 5700XT & Razer Core X


ReplyQuote
Zucca
(@zucca)
New Member
Joined: 4 months ago
 

HI!

I ahve an iMac 2018 with an egpu vega 64 setup. I isntalled the Windows to an external ssd and I booted the Windows. I installed every drivers with the boot camp assistant and also donwloaded and isntalled the newest driver for the vega 64. When I try to reboot the OS with the vega 64 (hdmi from teh card) after the windwos logo I see only black screen. In the device Manager it says error 12 It has not enoguht free power or something (hard to translate from Hungary).

I read some topics from ehre but all was so difficult and I dont't rly understand them.. maybe any video or an easy step by steap method to fix the problem? 

Thanks guys!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@kaleb_kemp)
New Member
Joined: 6 months ago
 

Hello there, I’ve explored these forums and found different guides to solve code 12 on Macs, but I’m having trouble finding the guide to solve it for my 2018 13” MacBook Pro today, I know I’ve found it before, but can’t seem to find it today and it seems that each model has slightly different solutions so I want to be sure I’m doing right. Help would be appreciated as I’m in desperate need of it to get a Vega 64 working in Bootcamp. Previous graphic cards I’ve been able to live with not having my internal display working by leaving the eGPU plugged in at boot, but now my Vega 64 isn’t powering my external display at boot so I’m left with a pretty expensive paperweight that works fine in other computers (my dad tried it in his desktop and it works great) and under macOS but not Windows. Any help would be appreciated!

MacBook Pro 2018 13” w/Touch Bar, Core i7, 16GB RAM, 1TB SSD
RAZER Core X
Radeon RX Vega 64


ReplyQuote
(@103736254)
Active Member
Joined: 2 months ago
 

I’m having trouble finding the guide to solve it for my 2018 13”  MacBook Pro ,I have tried all kinds of  solutions ,failed to fix Error 12. 

Any help would be appreciated!

Pending: MBP 2018 13'inch 8g 512GB,(Sapphire)RX 5700XT 8G ,Razer Core X


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 1 year ago
 

I have made a clean bootcamp installation, on external ssd, Windows 10 , 1909.

Windows has various updates ready to download and card has not been connected yet. 

2020-01 windows update is ready (KB4528760)

Apple Media 6.1.7100.0

Apple System 6.1.7500.5

Window .net Framework 3.5 4.8

Please post your recommendation of the best steps to follow in order to avoid error 12

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Test1
(@test1)
Active Member
Joined: 11 months ago
 

@tsakal

I read your post on a different thread (the one with update 18362.329). I assume it's regarding your (A) build?

Right now, it seems that the only stable windows version for an eGPU setup with your type of card is downgrading to windows 1903, ver 18362.295). Theres a lot of posts on how to downgrade to that version in that thread if you don't know how, and it's very important that you disable all types of automatic updates. Sometimes windows won't allow disabling these in the "windows update center". So you will have to go through the "gpedit" way. After you have done that, I suggest that you follow any detailed guide with a RX5700 in the build section. I usually have a lot of success following the guides by @itsage .

Edit: I just did a quick search on the builds section and found two builds with a MBP 13" and RX5700 XT. Although not the same case or MBP iteration (the second one). I'm sure it will work for your current setup. The second one is a bit more detailed than the first one (in case you need more details).

MBP 13" 2018 + RX5700 XT + Mantiz. https://egpu.io/forums/builds/2018-13-macbook-pro-8th4cu-rx-5700-xt-32gbps-tb3-mantiz-venus-macos-10-14-6-win10-1903-badtz/

MBP 13" 2017 + RX5700 XT + Mantiz. https://egpu.io/forums/builds/2017-13-macbook-pro-7th2cu-rx-5700-xt-32gbps-tb3-mantiz-venus-macos-10-15-1-win10-1903-itsage/

Have a great day!

This post was modified 3 days ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 1 year ago
 

@test1

Thank you very much for that. 

yea it is for my A build. 

i have set up a new ssd with w10 1903 v1 Version. Initially could not get the gpu recognised. 
Now I can see the card but have the errror 12. i ll try disabling a pci port next.

i have tried the 1803 downgrades to summer update. I tried full 1909 with full 2020 updates as well as downgrade to original release. I tried 1903 with both full updates and downgrading to .295. That is why I think my next step will be the pci solution

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
 of  4