2019 16" MBP + Razer Core X + Kepler-Based nVidia GTX Titan Black = Head Scratch...
 
Notifications
Clear all

2019 16" MBP + Razer Core X + Kepler-Based nVidia GTX Titan Black = Head Scratching  

  RSS

network_noob534
(@network_noob534)
Active Member
Joined: 4 months ago
 

GPU and enclosure work great in Bootcamp! In macOS Catalina 10.5.4 however, nothing occurs. I have tried the troubleshooting guides for unplugging. I have tried purge-wrangler and some other various scripts to force the usage of an nVidia GPU using built-in drivers for Kepler devices. 

Nothing. 

I'm scratching my head, and have tried so many things that I'm at a loss. Does anyone have a quick and dirty way to get a Kepler-based supported nVidia GPU working in a Thunderbolt 3 enclosure, on a Mac that natively supports eGPUs, with an nVidia card that supports Catalina?

I have been going nuts -- I have the following setup:

  1. When I use Purge-Wrangler and reboot; the system freezes on the Apple Logo. The system fans then spin up fast and the machine shuts down. 
  2. If I boot without the eGPU plugged in, then plug in at login screen, the eGPU is detected and it "pretends" the login screen is being output to the monitor, but it is only a black display on the external monitor (using HDMI AND DisplayPort)
  3. If I boot, login, plug in eGPU, the system freezes, then reboots about 50% of the time. The other 50% of the time, its fine. I then Go to "About this Mac" and see the Nvidia GTX Titan Black is listed as a GPU, but am unable to use it to output to another display. 

I have tried the command pmset -a gpuswitch 0 command, which seems to be input correctly... but nothing happens. I'm at a loss. 

This topic was modified 4 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
network_noob534
(@network_noob534)
Active Member
Joined: 4 months ago
 

@datahawk, I have an RX 5700 XT which works fine on the Mac side, but throws Error 12 on the Windows end; even after downgrading to the version of Windows suggested. 

 

What do you mean that "this isn't supposed on the Mac side" -- my understanding from reading around here and Reddit is that Catalina has support for Kepler Cards (AKA most GTX 600 and GTX 700 cards due to systems having those dGPUs). 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Datahawk
(@datahawk)
Active Member
Joined: 4 months ago
 

Your post says you have an NVIDIA card, not an AMD

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
network_noob534
(@network_noob534)
Active Member
Joined: 4 months ago
 
Posted by: @datahawk

Your post says you have an NVIDIA card, not an AMD

That’s correct. The issue I’m having is getting the NVidia card to work on the Mac side. 

I already did try AMD, but that only works in macOS and not Windows - so now I got the nVidia card to hopefully have it work in both, and am sadly let down. 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Florin Samareanu
(@florin_samareanu)
Eminent Member
Joined: 9 months ago
 

@network_noob534, are you sure that Titan black has MacOS drivers? The web drivers don’t work on 10.15. 

 

16'' Macbook Pro - Razer Core X Chroma - PowerColor Red Devil 5700XT - LG 27UK850


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago

ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

@florin_samareanu, Titan Black uses Kepler architecture which has macOS drivers even in Catalina
https://en.wikipedia.org/wiki/GeForce_700_series

I'm using a GTX 680 which is also Kepler
https://en.wikipedia.org/wiki/GeForce_600_series

 

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

For GTX 680, I'm using Dual Link DVI because I have an old Apple 30" Cinema display. I think the DisplayPort output does not work in Catalina. Maybe WhateverGreen + Lilu has an option to fix this?
https://github.com/acidanthera/WhateverGreen
Maybe one of the agdpmod options?

 

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 
Posted by: @joevt

Maybe WhateverGreen + Lilu has an option to fix this?

Could be - haven't tried.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
network_noob534
(@network_noob534)
Active Member
Joined: 4 months ago
 
Posted by: @mac_editor

@network_noob534, https://github.com/mayankk2308/purge-wrangler/issues/48

 

Thank you! Though I guess my issue is more "intense" -- DisplayPort doesn't work, period. But then I tried HDMI which resulted in a black screen... and being able to drag my cursor over... but nothing else. Gadzooks. 

I guess I will need to do more troubleshooting for now!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote