2020 MacBook Pro 13" Ice Lake CPU Boot Camp eGPU Setup/Troubleshooting
 
Notifications
Clear all

2020 MacBook Pro 13" Ice Lake CPU Boot Camp eGPU Setup/Troubleshooting  

 of  28
  RSS

Berkan
(@berkan)
Active Member
Joined: 4 months ago
 

@fabianring Thanks, I appreciate your effort. I followed your guide again step by step, however unfortunately I am still stuck at error 12.

@andygev35 I see thanks, could you tell me which AMD drivers you used when you switched to the 5700 XT?

@pabek I will let you know if I get it working.

 

2020 Macbook Pro 13'' with 8th Gen Coffee Lake CPU + Razer Core X + AMD RX 5700 XT


ReplyQuote
fabianring
(@fabianring)
Active Member
Joined: 3 months ago
 

@berkan

when do u get error 12? are you 100% sure you got the right windows version and it never updated?
because I only saw error 12 after updating windows wrongly or using the wrong iso.

 

2020 MacbookPro 13"
Razer Core X Chrome
AMD RX 5700

working with flaws


ReplyQuote
andygev35
(@andygev35)
Estimable Member
Joined: 4 months ago
 
Posted by: @berkan

could you tell me which AMD drivers you used when you switched to the 5700 XT ?

I’m using the latest official AMD Adrenalin Recommended version (20.4.2)

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
Berkan
(@berkan)
Active Member
Joined: 4 months ago
 
Posted by: @fabianring

@berkan

when do u get error 12? are you 100% sure you got the right windows version and it never updated?
because I only saw error 12 after updating windows wrongly or using the wrong iso.

 

I am pretty sure I have the correct version. Here are my current Windows specifications:

image

@andygev35 Okay thanks, I have tried that already. 

2020 Macbook Pro 13'' with 8th Gen Coffee Lake CPU + Razer Core X + AMD RX 5700 XT


ReplyQuote
Snoek
(@snoek)
Active Member
Joined: 1 year ago
 

@andygev35, Hi,

Have you definitely disabled all the Apple Boot security by holding down COMMAND-R and then (I think) Utilities - Startup security? I only ask because I hadn't done this and it magically made all the difference.

I have to admit that I have actually given up, I really wanted an RTX and couldn't get that to work (although the 5700 XT did) so I have just gone crazy and building a high spec PC for gaming.

 

MacBook Pro 13” 2020 (2.3 GHz Intel Core i7, 32GB 3733 MHz LPDDR4 &amp Intel Iris Plus Graphics 1536MB)
MacBook Pro 13" 2018 (2.7 GHz Intel Core i7, 16 GB 2133 MHz LPDDR3 & Intel Iris Plus Graphics 655 1536 MB)
-Sonnet eGFX Breakaway Box 650 with Asus RX Vega 64 ROG STRIX OC
-HTC Vive


ReplyQuote
ravarro
(@ravarro)
New Member
Joined: 2 months ago
 

@fabianring,

 

Hi, I am completely new to eGPU and I have decided to try out your steps as I have the exact same model as yours but I have 8GB of ram. So far nothing has worked so far and I am still getting the error 12 code right after installing the AMD drivers from 'bootcampdrivers'. I have also done another clean install and this time, I am getting an error 207 while installing the Adrenalin drivers while also getting the error 12.

 

My eGPU setup: Razer Core X + Sapphire Nitro+ Radeon RX 580

 

I also decided to test out my GTX 1070 from my main gaming rig and it just freezes the whole MacBook when hot-plugging the eGPU.

 

 

 

 

This post was modified 2 months ago

2020 13" MacBook Pro (base model 8th gen i5/8/256) + Razer Core X paired with Sapphire Nitro+ Radeon RX 580
(which I couldn’t get working)
Gaming PC (Ryzen 5 3600, 16GB 3600MHz DDR4, GTX 1070, 512GB NVMe, 1TB HDD)


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@andygev35, I had the issue of the pci.sys file being replaced by windows. I ended up removing the permission given to trusted installer and system for this file. I have rebooted a couple of time till now and it just stays the same.

 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
andygev35
(@andygev35)
Estimable Member
Joined: 4 months ago
 
Posted by: @tsakal

I ended up removing the permission given to trusted installer and system for this file. I have rebooted a couple of time till now and it just stays the same.

Very interesting.  It makes perfect sense.

2020 MacBook Pro, i5-1038NG7, 16GB RAM, 1TB
Razer Core X
Sapphire Pulse RX 5700 XT Dual BIOS

 
2020 13" MacBook Pro [10th,4C,G] + RX Vega 56 @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@andygev35, @itsage, on your win10 2004 set are both screens working?

 

This post was modified 1 month ago

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
cbroeg
(@cbroeg)
Active Member
Joined: 1 month ago
 

Hi

I wanted to comment my experiences. Thank you all for this great pool of information!

My previous MacBookPro 2017 (see signature) was running ok on 1903 and 2004-DEV but only using automate-efi. Without automate-efi windows crashes on boot. 

This is to relate my tries with the new 2020 13-inch MacBookPro.

1st try:

I installed Windows 2004 insider DEV with all the updates. Did the full DDU in safe mode 3 times (NVIDA, AMD, AMD reboot). Tried disabling PCI root part 1-3 plus FaceTime camera. Hot/cold plugging. Tried port dance.  I always got Error 12 (error 207 after AMD driver install). I take note that I never tried DDU on audio drivers. This I only read later. Side note: I could not disable the internal graphics card as recommended by several people. Windows would freeze immediately and I had to force reboot. 

I also tried to replace pci.sys with the driver from 1903. No success. If windows update was on pci.sys was immediately replaced to the new version and Error 12. If I disabled windows update in policy editor windows refused to boot and went into repair mode.

After trying a few days without success I trashed bootcamp and started over with the recommended 1903 windows.  

 @andygev35: Thanks a lot. I followed your prescription and it worked. There are minor differences however:

  • I allowed security updates after fresh install before disabling all updates
  • after AMD driver install I get error 207 and in device manager Error 12. After rebooting everything is fine, though!
  • I cannot re-enable any of the PCI root ports. As soon as I do I get Error 12 again
  • The good thing: disabling PCI Root 1-3 again and rebooting fixes the problem again
  • Hot plugging does not work. Error 12. 

Any ideas what I am doing differently?

Performance is great. Much better than on my 2017 MBP. I am mostly using it for CS:GO, though. Now I get >120 FPS continuously at 2K resolution all settings maxed. I think it is due to the faster CPU.  Did not compare benchmarks yet. 

Kind regards,

Chris 

MacBook Pro 13" 2020, 2TB SSD, 32 GB RAM, 2.3 GHz i7 quad core, 4TB ports, Razer Core X, Sapphire radeon RX 5700 XT
old config: MacBook Pro 13" 2017, 1TB SSD, 16 GB ram, 3.5 GHz i7 dual core, same eGPU


ReplyQuote
 of  28