2018 13" MacBook Pro + 5700 XT - Code 43
 
Notifications

2018 13" MacBook Pro + 5700 XT - Code 43  

  RSS

Alec
 Alec
(@alec)
Trusted Member
Joined: 3 years ago
 

I finally beat code 12 on my MacBook Pro 13" 2018, but now I'm getting a new error from hell with pretty much no documentation on this forum. Anyone have ideas? Don't suggest driver reinstallation because I've already done that too many times.

I really wish these multi-billion corporations would stop screwing over their customers. First we have Apple going after Nvidia and now Windows going after AMD. I miss the days when companies would put innovation first and profits second...

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Phoenix2063
(@phoenix2063)
Eminent Member
Joined: 2 years ago
 

I use a 5700xt with my 13" MacBook Pro 2018 model, no issues just plug and play on OSX. Are you getting this error in Windows bootcamp or OSX? 

Nvidia want full control over their drivers if Apple were to use them over AMD is my understanding of the dispute. 

Mantiz Venus MZ-02
- Gigabyte AMD RX 5700 XT


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 3 years ago
 
Posted by: @phoenix2063

I use a 5700xt with my 13" MacBook Pro 2018 model, no issues just plug and play on OSX. Are you getting this error in Windows bootcamp or OSX? 

Nvidia want full control over their drivers if Apple were to use them over AMD is my understanding of the dispute. 

Bootcamp. The whole dispute is petty and childish, but that's what large corporations have become.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Have you tried reinstalling drivers?

nah I’m kidding. 

I assume all is working fine in macOS? Error 43 is usually driver or power related but I think it’s also quite a generic error message which doesn’t really help. 

I had the same issue with one of my 5700xt’s after it working just fine for a day so sent it back. 

Not much help for you I’m afraid. 

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 3 years ago
 
Posted by: @eightarmedpet

Have you tried reinstalling drivers?

nah I’m kidding. 

I assume all is working fine in macOS? Error 43 is usually driver or power related but I think it’s also quite a generic error message which doesn’t really help. 

I had the same issue with one of my 5700xt’s after it working just fine for a day so sent it back. 

Not much help for you I’m afraid. 

It works fine in MacOS. 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 1 year ago
 

I experienced this error 43 with my MBp 13 2018 and AGB rx580. Unfortunately, the only way for me to fix it was by installing a fresh clean install of bootcamp. 

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 1 year ago
 

@badtz

which windows and Mac OS versions do you refer to ? 

 

Best

which one did you use for the fresh install ?

This post was modified 1 month ago

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 1 year ago
 

At that time I was on windows 1809, Macos Mojave 10.14.1 (never update to Catalina). However, Windows version 1903 18362.30 - 295 should work well.

Windows ISO link here

Update 1903-18362.295 here

This post was modified 1 month ago

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 1 year ago
 

@badtz

Are you now in Catalina ? 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 3 years ago
 
Posted by: @badtz

I experienced this error 43 with my MBp 13 2018 and AGB rx580. Unfortunately, the only way for me to fix it was by installing a fresh clean install of bootcamp. 

I already did that. 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 1 year ago
 

@alec

I think that he is still in Mojave. 

With Catalina it is 50-50 that it woks. 

1. I have tried a new install with 1909 no success 

2. new install with 1903 v1 and custom update to .295 no success

3. existing install of 1803 fully updated no success 

4. 1803 install downgraded to .295 equivalent no success. 

All the above done with ext ssd

I am now with the two install in different ssd's No2 and No4. I have managed to get the drivers install and the card recognized but have error 12 in both. 

Nest I will try to connect the mbp through usb c to my lg 1080 monitor while connecting the egpu instead fo using a usbc HDMI adapter for connecting to my 4k monitor.  

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 1 year ago
 

I'm still on Mojave 10.14.6. Have never updated to Catalina, Windows 1903-18362.295

Just updated my AMD to version 20.1.2. Here's my setup:

1. Windows 1903 18362.295

2. DDU 3 times

3. Disable PCIE Root port#3 -9DBA (not sure if this is necessary but thats what I did), connect egpu in my case Mantiz Venus/Red Devil 5700XT, installed AMD version 20.1.2 here

4. Under device manager it showed error 43. Click Finish on AMD installer (not restart). Then shutdown.

5. Disconnect egpu. Power cycle egpu (2 mins). Its like cooking 😛 

6. Turn on Macbook (PCIE Root port#3 -9DBA still disable). Turn on egpu. Wait till everything finish loading. Then connect.

7. Voila

8. Re-enable PCIE Root port#3 (next reboot you dont need to disable this). It works hot plugged

 

@tsakal

try installing bootcamp internally

This post was modified 1 month ago

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 1 year ago
 

@badtz

I prefer not to. 

i ll give it another try next week 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 3 years ago
 

Looks like I'll be going with a 2080 ti for Windows gaming... 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote