2018 13" MacBook Pro + 5700 XT - Code 43
 
Notifications
Clear all

2018 13" MacBook Pro + 5700 XT - Code 43  

 of  2
  RSS

Alec
 Alec
(@alec)
Trusted Member
Joined: 4 years ago
 

I finally beat code 12 on my MacBook Pro 13" 2018, but now I'm getting a new error from hell with pretty much no documentation on this forum. Anyone have ideas? Don't suggest driver reinstallation because I've already done that too many times.

I really wish these multi-billion corporations would stop screwing over their customers. First we have Apple going after Nvidia and now Windows going after AMD. I miss the days when companies would put innovation first and profits second...

2016 15" MacBook Pro (RP450) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (Razer Core) + Win10 [build link]  

ReplyQuote
Phoenix2063
(@phoenix2063)
Eminent Member
Joined: 2 years ago
 

I use a 5700xt with my 13" MacBook Pro 2018 model, no issues just plug and play on OSX. Are you getting this error in Windows bootcamp or OSX? 

Nvidia want full control over their drivers if Apple were to use them over AMD is my understanding of the dispute. 

Mantiz Venus MZ-02
- Gigabyte AMD RX 5700 XT

 
2018 13" MacBook Pro [8th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15 [build link]  


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 4 years ago
 
Posted by: @phoenix2063

I use a 5700xt with my 13" MacBook Pro 2018 model, no issues just plug and play on OSX. Are you getting this error in Windows bootcamp or OSX? 

Nvidia want full control over their drivers if Apple were to use them over AMD is my understanding of the dispute. 

Bootcamp. The whole dispute is petty and childish, but that's what large corporations have become.

2016 15" MacBook Pro (RP450) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (Razer Core) + Win10 [build link]  

ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

Have you tried reinstalling drivers?

nah I’m kidding. 

I assume all is working fine in macOS? Error 43 is usually driver or power related but I think it’s also quite a generic error message which doesn’t really help. 

I had the same issue with one of my 5700xt’s after it working just fine for a day so sent it back. 

Not much help for you I’m afraid. 

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 4 years ago
 
Posted by: @eightarmedpet

Have you tried reinstalling drivers?

nah I’m kidding. 

I assume all is working fine in macOS? Error 43 is usually driver or power related but I think it’s also quite a generic error message which doesn’t really help. 

I had the same issue with one of my 5700xt’s after it working just fine for a day so sent it back. 

Not much help for you I’m afraid. 

It works fine in MacOS. 

2016 15" MacBook Pro (RP450) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (Razer Core) + Win10 [build link]  

ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 2 years ago
 

I experienced this error 43 with my MBp 13 2018 and AGB rx580. Unfortunately, the only way for me to fix it was by installing a fresh clean install of bootcamp. 

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT

 
2018 13" MacBook Pro [8th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + Win10 1903 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@badtz

which windows and Mac OS versions do you refer to ? 

 

Best

which one did you use for the fresh install ?

This post was modified 9 months ago

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 2 years ago
 

At that time I was on windows 1809, Macos Mojave 10.14.1 (never update to Catalina). However, Windows version 1903 18362.30 - 295 should work well.

Windows ISO link here

Update 1903-18362.295 here

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT

 
2018 13" MacBook Pro [8th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + Win10 1903 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@badtz

Are you now in Catalina ? 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 4 years ago
 
Posted by: @badtz

I experienced this error 43 with my MBp 13 2018 and AGB rx580. Unfortunately, the only way for me to fix it was by installing a fresh clean install of bootcamp. 

I already did that. 

2016 15" MacBook Pro (RP450) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (Razer Core) + Win10 [build link]  

ReplyQuote
 of  2