2018 13" MacBook Pro + 5700 XT - Code 43
 
Notifications
Clear all

2018 13" MacBook Pro + 5700 XT - Code 43  

 of  2
  RSS

tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@alec

I think that he is still in Mojave. 

With Catalina it is 50-50 that it woks. 

1. I have tried a new install with 1909 no success 

2. new install with 1903 v1 and custom update to .295 no success

3. existing install of 1803 fully updated no success 

4. 1803 install downgraded to .295 equivalent no success. 

All the above done with ext ssd

I am now with the two install in different ssd's No2 and No4. I have managed to get the drivers install and the card recognized but have error 12 in both. 

Nest I will try to connect the mbp through usb c to my lg 1080 monitor while connecting the egpu instead fo using a usbc HDMI adapter for connecting to my 4k monitor.  

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Jimmy
(@badtz)
Eminent Member
Joined: 2 years ago
 

I'm still on Mojave 10.14.6. Have never updated to Catalina, Windows 1903-18362.295

Just updated my AMD to version 20.1.2. Here's my setup:

1. Windows 1903 18362.295

2. DDU 3 times

3. Disable PCIE Root port#3 -9DBA (not sure if this is necessary but thats what I did), connect egpu in my case Mantiz Venus/Red Devil 5700XT, installed AMD version 20.1.2 here

4. Under device manager it showed error 43. Click Finish on AMD installer (not restart). Then shutdown.

5. Disconnect egpu. Power cycle egpu (2 mins). Its like cooking 😛 

6. Turn on Macbook (PCIE Root port#3 -9DBA still disable). Turn on egpu. Wait till everything finish loading. Then connect.

7. Voila

8. Re-enable PCIE Root port#3 (next reboot you dont need to disable this). It works hot plugged

 

@tsakal

try installing bootcamp internally

MBP 2018 13" i5 512GB Touch Bar (MR9R2)
Aorus Gaming Box RX580
Mantiz Venus, Red Devil 5700XT

 
2018 13" MacBook Pro [8th,4C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + Win10 1903 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@badtz

I prefer not to. 

i ll give it another try next week 

A) 2020 MacBook Pro, i7-1038NG7, 32GB RAM, 1TB, EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, Samsung 65 Q70R
Mac OS Catalina 10.15.5, Internal Bootcamp Windows 10 2004 pci.sys swap.
B) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

C) 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

D) 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Alec
 Alec
(@alec)
Trusted Member
Joined: 4 years ago
 

Looks like I'll be going with a 2080 ti for Windows gaming... 

2016 15" MacBook Pro (RP450) [6th,4C,H] + GTX 1080 @ 32Gbps-TB3 (Razer Core) + Win10 [build link]  

ReplyQuote
 of  2