Apple's USB-C to USB-A adapter causes graphics driver bluescreen in bootcamp
 
Notifications
Clear all

Apple's USB-C to USB-A adapter causes graphics driver bluescreen in bootcamp  

  RSS

Smackintosh
(@smackintosh)
Active Member
Joined: 4 years ago
 

A word of caution for macbook pro owners trying to get their eGPUs working.  I had a hard time trying get get Win10 stable when using an Aorus 1070 Gaming Box working with my 13" 2016 MBP TB. The external monitor would work, but after 20 seconds or so, I'd get a blue screen with garbled white lines, and would have to reboot. I tried multiple win10 versions.  The creators edition was the worst.

Turns out, it's apple's own USB-C to USB-A adapter (A1632) that was causing the NVIDIA driver to crash!  I was unwittingly using it with an external keyboard for setup.  It was hard to pin down because in some win10 versions, the driver would crash to blue screen, or sometimes it would recover.  If it recovers, I get an info box saying the NVIDIA driver has crashed but recovered. I don't understand why this is the case. 

I can have everything working with the eGPU happily doing it's thing, then plug in the adapter only (nothing attached) and I get a blue screen.  I do not have this behavior with any other adapter.   It's odd that an adapter can take down a graphics driver, but there it is.  There was another post that described the same type of blue screen but I can't find it.  I'd be curious to know if others have seen this issue or not.

A1632 adapter
2016 13" MacBook Pro [6th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box) + macOS 10.13 & Win10 // GTX 1060 dGPU vs GTX1080 eGPU [build link]  

ReplyQuote
Smackintosh
(@smackintosh)
Active Member
Joined: 4 years ago
 

Actually, now I'm not sure I can't point to that adapter specifically.  I plugged in an external SSD to the same side as the eGPU thunderbolt cable, and it did the same thing.  I think it is a pcie resource allocation problem.  I don't have the error 12, but perhaps I am on the edge of it.  I have disabled the facetime camera, maybe that will help. the 2016 13" macbook pro seems particularly vulnerable to this if I understand the issue correctly.

2016 13" MacBook Pro [6th,2C,U] + GTX 1070 @ 32Gbps-TB3 (AORUS Gaming Box) + macOS 10.13 & Win10 // GTX 1060 dGPU vs GTX1080 eGPU [build link]  

ReplyQuote
Chippy McChipset
(@chippy-mcchipset)
Reputable Member
Joined: 4 years ago
 

Your second theory is on the right track. You were using a MBP13,2 and the right-side ports? There is a known limitation that is likely the cause of your issue:

https://support.apple.com/en-us/HT207256

(Third section down, second bullet... "Always plug higher-performance devices into the left-hand ports on MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports) for maximum data throughput.")

 

Although when using Boot Camp / Windows that always adds an extra element of fun as device compatibility can be an issue. Not sure if that adapter is compatible with Boot Camp / Windows or not. 

Bring peace to your computing life: stop trying to understand Apple.


ReplyQuote
Arthy
(@arthy)
Eminent Member
Joined: 3 years ago
 

I'm having exactly the same issue on that adapter, but with an optical mouse. I'll try with a hub but I think I'll have the same problem. The MBP seems to not support other TB3 devices on top of the eGPU.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
detunedradios
(@detunedradios)
Trusted Member
Joined: 3 years ago
 

I use this adapter to connect a USB hub with a hard drive, mouse, and keyboard with no issues in Boot Camp. I am using an AMD card and a 2016 15" Pro, though.

2016 15" MacBook Pro - 2.7GHz Core i7, Radeon Pro 460 4GB, 1TB SSD
Sonnet Breakaway Box 350, modded with 650W PSU, with Radeon RX Vega 64


ReplyQuote
Shivam Sinha
(@shivam_sinha)
New Member
Joined: 3 years ago
 

Hey! Thanks for post.

I'm facing a similar issue now, where I can't connect any of my peripherals because any adapter I connect will crash the setup.

Did you ever figure out a workaround/fix for this? I also tried using my Hyperdrive adapter I own and that was also crashing my bootcamp. The only thing I can do right now is use the Aorus Game Box's (GTX 1080) included USB hub, but that's facing bandwidth issues and therefore I'm getting keyboard and mouse lag. 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote