[Bootcamp & Aorus GB 1080] Can't connect any peripherals!
 
Notifications
Clear all

[Bootcamp & Aorus GB 1080] Can't connect any peripherals!  

  RSS

Shivam Sinha
(@shivam_sinha)
New Member
Joined: 3 years ago
 

So I got my Aorus Gaming Box with GTX 1080 today and at first, I had plenty of challenges in getting it to work.

The first problem I realized was that the DP cable I bought was a dud so no output was going to the monitor, so I switched that out with a spare HDMI cable I had, still no dice. So in a online post I found, someone say to disconnect all peripherals. I had my monitor's USB hub connected via Apple's own USB-C to USB-A adapter. Disconnected that, restarted with the eGPU still plugged and everything works like a charm. If it weren't for these two issues, my setup was essentially plug n play (with the added step of connecting the eGPU from a cold boot).

Only problem is that I need to connect my keyboard and mouse to do basically anything. So no adapter I have (Apple or the Hyperdrive one I own) works. I tried the Gaming Box's own USB and things works for a little bit before I realized that the mouse keeps loosing connection. The RGB lights still work and everything but no input is taken. So I'm basically at this point where I can't connect any peripherals with my current setup. I also tried the USB power disable thing but that doesn't work either.

Anyone with a similar setup have any workarounds/fixes?

Setup:

Auros GB GTX 1080 to Dell Ultrasharp (via HDMI)

Macbook Pro 15" 2016 (via Bootcamp)

Peripherals: This cheap keyboard, and this Logitech Mouse.

Edit: To add, I didn't do any of the rEFI setup like several of the guides mentioned. I just installed the Nvidia Drivers, along with Aorus Game Engine and everything was good to go.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote