Boot Camp eGPU Setup Guide - Windows Gaming with Macs
 
Notifications
Clear all

Boot Camp eGPU Setup Guide - Windows Gaming with Macs  

 of  33
  RSS

orchoidizer
(@orchoidizer)
Active Member
Joined: 9 months ago
 

Hi daquin9356, I have exactly the same Macbook Pro as yourself.
I was wondering if you have had any success?

Mid 2015 15-inch MacBook Pro Retina (2.2GHz Intel quad Core i7)
Intel Iris Pro Graphics. Thunderbolt 2, High Sierra - Bootcamp Win10 1903 (18362.295)
Razer Core X - Vega 64, Apple TB3 to TB2 Adapter ,- 2m TB2 cable


ReplyQuote
(@shoust_cz)
New Member
Joined: 11 months ago
 

Evrything works perfect on my mbp 16”(i7,16gb,5500m 8gb) with AORUS Gaming box 1080 but i have one problem with discharging laptop under heavy load (only cpu, amd gpu do nothing because egpu) is there any solition for this problem... i bought that Mac 1 week ago so evrything is new
thx

This post was modified 2 months ago

MacBook Pro early 2017 AORUS Gaming box with rx570 os:win 10 & catalina


ReplyQuote
Juraj
 Juraj
(@Juraj)
Joined: 2 months ago
 

Hi, I have MBP 2017 with touchbar and I am running newest Catalina and newest Windows version to date with SONET eGFX Breakaway Puck. I followed the guide to the letter and I actually get the eGPU card working, but it crashes in about 5 mins of running. I have tried
newest drivers, older drivers, but nothing work. The crash is black screen on my external display following crash of MBP display and windows reboot. Has anyone else experienced this issue? Is there a solution for it?

Edit to latest post: I found the solution. Connection of additional high powered device such as iPhone or Apple Magic keyboard is the rootcause. Low power devices such as Logitech MX dongle is not causing crashes

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@mark_troyer)
Active Member
Joined: 2 months ago
 

Been working at this for a few days.

Setup is 2018 MacBook Pro 13 inch 16GB of ram and I7 core.  

Have AMD Radeon 5700XT with Sonnet 650W breakaway box.

Tried a lot of different items, build of Win is 1903 - tried the EFI route, tried the hot plug, cold plug, about any other plug I could think of.

Getting either Error 12 or Error 43, Device works perfect in Mac OS (Catalina) 

I may just stick with parallels, but I think its def holding the 5700 back here, either that or the I7 can't emulate for VM work and do fast high Rez games.  Not sure what else to try. Although the one place I think I can try and double check is if the EGPUBOOT off USB drive update is needed for Catalina, but is that needed for booting to windows?  If so, can anyone explain how to update the new Key for UID of MAC HD?

I don't know how to update the config.plist via clover.  Thanks and im up for any other ideas, I also didn't see anyone with my specific configuration here, if anyone does have that working and can let me know steps, im up for trying that too!

Thanks !

Mark

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@mark_troyer, For Apple T2 Security Chip Macs, modified apple_set_os v.05 works more consistently in Boot Camp.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 5700 @ 32Gbps-TB3 (Prototype eGPU Enclosure) + macOS 10.15.4 & Win10 1903 [build link]  


ReplyQuote
(@mark_troyer)
Active Member
Joined: 2 months ago
 

@itsage, Thanks for the tip, I can try that for sure, so since I am on Mac OS X 10.15.3 won't that non updated .15 EFI Boot file not work?

I did update all the security settings here, but yes when I get to the selection of windows and hit enter, it just hangs there on the EFI boot screen.  

Should I just blow away that thumb drive and then input the .5 version here?

Do we have a link for what it should look like, I think I have it set up right, but never know since this is the first time I've really dug into the Boot loaders, EFI, etc.

 

Thanks!

Mark

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@mark_troyer)
Active Member
Joined: 2 months ago
 

Well holy moly!!! 
got this finally working now and running some benchmarks. Looking awesome so far. 
the .5 version of efi boot seems to help and I will saw I was about to just throw in towel, but just kept swapping ports and the error 12 went to 43 and back. So far I’ve played re3 remake on high as well as daymare. I would say from gaming in Mac or same games in parallels this is a marked improvement. I would guess around 30-40% Easy!! 
thanks for all the posts here. This noob is really getting there. 
mom finished up heaven and basic netted 232.3 with 5852 score!

Thanks all for all the help!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
(@mark_troyer)
Active Member
Joined: 2 months ago
 

Not sure if this is the right place to put in some benchmarks.

But I ran the Heaven Benchmark on Windows 10 via Parallels, Native OS X Ver 10.15.3, and lastly Windows 10 (build 1903) Via Bootcamp.

Settings were Extreme, not full screen and 1600x9000

Parallels = 30.1 FPS and total score of 762
Mac OSX = 60.4 FPS and total score of 1523
Windows 10 Bootcamp = 120.1 and total score of 3022

So pretty much doubles each iteration here of speed and overall score, needless to say, no wonder people really say to get bootcamp going on Macs for PC gaming!

Thanks again to any and all help here, the crazy port swap has worked now 5 times, and im in OS X now so I can format a MAC external drive to load some Steam games to.

Thanks!

Mark

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
Delta6alpha
 Delta6alpha
(@Delta6alpha)
Joined: 2 months ago
 

So I’ve got a base 2019 13” and a RX580 gaming box. I’ve followed these instructing a 4 or 5 times, and I have this problem where either the EFI doesn’t seem to kick in (it hangs at Windows boot) or I get into Windows and the card is reading Error 43. It take 15-30 restarts to finally get everything to load properly. I plug my mouse/keyboard into the eGPU, and it’s powering a LG UltraFine 4K with a DP to TB3 cable. What’s up with this?

Once it’s going, it’s amazing.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@Delta6alpha, For a Mac with Apple T2 Security Chip, you can try the modified apple_set_os v0.5 boot loader.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 5700 @ 32Gbps-TB3 (Prototype eGPU Enclosure) + macOS 10.15.4 & Win10 1903 [build link]  


ReplyQuote
 of  33