Boot Camp eGPU Setup Guide - Windows Gaming with Macs
 
Notifications
Clear all

Boot Camp eGPU Setup Guide - Windows Gaming with Macs  

 of  35
  RSS

Volodymyr Demtsiu
(@volodymyr_demtsiu)
New Member
Joined: 3 years ago
 

Hi guys!
Finally i see some results!!!
My configuration - Macbook pro 2016 with radeon pro 460 4gb, Akitio node tb3, nvidia gtx 1080Ti via bootcamp.
I did everything according to guide, but i have 1 issue and 1 question!

ISSUE - gtx1080ti is visible, but works only with external monitor.. any benchmarks do not want even start on internal monitor like on your video. And geforce menu says there is no monitor connected to graphics card.
I did everything in 5AM so there is a chance that I miss something, but what? ))

QUESTION - if I wannt just take my macbook without eGPU to trip or something, and work with it like before, with radeon pro 460, how can I do that and dont brake everything i do for eGPU? (on windows)

Thanks for your work!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
DigiBldg1
(@digibldg1)
New Member
Joined: 3 years ago
 

@Humanovation : How did you end up getting past this issue with the Vive? "headset needs to be run on the same graphics card as the SteamVR program" What, if any additional hardware did you have to use? I have: 15" Mid-2017 MacBook Pro, Sonnet Breakaway Box, AMD RX 580, Windows 10 on removed link It seems that SteamVR content without laptop display mirroring works great, but SteamVR content that mirrors the HMD on the laptop display requires the USB and HDMI HMD to be connected to the same graphics removed link Is this the same problem you encountered and solved? If so, how? Thanks!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Humanovation
(@humanovation)
Eminent Member
Joined: 3 years ago
 

– I got a DP to HDMI cable and connected that from the RX 580 to my TV. – I set the TV up to extend my laptop’s display rather than mirror it, and then set the TV as the main display in Settings>Displays. – Plugged the Vive headset into the HDMI out on the RX 580 – Open SteamVR and/or any associated programs so that they open on the TV and not on my MBP display. That’s it … you are using the RX 580 to drive both your TV and the Vive headset while the iGPU continues to drive the laptop display.

2017 15" MacBook Pro (RP560) [7th,4C,H] + RX 580 @ 32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13 & Win10 [build link]  

ReplyQuote
MrDanne
(@mrdanne)
Active Member
Joined: 3 years ago
 

There is a new rEFInd available 0.11.2. Maybe it is good to update the link above.

MacBook Pro 15" Late 2016 Touch bar | Sapphire Radeon RX Vega 56 8GB HBM2 | Mantiz Venus MZ-02 Space Gray


ReplyQuote
deathtrapz
(@deathtrapz)
Eminent Member
Joined: 3 years ago
 

I'll try to make this as clear as possible to understand because even I am slightly confused what is happening.

So firstly I got my Aorus Gaming Box and set everything up as above and it worked great! But then I became stuck in a boot-loop and the manual restore points I made wouldn't show so I just ended up clean installing windows on my 2017 15" MBP

Here is where my problem lies when I open device manager on windows (not running on integrated) the integrated card doesn't show what so ever, not even as microsoft basic display driver. So when I run the intergrated.bat  and then boot using the apple_set_os.efi in refind then boot to windows it just hangs. I have enabled show hidden devices in device manager with no results either, it is almost as if the internal graphics card is not there, which is obviously false as if i disable the radeon pro 555 the internal kicks in. Even then it does not display in Device manager. Any help would be great as i'm pretty stuck at the moment. 

-----------

*Edit

I managed to get this working by disabling the radeon 555 in device manager. Then running the integrated script,booting into windows and then everything worked out fine. Except I am stuck with a constant screen flicker when the display is idle, but if a youtube video is played then the flickering stops, any ideas?

2017 MBP 15" - Aorus Gaming Box 1070 - 2012 iMac 21.5"


ReplyQuote
ICULikeMac
(@iculikemac)
Estimable Member
Joined: 3 years ago
 

Hi deathtrapz,

Did you ever work out the screen flickering solution? I have that problem as I'm typing? 

Thank you!!

2019 Razer Blade Stealth GTX1650 Win10
Aorus Gaming Box RTX 2070
Asus XG Station Pro (RX570 8GB + RTX 2080)


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

I had the same issue and fixed mine by hot plugging after selecting boot OS. Thats all I do to get my Nvidia card to work. 

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
ngthtg735252
(@ngthtg735252)
Active Member
Joined: 3 years ago
 

Should this article update with new windows update?
I have Macbook Pro 2016 with Mantiz Venus + Aorus RX 580 8GB, after install Windows 1709, just need to disable PCIe 1905 and the setup work perfect.
Windows now work with or without eGPU, just simple boot, when I want to use eGPU, just plugged in the cable and restart the windows. Also there is no error or additional step when switch from Mac to Win or Win to Mac.
Thanks 1709 Windows update Grin
p/s: I am install windows 1709 directly from Bootcamp

Macbook Pro 2016 15inch - RP455 with Mantiz Venus Gray + Gigabyte Aorus RX580 8GB => P2715Q 4K 😀


ReplyQuote
Chrisddddddddd
(@chrisddddddddd)
New Member
Joined: 3 years ago
 

Thank you for your guideline. It works on my laptop, my laptop is mid-2015 15'' macbook pro with amd m370x gpu, and i use aorus gaming box 1070, connect with TM3 to TM2 adapter. But still have some problem on windows and os x. when i connect egpu on windows, the light of box doesn't work, other function all work in windows. I don't know how to use internal display on macbook. This all the problems i meet.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
deathtrapz
(@deathtrapz)
Eminent Member
Joined: 3 years ago
 

Temporarily I can fix it by uninstalling the internal intel driver with DDU then Manually installing the intel driver again. This fixes the flashing but after playing a game or any graphics intensive task the driver crashes and the flashing beings again until you reinstall the driver ect... But this is not a great fix as it always crashes mid game and when in a competitive game it takes 5 min to get back up again. My 'current' solution is to save a GIF on the desktop and just run it in the background, this solution is not a fix but works perfectly. Alternatively if you use an external display the flashing doesn't occur. 

I can't hot plug my Aorus as I run my OS through an external SSD plugged into the Aorus. I understand bandwidth is lost to the USB ports but it looks a lot cleaner and is much easier to just plug in the thunderbolt 3 cable and have everything there.

2017 MBP 15" - Aorus Gaming Box 1070 - 2012 iMac 21.5"


ReplyQuote
 of  35