Bootcamp Windows 10 Pro April 2019 Insider Recognising Blackmagic eGPU
 
Notifications
Clear all

Bootcamp Windows 10 Pro April 2019 Insider Recognising Blackmagic eGPU  

 of  5
  RSS

Sean Malinoski
(@sean_malinoski)
Active Member
Joined: 2 years ago
 

@OliverB  

My vega56 will run on an external monitor as long as I have it plugged into my mac on boot.  From there I am able to use the EGPU as the running graphics unit.

Worth noting that most games crash or freak out within about 10-15 minutes of play and require a complete reboot of steam.  Unsure if this is a driver issue or what.   Attempting to find a solution to that particular element...

2019 16" MBP W/ 5500M 4GB + 2.3 i9
Razer Core X Chroma
EVGA RTX 2070 Super 8GB


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 

@sean_malinoski, I see.. that's the standard that is has to be plugged in during boot.

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
Fakhrul Islam Murad
(@fakhrul_islam_murad)
New Member
Joined: 2 years ago
 

Thanks (@aging_product) ! You saved my days!

I got my blackmagic yesterday. I installed it with my Macbook Pro 2015 15 inch (Intel GPU). 
Then Installed Windows Insider as instructed!

Boom!

I can use macbook display, BlackMagic HDMI port working fine as well as Thunderbolt 3 port via (Ugreen USB-C male to Displayport Male Cable). I have tested 4K resolution. Working butter smooth.

Played games "NFS Payback". Decent performance at Ultra setting in Full HD resolution. 

Thanks! (@aging_product) to start this thread. (I just registered the account to say you thanks!)

This post was modified 2 years ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Ruby Redkinetix
(@ruby_redkinetix)
New Member
Joined: 1 year ago
 

guys, i need help here, 

I run all recommended method to run egpu on bootcamp. I have imac latest 2017 with radeon pro 550 inside , and mantiz egpu box with radeon vega 64. OSX : mojave. 

here the stories;

i installed win 10 through bootcamp. but i didn't unplug my egpu. i though it will run well. but the monitor with egpu just black. only my imac shoing windows. 

so, I run ddu , erase everything and reset.  win 10 detect my radeon pro 550 (or 555 i forget), then i tried , hot plug or any thing for egpu, but all screen go black. including my imac

I tried to plugin while watching the computer management, and the win 10 recognize the radeon vega 64 , but few sec, all go black.. , i need help here 

I connect my egpu to 2 hdmi and 1 displayport 

.. I need to run an stock trading program on win 10. I tried with parallel latest ver with higher memory setup, but still doe't wok well. so I need to run on win 10. 

need a guidance here...

My Mac: iMac Retina 4k 21.5 inch, 2017, Intel core i5, Radeon pro 555 2 gb , Mantiz eGPU with Radeon Vega 56 8 GB my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 
Posted by: Fakhrul Islam Murad

Thanks (@aging_product) ! You saved my days!

I got my blackmagic yesterday. I installed it with my Macbook Pro 2015 15 inch (Intel GPU). 
Then Installed Windows Insider as instructed!

Boom!

I can use macbook display, BlackMagic HDMI port working fine as well as Thunderbolt 3 port via (Ugreen USB-C male to Displayport Male Cable). I have tested 4K resolution. Working butter smooth.

Played games "NFS Payback". Decent performance at Ultra setting in Full HD resolution. 

Thanks! (@aging_product) to start this thread. (I just registered the account to say you thanks!)

So this is it... first report of the TB3 port working for monitor output, albeit with an older Mac.

eGPU ordered.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 
Posted by: Eightarmedpet

So this is it... first report of the TB3 port working for monitor output, albeit with an older Mac.

eGPU ordered.

@eightarmedpet
let me be a smart-ass: I told you this before.. 😉

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 
Posted by: Eightarmedpet

So this is it... first report of the TB3 port working for monitor output, albeit with an older Mac.

eGPU ordered.

@eightarmedpet I thought the issue wasn't the port, but using a thunderbolt display (the poster you responded to seemed to be using a Displayport monitor, not a TB3 like the 5K). Nonetheless, keep us posted on how things work out.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 
Posted by: OliverB
Posted by: Eightarmedpet

So this is it... first report of the TB3 port working for monitor output, albeit with an older Mac.

eGPU ordered.

@eightarmedpet
let me be a smart-ass: I told you this before.. 😉

Ha, no, you assumed, and there is a difference. 

@mac_editor I’ve just made the assumption that if the tb3 port out puts to a monitor via adapter then it should do without (to the 5k). Argh, I really hope all assumptions are correct here....

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


OliverB liked
ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@eightarmedpet Hmm, I recall concluding that the 5k doesn't work because it is a thunderbolt device and affects device allocation in Windows, resulting in an error 12 on the GPU - unless this is completely incorrect (I hope it is). Perhaps @joevt could chime in and shed light on what happens in this regard, as they seem very knowledgeable about thunderbolt in general.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@mac_editor from what I read from multiple posts on here it wasn't error 12 that was the issue (hey, does that even exist?! I'm kidding, it does... 😉 ) but any sort of picture being omitted via the TB3 port. 

There was one chap who said his 5K made noises and the USB ports were recognised but no actual picture - this has happened to me with various work rounds and I made the assumption it was bandwidth related. I think apple_set_os caused the same behaviour and I believe that did limit bandwidth (please strike through if you know for a fact that's an incorrect so as to avoid propagation of any incorrect information).

I feel we have never really had anyone fully test the Blackmagic eGPU in W10, when @itsage tested the unit it was fresh off the production line and both Windows and drivers have changed since.

@guideofgalaxy claimed a high level of success (but no picture I believe).

I have a dream it will be as simple as disabling a port or two to reduce bandwidth use (webcam). I also assume I'll be wrong...

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
 of  5