Can't even get the drivers to load for my eGPU
 
Notifications
Clear all

Can't even get the drivers to load for my eGPU  

  RSS

(@henrik_walland_lund)
Active Member
Joined: 2 weeks ago
 

Ok, so I'm on a 16" MBP trying to get a Gigabyte Radeon 5600 XT in a Razer Core X to work, but I've yet to get past the yellow-banged "Microsoft Default Display Driver" with an error 31 and the error message "the driver that tried to load was not the same driver during the POST". It's the same error even if I use the default Apple boot camp driver or the one from bootcampdrivers.com - I can't even get to the dreaded "Error 12" stage.

I've followed the instructions to get the bootcampdrivers.com drivers installed, using DDU from Safe Mode and verifying that it is indeed the correct driver version installed - but when I plug in the eGPU, I just get the Error 31 no matter what I do.

I'm about this close to giving up on it altogether and just waiting until AMD and Apple get this shit sorted properly.

Anyone got any ideas?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@henrik_walland_lund

AMD has a new driver.

https://www.amd.com/en/support/graphics/amd-radeon-5600-series/amd-radeon-rx-5600-series/amd-radeon-rx-5600-xt

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.4 Catalina / Windows 1809 / LG 27" 4K display


ReplyQuote
(@alaxend0l_games)
Active Member
Joined: 2 years ago
 

@mini-i5, Wait, I'm confused, you can install non-bootcamp AMD drivers on a MacBook Pro in bootcamp? I thought you were limited to just the bootcamp amd drivers and the drivers from bootcampdrivers.

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@henrik_walland_lund)
Active Member
Joined: 2 weeks ago
 

I've tried installing these drivers, but the installer just throws an error saying that no AMD hardware is installed. The bootcampdrivers.com drivers are the only drivers I'm able to install, apart from the official Apple Boot Camp drivers.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@henrik_walland_lund

Are you using the AMD auto-detect software? Or installing manually?

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.4 Catalina / Windows 1809 / LG 27" 4K display


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@alaxend0l_games

I downloaded and installed the RX 5700 XT driver from AMD’s site when I got my card in Nov. 2019.

It works great on my Mini. 

My version of Bootcamp is from 2018 (pre-Navi cards). 

 

This post was modified 2 weeks ago

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.4 Catalina / Windows 1809 / LG 27" 4K display


ReplyQuote
(@henrik_walland_lund)
Active Member
Joined: 2 weeks ago
 

Ahh… The Mini doesn't have an AMD dGPU, it only has the Intel iGPU. That's why you can install the AMD drivers.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@henrik_walland_lund

Is your Core X showing as connected in Windows Device Manager?

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.4 Catalina / Windows 1809 / LG 27" 4K display


ReplyQuote
(@henrik_walland_lund)
Active Member
Joined: 2 weeks ago
 

The Core X itself isn't showing anywhere, but the GPU in it is showing as the "Microsoft Basic Display Adapter", with a yellow bang and "Error 31" in its description.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@henrik_walland_lund

Did you set the Windows Thunderbolt App to automatically approve connection to the Core X?

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.4 Catalina / Windows 1809 / LG 27" 4K display


ReplyQuote
(@henrik_walland_lund)
Active Member
Joined: 2 weeks ago
 

What is this “Thunderbolt App”?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@henrik_walland_lund)
Active Member
Joined: 2 weeks ago
 

Nobody else with any input?

Just to add some details: I'm using Norwegian language, and tried the Windows Insider Fast Ring version as I read somewhere that people were having luck with that. But still the same issue, driver fails to even load.

Also, I'm only interested in using the MacBook in clamshell mode with the external display only, so I don't care about the dGPU and certainly not about the iGPU.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
zacoiz
(@zacoiz)
Active Member
Joined: 5 days ago
 

@henrik_walland_lund, hi Henrik. I'm having the exact same problem with my 5600 xt with the core chroma, on a MBP 2019 15". Did you have any luck with your setup, and if yes can please share your steps, I'm this close to just return the egpu setup.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@henrik_walland_lund)
Active Member
Joined: 2 weeks ago
 

@zacoiz, unfortunately, I never found a solution. No matter what I did, what version of drivers or Windows I used, it all just resulted in the same.

I ended up returning the eGPU setup to the store. This is clearly not ready for general use yet.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@pavol_jurik)
New Member
Joined: 3 days ago
 

@henrik_walland_lund, looks like o have the same problem and will do the same thing - return my amd 5600 xt card. 

btw when I try to manually update driver, and choose one from the list of available drivers, there is no amd 5600 xt driver listed (just 5500 and 5700 xt), so its possible that version from bootcamp drivers doesnt include support for this card(?)...

egpu would probably work with nvidia cards in windows bootcamp, i will try it (and loose macos support)

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@steven_sharko)
Active Member
Joined: 4 days ago
 

Damn, I was very sad to read this thread as I have a very similar issue. However, I do get the error 12 messages, just do not know where to go from there.

 

I also have a MBP 16" (2019) with a Razer Core X and RX VEGA 64. I've noticed the bigger models are having more issues. If anyone has a work around, please do @ me and let me know, as I still have a couple days before I can/need to return the eGPU.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts

Razer Core X / MBP 16" / RX VEGA 64 Graphics Card


ReplyQuote