Can't get eGPU to output to external display
 
Notifications
Clear all

[Solved] Can't get eGPU to output to external display  

  RSS

Jeremy Whelan
(@jeremy_whelan)
New Member
Joined: 1 month ago
 

2018  15" MacBook Pro (win10 64bit Bootcamp) + Razer Core X + nVidiaGTX970  

Hi all, I have just bought a razer core x and struggled to get my old gtx970 to be recognized by the system. Turns out the default Bootcamp Radeon drivers were interfering. Prior to removing those drivers, I kept getting error 12 and then a sudden blue screen with QR code link for general diagnostic help but no specific information. The Macbook speakers went crazy beeping and I was seriously freaking out that my computer was at risk of damage. Fortunately, once I uninstalled the AMD Radeon drivers, I was able to install the Nvidia drivers everything seemed to work ok except that the eGPU is still not outputting anything. The system does not recognize that there is an external display connected.

I have checked all the obvious things like hdmi cables, other devices, and the displays but it is definitely something to do with the system because everything else works fine. Any suggestions? 

( I apologize if this has already been asked and answered elsewhere, I am new to this forum and did have a search first but didn't see any discussion threads about it. ) 

This topic was modified 1 month ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Jeremy Whelan
(@jeremy_whelan)
New Member
Joined: 1 month ago
 
Posted by: @jeremy_whelan

2018  15" MacBook Pro (win10 64bit Bootcamp) + Razer Core X + nVidiaGTX970  

Hi all, I have just bought a razer core x and struggled to get my old gtx970 to be recognized by the system. Turns out the default Bootcamp Radeon drivers were interfering. Prior to removing those drivers, I kept getting error 12 and then a sudden blue screen with QR code link for general diagnostic help but no specific information. The Macbook speakers went crazy beeping and I was seriously freaking out that my computer was at risk of damage. Fortunately, once I uninstalled the AMD Radeon drivers, I was able to install the Nvidia drivers everything seemed to work ok except that the eGPU is still not outputting anything. The system does not recognize that there is an external display connected.

I have checked all the obvious things like hdmi cables, other devices, and the displays but it is definitely something to do with the system because everything else works fine. Any suggestions? 

( I apologize if this has already been asked and answered elsewhere, I am new to this forum and did have a search first but didn't see any discussion threads about it. ) 

Ok, so it turns out I'm an absolute idiot and forgot to plug the PSU cables into the graphics card!!! Problem Solved! I did previously use the DDU to uninstall the default AMD Radeon drivers. There doesn't seem to be a way to undo that but from what I have read it was a necessary step anyway.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote