Catalina 10.15.4 eGPU stop working in Win10
 
Notifications
Clear all

Catalina 10.15.4 eGPU stop working in Win10  

  RSS

rockevan
(@rockevan)
Active Member
Joined: 3 years ago
 

Hi,

 

Today I have updated the MacOS to 10.15.4. It stops my MacBook pro 2018 15inch from booting while Raedon 5700 is connected.

Windows version is 18362.30

Hot-plug does not work either. It shows error 12.

Has anyone experience this issued?

 

Edit:

To make it work again, I downgraded 10.15.4 to 10.15.3 and removed the updated bootcamp software 6.1.10.

I also updated Windows to insider build 19592.1001 (fast ring).

This topic was modified 2 months ago

MacBook Pro 15 inch 2018
Akitio Node RX 5700
MacOS 10.15.3
Windows Fast Ring Build 19603


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

Thanks for letting us know 

I will not even go close to it. 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 9 months ago
 

10.15.4 works great on my Mini. Not a single issue.

My Windows 1809 Bootcamp installation runs great.

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.4 Catalina / Windows 1809 / LG 27" 4K display


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@mini-i5, Thank you for that

Need help to run forza Horizon / Motorsports

I had to Setup a clean new boot camp on an ext ssd. Using w10 1903 v1 etc. however this time After finishing the first setup, I let w10 update to the latest versions up to mar20 Including the security updates and then uninstalled them (excl the security ones). 

over the last week I find this process to have resulted in a much more stable system, 0 issues.

however I cannot play neither forma horizon or motorsports. In my previous build horizon was working ok 

any help welcome

 

 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 9 months ago
 

@tsakal

Ah, good to hear you have 1903 running well. 😀

People have problems with Forza if they have MSI Afterburner or a similar utility open. 

Also, you can try to reset app by right clicking on Forza Horizon 4 > More > App Settings > "Terminate" then "Reset".

 

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.4 Catalina / Windows 1809 / LG 27" 4K display


ReplyQuote
Netcho
(@netcho)
Eminent Member
Joined: 1 year ago
 

For the first time I am trying to get the eGPU run on Windows 1903 ver 1 under Catalina 10.15.4 but no luck. I get the error 12. Running Macbook Pro 15" mid 2015 (R370X card) and eGPU with Vega 56. Any help will be appreciated. 

MacBook Pro 2015 15” 2.5 GHz

 
2015 15" MacBook Pro (R9 M370X) [4th,4C,H] + RX Vega 56 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.14.4 [build link]  


ReplyQuote
tsakal
(@tsakal)
Reputable Member
Joined: 2 years ago
 

@netcho,

My MacBook Pro does not have a discreet gpu just the inter iris one. You should check on the guides page or the forum topics to find somebody who has similar hardware configuration as sometimes setup is specific to the hardware used. 

That is what I did anyway, and always worked on first attempt. 

 

Best

 

 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Razer Core X, Nitro+ RX5700 xt 8Gb, LG 32UK550
Mac OS Catalina 10.15.2, Ext SSD Windows 10 1903 V1 .295

B. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb, Mac OS Catalina 10.15.2, Ext SSD Windows 10 1803

C. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
(@darren_yeoh)
New Member
Joined: 3 months ago
 

Didn't work for me as well using the apple set os bootloader on 10.15.4. Managed to downgrade to 10.15.3 and it started working again. Running windows 1903 (18362.30).

This post was modified 2 months ago

Macbook Pro 13" 2019 Model
Razer Core X
GALAX GTX 1070 Ti


ReplyQuote