eGPU working great on mac, but not Windows?
 
Notifications
Clear all

[Solved] eGPU working great on mac, but not Windows?  

  RSS

viciousmoth
(@viciousmoth)
Active Member
Joined: 1 year ago
 

Hi, this is my first try at using an eGPU. I am using a Mac Mini 2018 running the latest public MacOS, and partitioned the internal disk for bootcamp, running Windows 10 18362.295. I installed a Sapphire Radeon 5700 XT Nitro+ in a Razer Core X. Connection is from the egpu hdmi to my monitor hdmi. This setup is recognized by MacOS just fine. My issue is figuring out how to get windows to recognize my gpu. During my attempts, I needed to connect a second hdmi cable from the mac mini itself to a second hdmi input to see the desktop.

I tried having the egpu connected from a cold boot and eventually read here that's no good (flickering screen, cutting in and out, hanging on the windows logo). I then tried to boot into windows first and then plug in the egpu, and switching from the mac mini hdmi signal to the egpu signal. There is no signal. When I do connect the egpu tb3 cable I do hear the chime that hardware has been connected, and hear the chime when it is disconnected. But I don't see any prompts or pop ups or anything like that. Just the sound.

I do want to note that I have not manually installed any video drivers. I hoped this would be straight forward since the mac mini only has integrated graphics, and expected for some drivers to be installed upon connection. Should I install gpu drivers before trying again? I tried going here: https://www.sapphiretech.com/en/drivers-download but the page just says 'Radeon GPU drivers only', as if it's saying it doesn't detect what's connected? Clicking on that sends me to https://www.amd.com/en/support

Meanwhile, I am trying different search terms to figure out my problem. I am encouraged that the hardware is recognized by MacOS, so hopefully I'm close. Any advice or pointing in the right direction is appreciated. I am thankful for the wonderful resources and knowledge here.

Mac Mini (2018) 3.2 Ghz 6-core i7, 32GB Ram, 500gb SSD
Enclosure: Razer Core X - GPU: Sapphire Radeon Nitro+ 5700 XT Monitor: Dell AW3420DW


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@viciousmoth You need to install Radeon drivers manually. Automatic device detection and driver installation in Windows is not the best option. They often result in outdated drivers which may or may not work with the connected hardware. The safest way is to boot into Windows 10 with the monitor connected to the 2018 Mac mini HDMI port and no eGPU connected. Hot-plug the eGPU in Windows Desktop and proceed to download and install Radeon drivers directly from AMD website. Shut the computer down when Radeon drivers complete installation. Connect the eGPU to 2018 Mac mini and switch the monitor cable to eGPU only then boot into Windows.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
viciousmoth
(@viciousmoth)
Active Member
Joined: 1 year ago
 

@itsage

Thank you for the detailed explanation, I really appreciate it. It got me up and running! I am still trying to figure out the best way to boot into Windows. For those in a similar situation - So far, the only sure way to boot into Windows 10 is to be in MacOS with the eGPU connected, and then bootcamp restart into Windows.

Ways that have failed:

If I last shut down on Windows, and attempt to boot with the eGPU attached, I get 'no signal' error.

If I last shut down on Windows, if I boot to desktop without the eGPU and then plug in the eGPU once the desktop has loaded, still no signal. I can hear the Windows system sounds that seem to suggest everything should be OK. At this point, even switching connection to the mac mini hdmi out doesn't get a signal. I need to restart the PC.

If I am on Windows and simply restart, I get the 'no signal' error to the monitor. . In these scenarios, I need to restart again, and use the hdmi out on the Mac Mini to get back to MacOS.

As a variable unique to me, I am trying to figure out if there is a handshake issue with my monitor (BenQ EW3270U 4k 60hz). Occasionally I get an 'out of range' message on my monitor instead of 'no signal' when I attempt to hot plug the egpu. I trie d using an HDMI cable instead of Display Port, but it behaves the same. I will continue to try different combinations to see if anything works besides the restart from MacOS to Windows.

 

Mac Mini (2018) 3.2 Ghz 6-core i7, 32GB Ram, 500gb SSD
Enclosure: Razer Core X - GPU: Sapphire Radeon Nitro+ 5700 XT Monitor: Dell AW3420DW


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@viciousmoth The firmware for 2018 Mac mini is a work in progress for Apple so there's not really a solid way to switch between macOS and Windows with eGPU connected. You'd have to experiment with your own setup and see what works most reliably. For my own setup I have an ASUS USB-C monitor connecting to one of the Thunderbolt 3 ports all the time. The eGPU would occupy another Thunderbolt 3 port and power a separate monitor. I also use automate-eGPU EFI to keep the Intel iGPU activated when booting into Windows with eGPU. You can check an example build [2018 Mac mini + RX Vega 56 Nano].

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
viciousmoth
(@viciousmoth)
Active Member
Joined: 1 year ago
 

@itsage

Much appreciated.  Nice idea with the usb-c monitor, and I hadn't considered automate-egpu since I'm only dealing with iGPU, but I understand now why. I'll continue experimenting. Thanks for the help and ideas, cheers.

This post was modified 12 months ago

Mac Mini (2018) 3.2 Ghz 6-core i7, 32GB Ram, 500gb SSD
Enclosure: Razer Core X - GPU: Sapphire Radeon Nitro+ 5700 XT Monitor: Dell AW3420DW


ReplyQuote
BigJambox
(@bigjambox)
New Member
Joined: 2 months ago
 

@viciousmoth, Thank you very much! I just set up my Mac Mini with a Core X and 5700xt and could not for the life of me get it to work in Windows 10 Boot Camp. You advice on being in the Mac OS first and using the egpu then booting into Windows worked. Thanks again! Now it time to start playing some games!!!

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
viciousmoth
(@viciousmoth)
Active Member
Joined: 1 year ago
 

@bigjambox, you’re welcome! I remember the first time it finally worked for me and it was time to play games. Exciting times!

By the way, this is still the only reliable way for me to get to Windows, but I’ve learned to be ok with it. I haven’t tried the automate-eGPU EFI that was suggested to me because I wasn’t sure how to get that to work. But it sounds like a really great way to boot reliably - it’s on my to-do list to try it sometime.

When I’m done with Windows and bootcamp back into MacOS, it’s a 50/50 chance of a black screen. The only reliable way for me to go from Windows to MacOS is once I use the bootcamp menu to get back to MacOS, when the blue Windows restarting screen shows up (or just as it goes away) I have to unplug the eGpu. I wait about 60 seconds (give or take) to give MacOS time to completely load to the log-in screen, and then I connect the eGpu. MacOS consistently shows up this way. 

Don’t forget that Windows likes to auto update the OS. I‘ve read it’s much easier to block updates with Windows 10 Pro, but I have Home. I set a monthly bandwidth limit of 2mb to make sure it never updates. When I was careless and it updated before, I was able to roll back the drivers and be OK. Just a bit annoying when that happens.

So I just repeat this process going between windows and MacOS. I’ve gotten used to it. Well worth it though! Have fun. 

 

This post was modified 2 months ago

Mac Mini (2018) 3.2 Ghz 6-core i7, 32GB Ram, 500gb SSD
Enclosure: Razer Core X - GPU: Sapphire Radeon Nitro+ 5700 XT Monitor: Dell AW3420DW


ReplyQuote