Error 12 on 16" MacBook Pro [i9, 5500M] + Razer Core X + RX580
 
Notifications
Clear all

Error 12 on 16" MacBook Pro [i9, 5500M] + Razer Core X + RX580  

 of  3
  RSS

Haoshiro
(@haoshiro)
Eminent Member
Joined: 3 years ago
 

I've commented on a few threads but thought it would be best to start a new thread.

I have so far been unsuccessful getting my Core X + 580 moved over from my Mid-2015 MBP due to Error 12.

My last attempt went as follows:

  • Install Windows 10 Pro 1903 V1 (18362.30) + Activated
  • Install Boot Camp drivers
  • Install .295 update
  • Reboot into Safe Mode and run DDU to remove AMD drivers
  • Shutdown, Plug-in Core X (front-left port), Turn on
  • Install BCD drivers (Adrenalin November 2019 edition)
  • Reboot (keeping Core X plugged in)

I only had power and the eGPU connected, no external devices (maybe some BT devices, unsure).

Device Manager
Properties General
Properties Driver

Previously I have also attempted to disable tb3 controllers, disable the 5500M, use automate efi boot usb, all to no avail.

Any help/insight/ideas would be appreciated!

This topic was modified 1 year ago

death to self


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@haoshiro I have tried several Radeon eGPUs with the 2019 16-in MBP in Boot Camp and error 12 was not an issue. I have not used any of our workarounds yet. If you have not tried hot-plug in Windows Desktop, give it a try. Usually the the Network and Sound icons on the Taskbar would show as disabled while the system is initiating the PCIe connection for the eGPU. After about two minutes you would get notification of the PCIe device. You can also try connecting the eGPU on the right sided Thunderbolt 3 ports and see if that makes a difference.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Denis Sulovic
(@denis_sulovic)
New Member
Joined: 1 year ago
 

Same issue with my MacBook Pro 2018 EGPU: razer Core x chroma + 5700xt please help fast! 

error 12 idk what to do! 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Haoshiro
(@haoshiro)
Eminent Member
Joined: 3 years ago
 

@itsage

I’ve tried cold and hot plug of every port with no success. Hot plugging doesn’t seem to disable anything and pop up in device manager in seconds with Error 12

I went ahead and order a 1070 in hopes nVidia works out simpler.

death to self


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@haoshiro Sorry to hear. On my 2019 16-in MBP, it's possible to hot-plug the an AMD eGPU and no error 12 (Win10 18362.295). Again I have not used any EFI boot loader or PCIe controller disablement.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Haoshiro
(@haoshiro)
Eminent Member
Joined: 3 years ago
 

@itsage

Yeah I’m really disappointed as I have a Freesync 4K monitor and the 8GB XFX Radeon RX 580 GTS Black Edition OC+ which has been great.

I tried with and without the workarounds and I’m using the same windows version as you (Win10 18362.295). I’ve even disabled the dGPU entirely after DDU and had only the eGPU connected.

It strikes me as very strange to be getting Error 12 on this new machine as I expected to work much easier than my Mid-2015

Even disabling controllers and booting with an automate efi usb boot doesn’t help (although the monitor will come on pre-windows using the boot loader).

death to self


ReplyQuote
win32asmguy
(@win32asmguy)
Active Member
Joined: 4 years ago
 

@haoshiro

Any chance you have an 8GB 5500M? I have ran into the same issue with code 12 using what should be a working Windows 10 build + AMD driver. The only difference I can tell between other working configurations is the extra vram could be causing the issue.

2016 15" HP ZBook 15 G3 Studio [6th,4C,H] + GTX 1070 @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
Haoshiro
(@haoshiro)
Eminent Member
Joined: 3 years ago
 

@win32asmguy

Nope. I have the stock 2.3Ghz i9, 16GB RAM, 4GB 5500M + Intel UHD 630

death to self


ReplyQuote
Haoshiro
(@haoshiro)
Eminent Member
Joined: 3 years ago
 

I did a bunch more testing trying to get this to work through different drivers (BCD and Official) while using an automate-efi USB boot drive.

It showed some promise as I did get some different behavior a few times.

The first few times booting with automate-efi the Intel UHD 630 would appear and I was able to install drivers for it but it would disappear again and never reappear after reboot.

Once I received Error 43 on the RX580 instead of Error 12 but was unable to reproduce it under the same circumstances.

Several times it booted with the external monitor black but still actually powered on, when that happened the RX580 didn't show up in Device Manager at all.

In a few scenarios with automate-efi everything looked promising but it was stuck at the windows loading animation (I waited 15min+ and it stayed hung up).

I tried disabling every thunderbolt controller, usb hub, etc except that used by the SSD and the eGPU and still received Error 12 on cold or hot plug and I tried this using all four ports individually.

In summary the non-Error 12 states I experienced were:

  • Error 43 once, could not reproduce
  • Active external monitor (only connected to the eGPU) but eGPU missing from Device Manager
  • Windows infinite loading animation on boot (reproducible using automate-efi)

I did also try not removing the Pro 5500M drivers and can confirm it causes a black internal screen on boot that I could not get around without booting a recovery disk, starting safe mode, and using DDU.

The GTX 1070 I order should arrive around 12/5 so I hope that works out without issues. I'd still prefer to make the RX580 work and just re-sell the 1070 though. 

death to self


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@haoshiro Keeping the stock Apple Radeon drivers and hot-plug an Radeon eGPU would result in black internal display as you found. This is due to Windows auto driver installation for the eGPU which then corrupts the dGPU drivers. The scenario when you got a stuck Windows logo while booting with automate-eGPU EFI is due to the connected eGPU. It's a recent compatibility issue of Mac firmware and apple_set_os.efi. I believe it effects Apple T2 Chip Macs only.

Have you tried booting into Windows using automate-eGPU EFI but no eGPU connected? If your Win10 is still on 18362.295, you can attempt hot-plug the eGPU. Don't disable any PCIe components because it may mess with Thunderbolt 3 device detection. Make sure to use the modified Radeon drivers from BCD. I tried original Radeon drivers from AMD but encountered error 173 "AMD graphics hardware was not found".

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
 of  3