Notifications
Clear all

Error 12 on 16" MacBook Pro [i9, 5500M] + Razer Core X + RX580  

 of  3
  RSS

Haoshiro
(@haoshiro)
Eminent Member
Joined: 4 years ago
 

@itsage Thank you for the information on what causes those scenarios. I also received that Error 173 error initially trying to install the official drivers but if you reboot with the eGPU connected and try again it then installed correctly (but still Error 12)

I did try hot plugging the eGPU after booting with automate-efi and the BCD drivers leaving all the devices enabled and was still stuck with Error 12.  Trying to disable devices was the last thing I did as a last ditch effort and the last thing I could think of left to do.

When I created the automate-efi boot disk I did use the install script and chose "NVIDIA" as the instructions said to due to out of date AMD patches.

Edit: And yes I am still on .295

This post was modified 2 years ago

death to self


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
Builds: 155
 

@haoshiro I tried automate-eGPU EFI boot loader to see whether the Intel UHD Graphics 630 iGPU in the 2019 16-in MacBook Pro is usable. Unfortunately it's the same situation as 2018 & 2019 15-in MacBook Pro. While it's possible to enable the Intel iGPU and force attach it to the internal display, you'd get white dots and eventual black display. We have to wait for @mat_hd's December release of the BCD drivers to use both RP eGPU and Radeon eGPU at the same time.

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 14" Microsoft Surface Laptop Studio [11th,4C,H] + RTX 2080 Ti @ 32Gbps-TB4 (WD_Black D50) + Win11 [build link]  


ReplyQuote
benvp
(@benvp)
Active Member
Joined: 3 years ago
 

@Haoshiro I'm also looking for a solution to this. I also experience the *exact* same issues like you. Error 12 no matter what. I think I tried all the things you tried. Anyway, my MacBook is slightly different. 2,4 GHz, 64 GB, 5500M 8 GB. And I am using the Razer Core X with a Radeon Vega64. So I assume it does not affect only RX graphic cards.

Will try a few different windows versions now. Starting with 1809 and then the newest 1909. Will let you know if I figure something out. Smile

 

Tested both the 1809 and 1909... still no luck... - I'm really wondering what causes the issue. Especially as itsage doesn't have any issues getting this setup running at all.

This post was modified 2 years ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
wittmason
(@wittmason)
Active Member
Joined: 4 years ago
 

I too am having issues with my 2019 16" MacBook Pro + Mantiz Venus + RX 580 and Windows 10 1903/1809. l should also mention I am running Catalina Supplemental update 10.15.1.

I've tried very similar steps as the OP. I've uninstalled graphic drivers with DDU I've installed BootcampDrivers.com drivers of the AMD November edition software. I've gotten error 12 each time.

Anyone else made any progress here?

 

EDIT: I did eventually get this to work but I had to follow to the letter the install procedure outlined in @itsage original post on his 16" MBP.

The one thing I kept missing was the tiny check box at the bottom of the DDU settings that says keep Windows from reinstalling drivers after uninstall. This was key and the only thing I had forgotten before.

This post was modified 2 years ago

2019 MacBook Pro 16" + Mantiz Venus + RX 580


ReplyQuote
wsjnohyeah
(@wsjnohyeah)
New Member
Joined: 2 years ago
 

I am having the same issue, using core X with 5700 XT. Can't get rid of the error 12 using any way. My RTX 2070 S on the other hand worked plug and play ; (

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
benvp
(@benvp)
Active Member
Joined: 3 years ago
 

@wittmason

Interesting. I also has checked the checkbox and still experiencing error 12. I gave up on that. I sold my Vega64 and will get a 2080 soon. Don't need the eGPU under macOS anyway.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
wsjnohyeah
(@wsjnohyeah)
New Member
Joined: 2 years ago
 

@benvp

This is the case for me as well

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
wittmason
(@wittmason)
Active Member
Joined: 4 years ago
 

@benvp

This is the post I followed verbatim (from itsage). Make sure to have the Win 10 xxxx.30 installer.

https://egpu.io/forums/builds/2019-16-macbook-pro-rp5500m-9th8ch-rx-5700-xt-32gbps-tb3-rog-xg-station-2-macos-10-15-1-win10-1903-itsage/#post-69351

2019 MacBook Pro 16" + Mantiz Venus + RX 580


ReplyQuote
acantril
(@acantril)
Eminent Member
Joined: 4 years ago
 

I have the same issue - I just can't get a 5700XT working without error 12. 

Followed the process that everyone else has suggested to the letter.

Not installed any additional tools (automate egpu) yet, ideally I want to avoid that.

Using a 16-inch, Core X, 5700XT. tried all TB3 ports, hotplug and not.

2019 MacBook Pro 16" / i9-9880HK / 32GB / 5500M 8GB
Razer Core X Chroma / AMD Radeon RX 5700 XT


ReplyQuote
acantril
(@acantril)
Eminent Member
Joined: 4 years ago
 

I just tried disabling the unused ports and still code 12 - pretty much out of ideas at this stage.

2019 MacBook Pro 16" / i9-9880HK / 32GB / 5500M 8GB
Razer Core X Chroma / AMD Radeon RX 5700 XT


ReplyQuote
 of  3