error Code 43 in Bootcamp / RX 5700 XT
 
Notifications
Clear all

error Code 43 in Bootcamp / RX 5700 XT  

 of  2
  RSS

graukatze
(@graukatze)
Active Member
Joined: 3 years ago
 
Posted by: @itsage

@eightarmedpet Error 43 happened on an RX 580 for me a couple of times. I did try switching to macOS right after to observe whether it's possibly a hardware issue. Interestingly enough the Thunderbolt connection was not detected in macOS. I had to disconnect and reconnect a few times for it be detected and the eGPU started working again. This was a VisionTek mini eGFX + RX 580. There were mouse and keyboard as well as Ethernet connected. None worked so it wasn't the RX 580 hardware issue. Maybe it's from the Thunderbolt 3 controller on either the enclosure or laptop? Thunderbolt 3 cable was the standard issued .5m one.

 

Same for me - after I upgraded to macOS Catalina I went back to try out Bootcamp + 5700XT w/Akitio Node and same troubles as described (sudden disconnect of eGPU with Windows 10 (Windows 10 1903 OS Build 18362.295 + bootcampdrivers AMD November or July V2), then trouble to even find eGPU in Catalina. Reboots, logons, waiting... at one point the eGPU is discovered again in Catalina and also in Bootcamp until the next disconnect.

Macbook Pro 2018 w/ Radeon Pro 560X
Akitio Node and RX5700 XT with Windows 10 1903 and macOS 10.14.6


ReplyQuote
Иван Кириченко
(@iddqd07)
Active Member
Joined: 4 months ago
 

@itsage, did you succeed with testing a different eGPU?

I'm currently experiencing the same "error 43" with [RX 570 + Zotac AMP BOX Mini 230w] and I'm wondering whether it's GPU failing or enclosure's Thunderbolt controller acting up or enclosure's power adapter providing insufficient power.

I tested the eGPU on 2 Macbook Pros (2014 over TB2 and 2018 over TB3) and could reproduce the problem on both of them. Thus, the problem is likely on eGPU side and not in the laptop's Thunderbolt controller.

 

MBP 13" Mid-2014 + Zotac Amp Box Mini 230w + Palit GTX 1650S


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@iddqd07, I have been troubleshooting with error 43. It's likely due to EFI boot loader. What I've found to work is what we call "port-dance". If you boot into Boot Camp with the eGPU connected to one Thunderbolt 3 port that results to error 43, simply disconnect the eGPU from that TB3 port and connect it to another TB3 port. Keep in mind not all versions of Windows 10 can support hot-plug of Radeon eGPU, therefore it's best to keep your system running 18362.30-.295. I replicated this same behavior and port-dance several times on the 2018 Mac mini with success.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2019 13" MacBook Pro [8th,4C,U] + RX 5600 XT @ 32Gbps-TB3 (VisionTek mini eGFX) + macOS 11 & Win10 2004 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 
Posted by: @itsage

I have been troubleshooting with error 43. It's likely due to EFI boot loader. What I've found to work is what we call "port-dance". If you boot into Boot Camp with the eGPU connected to one Thunderbolt 3 port that results to error 43, simply disconnect the eGPU from that TB3 port and connect it to another TB3 port.

Uninstalling from device manager on previous boot (like we did initially for 2018 MBP) could be a substitute for port-dance - unless people have tried it?

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@mac_editor, I tried "Uninstall device without driver removal" in Device Manager tonight. Unfortunately that did not resolve error 43. Port-dance worked to get the Radeon eGPU going. I proceeded to try booting into Windows 10 without the eGPU connected then hot-plug it. That worked with and without an EFI boot loader. This was on a 2018 Mac mini (USB-C portable monitor connected to USB-C port #4 always).

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2019 13" MacBook Pro [8th,4C,U] + RX 5600 XT @ 32Gbps-TB3 (VisionTek mini eGFX) + macOS 11 & Win10 2004 [build link]  


ReplyQuote
yamrzou
(@yamrzou)
New Member
Joined: 2 years ago
 

@itsage, I can confirm the "port dance" trick works with BootCamp on the Mac mini 2020, running Windows 10 1909.

But before that, I had to disable Network Adapters the first time I plugged the eGPU to get rid of a blue screen error, also reported by others in this reddit thread.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
Иван Кириченко
(@iddqd07)
Active Member
Joined: 4 months ago
 

@itsage, looks like in my case there was a faulty GPU. The main evidence is that it worked the same bad (once in 5-7 tries) with MacOS on MacbookPro 2018 (no EFI boot loader whatsoever).

Replaced it with GTX 1650S, so far so good :).

 

MBP 13" Mid-2014 + Zotac Amp Box Mini 230w + Palit GTX 1650S


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@iddqd07, That's good to hear. Thank you for providing an update!

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2019 13" MacBook Pro [8th,4C,U] + RX 5600 XT @ 32Gbps-TB3 (VisionTek mini eGFX) + macOS 11 & Win10 2004 [build link]  


ReplyQuote
 of  2