[SOLVED. Black screen. MBR] Mac mini 2012 + Razer Core X chroma + Bootcamp
 
Notifications
Clear all

[Solved] [SOLVED. Black screen. MBR] Mac mini 2012 + Razer Core X chroma + Bootcamp  

  RSS

Vetal
(@vetal)
Active Member
Joined: 1 year ago
 

- Mac mini late 2012: 2,3 GHz Quad-Core Intel Core i7, 16 GB 1600 MHz DDR3,
- Razer Core X chroma + ASUS ROG Strix Radeon RX VEGA64
- Mac os 10.15.4
Mac os works perfectly with eGPU (graphics card works), but Windows 10...
- Windows 10 (1809) installed via mac os default boot camp installer, using the default MBR mode (it's important!).
- Cables connection: mac mini <--> eGPU via thunderbolt 1/3 adapter, mac mini <--> monitor via hdmi, monitor <--> eGPU via VGA - DVI adatper.
(Note: I also tried to connect the second monitor to the eGPU via hdmi but it didn't solve my problem.)

I'd like to use "eGPU Setup 1.35" for solving "error 12" for my old mac mini. I already got instructions from @nando4. My eGPU is detected in the "Setup 1.35" menu.
=================
However, firstly I need to solve another problem (which is not connected with "error 12", as I understand): black screen after the frozen windows logo, it happens only in case I boot windows with connected eGPU.
Windows boots correctly (I'm able to shut down using alt+f4), but the display is not. As I understand, my integrated GPU should show the information instead of eGPU for "error 12" detection, but in my situation it tries showing the black screen from unconfigured eGPU, and doesn't want to show iGPU signal.

What I tried:
- Switching the source on my monitor (from hdmi to dvi and back) - no effect. Only the black screen.
- hot plug eGPU after windows booting. Windows doesn't detect it in the device manager.
- DDU, installing drivers from different sources: AMD.com (Adrenalin 2019, 2020), bootcampdrivers.com, etc. I still don't understand which way is correct for my purpose?
- boot using rEFind 0.12.0, no effect in MBR. Maybe I missed something important here, because I used it only after default installation.
- apple_set_os.efi, but it doesn't work in MBR mode (does it? Do I understand correctly?). It works only in case I install Windows in the GPT mode, but "Setup 1.35" works only in the MBR mode. I have no idea what to do.
Does anyone have any ideas how to boot Windows for mac mini 2012 + eGPU with working display in the MBR mode?

==============

SOLVED after updating to the Windows 19628 build, look at my message below.

This topic was modified 1 year ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Vetal
(@vetal)
Active Member
Joined: 1 year ago
 

Success!
I reinstalled Windows again in GPT mode, as usual detected 'error 12'.
However today I just updated to the 19628 build using Windows insider (Fast).
And "error 12" was over, everything works even on my old mac mini!
Thanks to this tread and Valkyrionetz message: https://egpu.io/forums/postid/79668/
I will write in more detail a bit later.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Neil Jin
(@neil_jin)
New Member
Joined: 1 year ago
 

@vetal, I encounter a non-detected problem, have you meet this before?

When I connect the egpu with my 2013 MacBook pro, it cannot be detected, even the code 2012 doesn't exist.

What should I do to solve it?

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Vetal
(@vetal)
Active Member
Joined: 1 year ago
 

Hey @Neil Jin, sorry I'm late, and I didn't detect your problem because I don't have a MacBook...
After 40 days my egpu and mac mini 2012 work great.
No any issues on mac os.
A few small issues on Windows:
- no displays detection after booting the Windows. It happens very rarely, in 1 case from 10.
- no displays detection after waking from the sleep mode.
Playing games on this mac mini is perfect, I hadn't expected that it's possible on this old machine.
Switching between Windows and Mac os is done through Windows bootcamp app and Mac OS Startup Disk, so I don't use internal graphics at all.
My current system:
Mac OS Catalina 10.15.4
Windows build 19628.
According to my bad past experience I don't want to update anything before the need arises.

This post was modified 1 year ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mk187
(@mk187)
Active Member
Joined: 1 year ago
 

@vetal

Hey, is it still working? I read this and joined windows insider to try and update to Windows build 19628 but cant seem to find it anywhere, or where do install it from? 

Prior to this did your EGPU work? and have you done anything extra to make it work? Or is it just plug and play on Windows build 19628? 

i have the same set up but on a macbook pro mid 2014 and just cant get it to work, connect the EGPU at the choosing boot stage, but once it tried to go into windows my screen just goes black. 

thanks

 

Macbook Pro Mid 2014 (No DGPU) + Razer Core X + Vega 64


ReplyQuote
Vetal
(@vetal)
Active Member
Joined: 1 year ago
 

@mk187, After updating to the 19628 my screen (which was connected to the graphic card) was detected automatically and that's it, no more black screen after launching the system, everything started working.
>"Prior to this did your EGPU work? and have you done anything extra to make it work? Or is it just plug and play on Windows build 19628?" 
I just stayed my update process for all night, and after the finishing and restarting my screen was detected.
However I don't know how to update to the 19628 now, because I bought the new macbook pro 13 2020 after that 3 month ago and have never returned to my mac mini again.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote