I can't access to the Nvidia control panel of my eGPU card
 
Notifications

[Solved] I can't access to the Nvidia control panel of my eGPU card  

  RSS

Bloodstainer
(@bloodstainer)
Eminent Member
Joined: 3 months ago
 

Hello,

I use an eGPU (RTX 2060 + Razer Core X) with an iMac (internal screen).

The only way I can run my eGPU with applications (games) is the to use the "Graphics specifications" feature of Windows 10, like that :

graphics specs

If works well for most of the games! 🙂

The problem is that I can't access to the NVIDIA Control Panel, because Windows 10 consider the GPU is not connected when I'm in the desktop...

I see this message:

nvidia control

Is there an alternative solution?

Thanks.

This topic was modified 1 month ago

Config: iMac (Retina 4K, 21.5-inch, 2017). eGPU : NVIDIA GeForce RTX 2060 (with a Razer Core X enclosure)


ReplyQuote
Igor Dasunddas
(@igor_dasunddas)
Active Member
Joined: 3 months ago
 

I had to install proper nvidia drivers myself in order to get the nVidia Control Panel.

There also seems to be an UWP App in the Windows Store that Windows suggested to me upon first time connect.

The nVidia Control Panel is not available by default even after installation. It is only available if you have your nVidia GPU connected.

EDIT: right.. and if it is not available,if your GPU is available, but inactive. You might want to start any application using the nVidia GPU first.

This post was modified 1 month ago

Laptop: DELL Inspiron 7391 2-in-1, i7 10510U, 16GB DDR3-RAM, 512GB nVME-SSD, Active Stylus
eGPU: Aorus Gaming Box 1080 (nVidia GeForce GTX1080) on Thunderbolt 3 connection


ReplyQuote
Bloodstainer
(@bloodstainer)
Eminent Member
Joined: 3 months ago
 

I already did that. I installed the proper drivers. Even if I launch an application that using the eGPU first, the control panel is still unavailable (the icon is visible in the task bar, but when I click on it, I have the message "Nvidia Display settings are not available. You are not currently using a display attached to an NVIDIA GPU").

This post was modified 1 month ago

Config: iMac (Retina 4K, 21.5-inch, 2017). eGPU : NVIDIA GeForce RTX 2060 (with a Razer Core X enclosure)


ReplyQuote
Bloodstainer
(@bloodstainer)
Eminent Member
Joined: 3 months ago
 

So, no solution?

I found many topics on this subject, but no solution... 🙁

https://www.reddit.com/r/eGPU/comments/9syu0q/nvidia_experience_detects_that_my_egpu_is/

 

 

This post was modified 1 month ago

Config: iMac (Retina 4K, 21.5-inch, 2017). eGPU : NVIDIA GeForce RTX 2060 (with a Razer Core X enclosure)


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

Which settings are you looking to change in Nvidia Control Panel. That message pops up when there’s no monitor directly connected to the Nvidia eGPU. You can buy a headless HDMI adapter to get around it.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
Bloodstainer
(@bloodstainer)
Eminent Member
Joined: 3 months ago
 

Hello @itsage. I'm looking to force Vsync to "on" because I have horrible tearing in some games.

I will try HDMI adapter, thanks.

This post was modified 1 month ago

Config: iMac (Retina 4K, 21.5-inch, 2017). eGPU : NVIDIA GeForce RTX 2060 (with a Razer Core X enclosure)


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@bloodstainer I don’t think that would fix the tearing issues. The Nvidia eGPU doesn’t drive the iMac internal display directly. The Radeon dGPU is what attached to internal display. I would recommend trying different driver versions from bootcampdrivers.com and see whether that helps.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
Bloodstainer
(@bloodstainer)
Eminent Member
Joined: 3 months ago
 

Oh ok, i see. Thanks for you help. I will test different drivers. 🙂

Config: iMac (Retina 4K, 21.5-inch, 2017). eGPU : NVIDIA GeForce RTX 2060 (with a Razer Core X enclosure)


ReplyQuote
bootz
(@bootz)
Trusted Member
Joined: 3 years ago
 
Posted by: @bloodstainer

Oh ok, i see. Thanks for you help. I will test different drivers. 🙂

I would avoid the headless display adapter and stick with the built-in Windows 10 graphic switching option. I have used both on an iMac internal display and the performance and overall response time is much better without the headless adapter.

Could you also disable the AMD dGPU and use the Intel iGPU + Nvidia eGPU? I know that Intel integrated graphics has options for V-Sync.

iMac 4k 2015 - 21.5" (iGPU only)
i5-5675R @ 3.10 GHz
8 GB RAM
Aorus Gaming Box 1070 via TB3 > TB2 adapter
Windows 10.0.17134


ReplyQuote
Bloodstainer
(@bloodstainer)
Eminent Member
Joined: 3 months ago
 

I have installed new bootcamp drivers (red gaming 2020) and enabled vsync via the Radeon panel. It works perfectly now and no more tearing.

Thank you very much. 😉

Config: iMac (Retina 4K, 21.5-inch, 2017). eGPU : NVIDIA GeForce RTX 2060 (with a Razer Core X enclosure)


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@bloodstainer That’s good to hear. Enjoy gaming with your eGPU!

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
(@sassanisgr)
New Member
Joined: 3 weeks ago
 

@bloodstainer

I had the same problem. I solved it with DIY Egpu setup 1x by nando4. I disabled the dgpu before windows start up and then nvidia control panel recognize my egpu, as well nvidia GeForce application.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote