2013 Mac Pro (nMP, 6.1, 2013, Trashcan) eGPU Setup Master Thread
 
Notifications
Clear all

[Solved] 2013 Mac Pro (nMP, 6.1, 2013, Trashcan) eGPU Setup Master Thread  

 of  8
  RSS

Sarwan Soomro
(@sarwan_soomro)
New Member
Joined: 7 months ago
 

It’s not working I have Mac Pro 6 with razer core x chroma with Radeon VII 

can someone help me out is there anyone in london who can come and do this for me and take payment 

also egpu is not recognised in windows but works in Mac Catalina using purge wrangler 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
orchoidizer
(@orchoidizer)
Active Member
Joined: 1 year ago
 

@exirion, Thanks a lot for that. Sorry for the delay.

 

Mid 2015 15-inch MacBook Pro Retina (2.2GHz Intel quad Core i7)
Intel Iris Pro Graphics. Thunderbolt 2, High Sierra - Bootcamp Win10 1903 (18362.39)
Razer Core X - Vega 64, Apple TB3 to TB2 Adapter ,- 2m TB2 cable


Exirion liked
ReplyQuote
Sarwan Soomro
(@sarwan_soomro)
New Member
Joined: 7 months ago
 

this is where I get stuck

i have mac pro 2013 trash can 12 core 64 gb ram d700 dual

i don't know what to do 

i have razer core x with radeon vii and rx 580 

i want to use with radeon vii

i have included all screen shots i have tried million times but i am getting stuck somewhere

tell me what should i do to get my egpu to work with windows bootcamp 1709 

i want to play windows steam games on mac pro and i want to know the solution 

can someone come to my house and do this for me i am prepared to pay 

 

 

 

thanks i live in barking london

sarsoom

This post was modified 6 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Jörg Henninges
(@jorg_henninges)
Active Member
Joined: 5 months ago
 

hi there,

im totaly new to all egpu stuff and im going to get an used razer core x to pair it with my 6,1.

gpu wise, i plan a vega64.

my 6,1 have a 2667v2 and 64gig with an dual d300. crossfire doesnt perform that well under macOS and windows and i hope i can gain some fps.

how much performance can i expect ?

second question is about windows. i use an external usb3.0 ssd to boot up win 10 pro ( 1909, 18363.778 ).

i dont use bootcamp to switch nor to install windows...am i affected with the "error12" issue ?

Mac Pro6,1 - E5-2667v2 - Dual D300 + Razer Core X'ed Vega64

 
2013 Mac Pro (FP D300 x2) [3rd,8C,E] + RX Vega 64 @ 16Gbps-TB2>TB3 (Razer Core X ) + macOS 10.14.6 [build link]  


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 1 year ago
 

You'll get a pretty significant performance boost over the d300 cards, no question. I have no experience running the vega64, but stepping up from the d700 to the RX 580 was a big leap for me.

As for running off an SSD without Bootcamp, you will get error 12. It doesn't matter if it's Bootcamp or not.

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
Jörg Henninges
(@jorg_henninges)
Active Member
Joined: 5 months ago
 

so i got the egpu up and running ( meanwhile with an gtx780 ), when i change the setup to an flashed hd7970, the card is not recognized in macos ( after i setup with PW ).
when i uninstall purge wrangler, system reports me a d700 beside of the two native d300. is the old thaiti card not compatible ?

Mac Pro6,1 - E5-2667v2 - Dual D300 + Razer Core X'ed Vega64

 
2013 Mac Pro (FP D300 x2) [3rd,8C,E] + RX Vega 64 @ 16Gbps-TB2>TB3 (Razer Core X ) + macOS 10.14.6 [build link]  


ReplyQuote
Sarwan Soomro
(@sarwan_soomro)
New Member
Joined: 7 months ago
 

Tell me how to make egpu work with Mac Pro 6 on boot camp I tried to do dsdt and everything but is there a guide on it on YouTube that shows step by step procedure as I get stuck on dsdt and making 64 memory 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
jcyeom
(@jcyeom)
New Member
Joined: 3 months ago
 

Hi everyone,

 

I have a question about Windows eGPU setup on 2013 Mac Pro.

 

I have Late 2013 Macbook Pro, 2013 Mac Pro, Razer Core X and Radeon RX Vega 64.

 

I could setup eGPU with great tools and great information of this site. But I have one serious problem.

 

  1. On Late 2013 15” Macbook Pro

 

1) Catalina – works fine with purge wrangler and purge nvda.

 

2) Windows 10 2004 – works fine with nothing.

Windows startup screen goes to eGPU’s external monitor.

Windows login screen is switched to the internal monitor – Nvidia GT 750M.

On Windows Device Manager, eGPU has error 43.

Once I disable and enable eGPU, error 43 is gone and it works fine.

 

  1. On 2013 Mac Pro (3.5 GHz 6 core and D700)

 

1) Catalina – works fine with purge wrangler.

 

2) Windows 10 2004 – I can get eGPU working but eGPU’s external monitor is not detected.

Initially I got error 12.

With automate-eGPU EFI and DSDT override, the error is changed to 43.

I tried to disable many combinations of PCI devices, but I couldn’t resolve error 43.

Just like on Macbook Pro, when I disable and enable eGPU, error 43 is gone.

But eGPU’s external monitor is not detected and Windows doesn’t use eGPU at all.

 

I tried many drivers on bootcampdrivers.com and many AMD official drivers.

I changed the graphics card to RX 460 and RX 5700 XT.

I changed Windows 10 to 1903 version.

 

But eGPU’s external monitor has never been detected on windows 10. The monitor is Dell 30” 2560*1600 with DVI input. It works fine on Windows 10 2004 of Macbook Pro and on Catalina.

 

Am I missing anything? Do you have any suggestions?

 

Thanks

Jeong Yeom

This post was modified 3 months ago

Late 2013 Macbook Pro, 2013 Mac Pro, Razer Core X and Radeon RX Vega 64.


ReplyQuote
AJ Scarcella
(@aj_scarcella)
Trusted Member
Joined: 1 year ago
 

One of the things that seems to consistently work for me (I literally did a fresh Windows install on my Mac Pro yesterday) is when I’m disabling PCI-to-PCI bridge devices in Device Manager, I always use the following ‘rules’:

  • View Devices by Connection
  • View hidden devices
  • Only disable PCI-to-PCI bridge devices that have nothing connected to them. As in, there is no plus to click to view devices connected to the bridge - they are fully standalone. 

This may help those of you still trying to get the Mac Pro with eGPU running. I’m running Windows 10 2004 and do not need any workarounds aside from disabling devices to get the eGPU recognised and working in Windows. 

The thing is though, drivers are currently limited to bootcampdrivers.com’s November 2019 release. There are serious issues with getting any releases after this working - generally, the display will completely crash out, forcing you to hard reboot. 

Performance for me currently on a clean system is... not great. It seems heavily throttled, more so than what I remember with certain games exhibiting severe FPS fluctuations. It seems driver related, but I’m nowhere near an expert in trying to diagnose the issue. I’m happy to test things if anyone more knowledgeable wants to offer an opinion. 

The other issue is that the success of getting this all working is currently contingent on one person creating a customised driver package. This person has also been on leave for a few months now, which means that anyone who needs drivers are just left in the lurch. None of the work that he does is particularly well documented and no one else is doing anything in the same space which basically means that the entire set up lives or dies on one person

At this point, I’m kind of wondering what the point of it all is. It’s been fun to tweak and play around but at some point, you kind of just want it to work so you can play games. 

Mac Pro 2013
OWC Mercury Helios FX
Radeon RX 580 8GB


ReplyQuote
 of  8