MacBook Pro 15 2018 Windows 20H2 with Blackmagic eGPU
 
Notifications
Clear all

MacBook Pro 15 2018 Windows 20H2 with Blackmagic eGPU  

 of  2
  RSS

cgWerks
(@cgwerks)
Trusted Member
Joined: 3 years ago
 

@drtung2708 I'm having a similar issue with my Blackmagic eGPU on my 2018 Mac mini. I've only gotten it working in 1809 so far, but I'll tell you what I did, as it might be of some help.

I think the key in 1809 (for me) is that the eGPU DOESN'T show up. If I install a fresh copy of Win10 1809, then hot-plug the Blackmagic (with my HDMI on the mini, obviously), it doesn't show up in Device Manager. Which means the AMD or BootCampDrivers installers won't work as is. I have to go to: Packages -> Drivers -> Display -> WT6A_INF and then right-click U0337288.inf (the number is different depending on the version) and install the .inf file.

It takes a bit, but eventually you'll get some dialogs (which might get hidden behind other windows, so you might want to clear/minimize them). It will verify if you want to install, and then give a success type box. But, it does install.

Then I shut down (not restart), switch the HDMI to the Blackmagic and start up the mini. Last night, after a couple of minutes, it just came right up. Other installs, I've had to hold the power button (power-off) a time or two before I got the Win10 screen via the HDMI on the Blackmagic. And, you'll then see the RX580 listed in Device manager.

Then (if memory serves), you have to install the set of AMD software, as that only installs the driver (and back in 2018, I remember it acted odd until I got the full set installed... like it would ramp the fans up randomly, etc.). I messed up last night trying to install a newer set of drivers, so I'll have to give it another go.

Anyway, maybe that can help? I think the issue I'm having in anything Win10 1903+, is that the BM does show up, and I'm right into the error 12 or other issues, which prevents anything from working. At least that's my theory at the moment. But, I'm stuck at 1809 so far. (I had zero luck with the apple_set_os efi boot loader, but I'm not sure I got it working correctly.)

As of July 24, 2021: 2018 Mac mini (i7, 16 GB RAM, 256 GB SSD) - Blackmagic eGPU (RX580) - Mojave 10.14.6 - (haven't succeeded past Win10 1809)


ReplyQuote
Drtung2708
(@drtung2708)
Active Member
Joined: 3 years ago
 

@cgwerks, thanks for your detailed solution. Unfortunately I can’t test it because I no longer own a BM eGPU. I hope it will be helpful for anyone else who has the same issue.

 

2018 15" MacBook Pro [8th,6C,H] + RX580 @ 32Gbps-TB3 (Gigabyte Gaming Box) + Win10 21H2


cgWerks liked
ReplyQuote
 of  2