Not able to disable PCI bridge with eGPU plugged in
 
Notifications
Clear all

Not able to disable PCI bridge with eGPU plugged in  

  RSS

Weekendiac
(@weekendiac)
Eminent Member
Joined: 3 months ago
 

I am using a RX 580 with my MacBook Pro, which works great, even under Windows (setup below).

Getting more performance I decided to switch to a Vega 64.

So installing a fresh Bootcamp etc. the device manager shows for sure code 12.

And here comes the problem. Usually I have to disable/enable the PCI root bridge of the eGPU (following the reports in this forum). But this option does not exist (see picture of the german Windows version), as far as the eGPU is connected. I got it just one time for a very short time until next reboot.

8ED4CCD1 663D 4B23 8898 A4045AA42069

So fundamentally it should work in Windows (under MacOS is without problems). I just need the disable/enable function.

Does anybody know how I can overcome this problem, for example in editing the registry?

by the way: RX580 is still Working fine.

This topic was modified 1 month ago

MacBook Pro 11,5 (15“ Mid 2015 with AMD Radeon R9 M370X, 16GB, 1TB SSD)
eGPU: Razer Core X Chroma with Apple TB3 to TB2 adapter and AMD Radeon Vega 64 using internal Display
Windows 10 pro build 2004 .19619 (by Windows Insider fast ring programm) and MacOS Catalina 10.15.5 with Purge Wrangler


ReplyQuote
creepypackets
(@creepypackets)
New Member
Joined: 3 weeks ago
 

@weekendiac, Are you getting the Code 12 issue? I am seeing the same thing on an Intel NUC 10. It seems like it is passing the HD audio in as well when connecting the eGPU and I am not sure if that is consuming too many resources but I cannot get around the issue. 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Weekendiac
(@weekendiac)
Eminent Member
Joined: 3 months ago
 

@creepypackets, yes I got error 12. That’s why I need to be able to disable the PCI-bridge, to get rid of error 12 to run my Vega 64.

I could solve the problem temporary by a fresh install of Windows Insiders 2004 latest version. Error 12 was there but directly after installing bootcampdrivers (April) I was once able to use toggler to switch the bridge on and off. Then error 12 was gone and even after every new start it still works. Fantastic! 
But it seems to me not a stable solution. After every restart ERROR 12 could come back and it makes me fear with every start of Windows. 🙁

Benchmarks are working, but it looks like handbrake on. 

So I still need this feature! But do not know how to change it as mentioned above. ?

 

 

This post was modified 3 weeks ago

MacBook Pro 11,5 (15“ Mid 2015 with AMD Radeon R9 M370X, 16GB, 1TB SSD)
eGPU: Razer Core X Chroma with Apple TB3 to TB2 adapter and AMD Radeon Vega 64 using internal Display
Windows 10 pro build 2004 .19619 (by Windows Insider fast ring programm) and MacOS Catalina 10.15.5 with Purge Wrangler


ReplyQuote