Notifications
Clear all

PCI-to-PCI Bridge error  

  RSS

jjjnagy
(@jjjnagy)
Active Member
Joined: 4 weeks ago
 

I've gotten my setup (in signature) to work reasonably well over the past few weeks, but as of today I can't seem to get it to work in Bootcamp at all.

I've previously only gotten the egpu to work when I hotplug it after booting into Bootcamp. When I went to hotplug it today, absolutely nothing was showing in Device Manager (even though I did get the Windows audio sound from plugging it in). I poked around a bit and found that whichever Thunderbolt bus I was using for the egpu would have the following error:

 

"This device cannot start. (Code 10)"

 

and say that there was a power failure. When I tried turning the egpu off and on again still plugged into the Mac Mini, Windows always bluescreens and gives the error "Kernal Security Check Failure."

 

Anyone have any experience with this? Is my best bet simply removing drivers and reinstalling?

2018 Mac Mini i7 10.15.5; Razer Core X 5600XT; Windows 10 1903


ReplyQuote
jjjnagy
(@jjjnagy)
Active Member
Joined: 4 weeks ago
 

Still seeking help with this--removed and reinstalled drivers but I still get the same error. Is this a hardware issue? Although this setup worked previously, I've been troubleshooting for a week and haven't figured out a solution. Any help would be appreciated. Thank you!

 

2018 Mac Mini i7 10.15.5; Razer Core X 5600XT; Windows 10 1903


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@jjjnagy, Have you checked to make sure Windows 10 1903 version are within .30 to .295? Do you use an EFI boot loader?

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
jjjnagy
(@jjjnagy)
Active Member
Joined: 4 weeks ago
 

@itsage, I'm running the .30 build

 

I've never used EFI boot loader before, but I have at this point tried everything other than that (include multiple fresh installs of Windows).

 

image

 

If it's helpful--I can't get the egpu to show up under Display Adapters in device manager at all. It just gives this error under PCI-to-PCI Bridge.

2018 Mac Mini i7 10.15.5; Razer Core X 5600XT; Windows 10 1903


ReplyQuote
jjjnagy
(@jjjnagy)
Active Member
Joined: 4 weeks ago
 

@itsage, using the EFI boot loader doesn't seem to have any effect. In fact, now I can't even get the computer to recognize the eGPU at all in Boot Camp. After I uninstalled drivers using DDU and I plug in the egpu to try to install AMD drivers, I get the error I screenshot above as well (and so I can't install any drivers since the tool says that no AMD devices are detected).

I guess it just amazes me that it could work fine for weeks and suddenly give such unusual errors (these days I'm wishing for Error 12...)

Everything still works fine under MacOS.

I suppose a fresh Windows install is my only remaining option, or?

 

2018 Mac Mini i7 10.15.5; Razer Core X 5600XT; Windows 10 1903


ReplyQuote