Radeon RX 5700 + Razer Core X + MacBook Pro 15" Late 2016
 
Notifications
Clear all

Radeon RX 5700 + Razer Core X + MacBook Pro 15" Late 2016  

  RSS

(@bennet_bruggemann)
New Member
Joined: 2 months ago
 

Hey,

first: sorry for my bad english. But this is why I start an new topic.

My problem is the known error 12. I know there are many instructions to solve it, but I'm German and because of that I dont understand everything and Google Translator is, as you know, not very helpful.

I would be very glad if someone can explain me step by step, for a non-native english speaker, what I should do.

Yesterday I tried it multiple times to solve the problem as in many other topics but either it won't work with my equipment or I didn't unterstand it correctly cause of too many technical terms or... I don't know...

So if someone could help me I would be very happy.

As you can see I have a MacBook Pro 15" Late 2016 with an i7, 512GB SSD, 16GB RAM and an AMD Radeon Pro 460; A Razer Core X; An ASRock Radeon RX 5700 8GB.

Yesterday evening I've already clean installed Windows 10, Version 1903 Build 18362.30. First I disabled Windows Auto Updates. After that Bootcamp had installed its drivers. Then I switched everythig off and did nothing else. (After the Win10 clean install I haven't connected the eGPU yet.)

I hope you can help me! Smile  

greetings

Bennet

MacBook Pro 15", Late 2016 | ASRock Radeon RX 5700 8GB | Razer Core X


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@bennet_bruggemann, This 2016 15-in MBP + Razer Core V2 + RX 5700 build is the closest to your configuration [build link]. Follow the Boot Camp steps and you should be able to use it in Windows without error 12.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 5700 @ 32Gbps-TB3 (Prototype eGPU Enclosure) + macOS 10.15.4 & Win10 1903 [build link]  


ReplyQuote
Fredrik Jonsson
(@fredrik_jonsson)
New Member
Joined: 2 months ago
 

@bennet_bruggemann,

 

if you haven’t fixed it yet, look at the top comment from this video (from Dex, which is me)

hope it helps!

This post was modified 2 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
(@bennet_bruggemann)
New Member
Joined: 2 months ago
 
Posted by: @itsage

@bennet_bruggemann, This 2016 15-in MBP + Razer Core V2 + RX 5700 build is the closest to your configuration [build link]. Follow the Boot Camp steps and you should be able to use it in Windows without error 12.

2 Days ago I found this build link, too. Now I'm able to use my eGPU.

But, for whatever reason, my iGPU doesn't work. In the device manager i can see the RX 5700 and also the Intel HD 530. So I have no picture on the internal display.

And is it normal that the eGPU only works on the Thunderbolt port on the rear right?

Warzone works that way, but no matter what my graphic settings are, I have an in-game maximum of 80fps and it often drops to about 30fps.

I have installed the Radeon Software Adrenalin 2020 Edition 20.3.1.

My Windows now is running on Build 1903 (18362.30). (18362.30 because 3 days ago I only read 1903, so I downloaded 18362.30 and isntalled windows. Is that a big problem or should I test ist with 18363.418?)

Some tips?

 

P.S: Or do I have to use the bootcampdrivers and not AMD's directly. If so, which one exactly from bootcampdrivers.com

This post was modified 2 months ago

MacBook Pro 15", Late 2016 | ASRock Radeon RX 5700 8GB | Razer Core X


ReplyQuote
(@bennet_bruggemann)
New Member
Joined: 2 months ago
 

@itsage, Also only cold-plug works. Even though it will always be displayed in EFI boot that no eGPU was detected.

This post was modified 2 months ago

MacBook Pro 15", Late 2016 | ASRock Radeon RX 5700 8GB | Razer Core X


ReplyQuote