HELP! Bootcamp windows 1903. RX 580 on mac mini 2018 acting like a secondary dis...
 
Notifications
Clear all

HELP! Bootcamp windows 1903. RX 580 on mac mini 2018 acting like a secondary display?  

  RSS

Luca Hahn
(@luca_hahn)
Active Member
Joined: 7 months ago
 

Hello 

First i'd like to say a huge thanks to this Community for all their posts that helped setting up my eGPU.
I recently find a working configuration but a small problem remains.

I installed apple_set_os.efi to boot in Windows and now the rx 580 is detected almost at every boot up.

Following mainly the advice and  set up from @sdedalus1's post:

https://egpu.io/forums/builds/2018-mac-mini-rx-580-16gbps-tb2-akitio-thunder2-macos-10-14-6-win10-1903-external-ssd-sdedalus1/#post-75654

it only fails if I forget to plug it in, when apple_set_os.efi is running and ask me to.

I don't do the thunderbolt switching because it won't detect the graphic card afterwards or give me error 12. Everything seemed to work fine the past few days both hdmi from mac mini and egpu displayed the same "desktop" or "image", (pretty much as the mirror setting in the mac os system preference) and I was able to launch the game when plugged to the egpu and take advantage of that precious computing power.

Note that as I am on  a Mac Mini i have to plug my hdmi on the Mac mini port at boot up and switch to the egpu port when at desktop (if i don't, I get a black screen)

problem:
When I get to the desktop and switch to the egpu, it is detected and running correctly. When I look at the device manager I have both Intel UHD 630 and Radeon RX580 as graphic card with no error 12. But its behaving like a second screen and not displaying the "main desktop", it is displaying a second one with only the task bar and Windows menu below. 
So i can slide a window like internet explorer for example in the "egpu screen" but when i launch a game it is displayed on the " main screen" or through the mac mini hdmi port to be precise. 

Added note: when I launch a game the graphic card fans start to spin and performance are clearly helped if you compare to no egpu, but still is way less than when you take the output from egpu's hdmi port. 

The weird thing is that before today both hdmi port would display the same thing so i just have to switch on the egpu port and lauch the game from there and it worked perfectly. but now it just doesn't. I switch to egpu hdmi port and I get an image of the desktop but with no app icons on it and as I said earlier just the task bar and Windows menu below the screen.

It may come from a setting i don't know of in Windows I guess, but can't seem to find anything that helps in the display or graphic settings, maybe I am some kind of blind or Something.
Thanks for your answers, and please keep in mind that I am still all new to this (especially on Windows), and french so I may lack of precise words to describe the situation. I hope I described the problem correctly.
Thanks again. 

Mac Mini 2018 Intel core i5 -8500B CPU @ 3Ghz / Intel graphic 630 UHD/ Razer Core X/ Pulse Sapphire Radeon RX580/ Mac os 1.14.6/ Bootcamp Windows 1903 on internal SSD 500Go


ReplyQuote
jangoloti
(@jangoloti_1)
Estimable Member
Joined: 1 year ago
 

I have a similar issue on Mac OS I need to unplug the HDMI cable when the eGPU is running. I tried an HDMI Splitter but it did not work.

This post was modified 7 months ago

Mac Mini 2018 i7 16 GB 512 GB SSD, Mac Book Pro 2016, HP Z31x, Sonnet Breakaway Box 550 W, Nitro+ RX5700 XT, KFA2 SNPR 1060 6GB eGPU,...


ReplyQuote
Luca Hahn
(@luca_hahn)
Active Member
Joined: 7 months ago
 

@, Nobody here can help out?

 

Mac Mini 2018 Intel core i5 -8500B CPU @ 3Ghz / Intel graphic 630 UHD/ Razer Core X/ Pulse Sapphire Radeon RX580/ Mac os 1.14.6/ Bootcamp Windows 1903 on internal SSD 500Go


ReplyQuote
sdedalus1
(@sdedalus1)
Eminent Member
Joined: 4 years ago
 

@luca_hahn, it sounds like the Mini is treating the egpu connected like a second display and not the main display. My process goes: boot up via apple_set_os.efi with hdmi plugged from mac mini to monitor. After booting to desktop and egpu is recognized and loaded, switch input on monitor to egpu, which is plugged in with displayport. Then I see a second egpu desktop. Unplug hdmi between Mini and monitor. My display on the egpu displayport input then becomes my main desktop. Are you unplugging the hdmi from mini after egpu is connected? And switching to a different input on your monitor? If you are and it still doesn't work, try changing the connection between egpu and monitor from hdmi to displayport, if you have that option on your gpu and monitor. Otherwise, try changing the display preferences after unplugging hdmi??

 

2018 Mac Mini (8th,4C,B) + RX 580 @ 16Gbps-TB2 (AKiTiO Thunder2) + macOS 10.14.6 & Win10 1903 // Win10 on external SSD (build link)

 
2014 13" MacBook Pro [4th,2C,U] + RX 580 @ 16Gbps-TB2 (AKiTiO Thunder2) + macOS 10.13.6 & Win10 1903 [build link]  


ReplyQuote