Setup in progress - MBP 2016 15" - AKiTiO Node Pro - 5700 XT
Clear all

Setup in progress - MBP 2016 15" - AKiTiO Node Pro - 5700 XT  


Active Member
Joined: 9 months ago

Hello, I hope a "work in progress" is allowed here. I have not yet been able to get it working after 2 days of attempts. So I figured I could make a thread as in progress to ask questions and maybe get some help.


I just nuked my Boot Camp partition since Windows stopped booting. Here is roughly what I did in my first round. I roughly followed this guide. But tried to fill in some blanks myself. These steps are specifically in the order I did it (I took notes).

  1. Install W10 build 18362.30
  2. Turned on "notify only" for auto updates of Windows
  3. Update to 18362.295 (from here)
  4. Downloaded DDU
    1. Safe mode 
    2. Run with all checkboxes for AMD
    3. Run with all checkboxes for Nvidia
    4. Restart
  5. Tried to install AMD drivers from the official website - This gave mer error 173, no AMD hardware detected
  6. Made a restore point in windows
  7. Boot back into macOS
  8. EFI
    1. Make a new FAT partition - I didn't have a USB drive
    2. Download the files for automate-eGPU EFI v1.0.5 (from here)
    3. Place into new partition
  9. Boot with EFI - I probably had the eGPU connected at this point, not sure if that's good
    1. It said "eGPU not detected" but it seemed normal reading around so I ignored it
  10. Check Device Manager for what is there


    1. Screen Shot 2020 08 06 at 12.09.38 PM
    2. Is this a correct state so far? I didn't check what the yellow warning was for to be honest.
  11. Downloaded Intel Graphics via "Intel Driver & Support Assistant"
    1. It installed "Intel Graphics - Windows 10 DCH Drivers"
    2. Now the state in Device Manager is like this:
    3. IMG 288AAEC592E8 1
  12. Try to HOT-PLUG the eGPU and install AMD Drivers again - Same 173 error
  13. Download Red Drivers from
    1. This at least Installs
    2. At this point the screen becomes super small resolution
    3. After the install I go to check the Device Manager again, hoping it will say 5700 XT
    4. I get this:
    5. IMG 50BACD8C916A 1
  14. Restart - I don't remember if I used EFI boot here or not, or if I removed the eGPU or not...
    1. Device Managers shows me this - I guess I don't have the eGPU connected here?
    2. IMG 78AC01FFDAB5 1
    3. The 455 is the integrated.. or I think it is called discrete GPU in this macbooks case?
  15. Boot into macOS
  16. Read some guides
  17. Following this guide
    1. From step 5 I copied the dsdt.aml file into my FAT partition
    2. I ignored step 6 because I am stupid and thought I was not on Catalina, so I ignored all Catalina mentions
    3. Reboot to EFI - Loading Windows Forever
  18. Reboot to macOS
  19. Delete the .aml file because I wanted to try something else
  20. I JUST notice at this point that error 12 was actually a little notice inside the device manager on the device itself. I had googled for error 12 quite a lot withoout being able too see how to identify it. So seeing as error 12 was at least some kinda "right track" and widely documented I was at least a bit optimistic at this point.

Now is the steps I took where I had to nuke my install. So reading around I figure that the top left port is where I should be using the TB3 cable. But then I read more on the setup guide and in step 3 for the 15" it says "External GPU works reliably using the right-side ports that connect to the PCI Express x4 Controller – 1909". 

  1. Move eGPU to top right port (so far I used top left)
    1. Disable the x16 and x8 PCI ports.
    2. Reboot to EFI - Blue Screen
    3. Reboot to Windows - Blue Screen
    4. Reboot to anything - Blue Screen Blue Screen Blue Screen Blue Screen
    5. Try safe mode - Blue Screen
    6. Try restore point 2 - Blue Screen
    7. Try restore point 1 - NOPE error was something like "windows needs to have system protection turned on". I could see the point, just unable to select it.
  2. So at this point I deleted the W10 partition, the little FAT partition and started to re install.

At the writing time of this post I have re partitioned the HDD and installed Windows 10 and will start over. When I installed it the device manager already shows me that I have "AMD Radeon Pro 455". I am not sure if it did this before, and the reason I saw the generic name earlier was because of DDU?

Not sure exactly what I will be doing differently, but I think something like this: 

  • Run DDU
  • Keep using left side of ports
  • Find error 12 asap
  • Generate the DSDT file for my specific laptop
  • Try some timing-plug ins

Some questions

  • How exactly do I know when it all works - is it when 5700 XT shows up properly in the device manager?
  • When no eGPU is connected - I am supposed to see only one entry under Display Adapters?
  • When eGPU is connected - I am supposed to see two entries, one for dGPU and one for eGPU?
  • When I hot plug the device - I see PCI entries coming and going, but nothing under Display Adapters changes (ill verify this..) - Is that correct?
  • MacBook pro 2016 15" - Should I use top left port?
  • Anything I specifically missed or did wrong on the steps above?

I'll post updates in this thread with things I try, what works and what doesn't.

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Pro) + macOS 10.15.5 & Win10 [build link]  

Active Member
Joined: 9 months ago

I also saw that error 12 can be solved by using the insider fast version of windows just now so maybe I should try that one?.

Another question, since I use the 2016 model I don’t have the “large allocation” like later models. The specific solution to this is:

  • to use the EFI boot plainly?
  • EFI boot WITH DSDL file for my MacBook  inside?
  • .. and other, more intrusive, system file patches
  • .. or something else

thanks again

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Pro) + macOS 10.15.5 & Win10 [build link]  

Active Member
Joined: 9 months ago

Alright so I guess I am quite lucky, because I got it working on my second try. Not even have to deal with disabling thunderbolt ports or anything like that so far.

I actually recorded the whole thing, so I might go through it to see the exact steps I made, edit a little bit and upload it at some point. Because I believe I am the only one with this !exact! setup (node pro and 5700XT).

I've had one crash so far, I plugged in a mouse on the left side of the device. Apparently that was not fine.

2016 15" MacBook Pro (RP455) [6th,4C,H] + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node Pro) + macOS 10.15.5 & Win10 [build link]