Trying to accelerate internal iMac display, but eGPU not showing as High Perform...
 
Notifications
Clear all

Trying to accelerate internal iMac display, but eGPU not showing as High Performance GPU option  

  RSS

jonathanheron
(@jonathanheron)
New Member
Joined: 7 months ago
 

Hi,

When I try to configure Power Saving GPU / High Performance GPU, both options list the same GPU and the eGPU is not used.

Here's my setup:

  • iMac 27" 2017 with Radeon Pro 575 GPU
  • Razer Core X with RTX 2060
    • Standard Driver from Nvidia.com
    • Connected to TV via HDMI
  • Windows 10 Pro, version 1903, build 18362.729

 

The setup I want to have

Accelerate the internal iMac display without any need to hook up an external display.

 

What I've tried

When I set the TV (connected to RTX) to act as an extended desktop, and set the TV as my main display, if I start Unigen Valley in a window on the TV it will be accelerated by the RTX. If I then move the window to the iMac's internal display, the Unigen continues to run on the RTX (with a 25% performance haircut).

But, if I run mirror desktop between the two screens, Unigen will never run on the RTX.

When I go into Display > Graphics Settings, and try to set graphics preferences for an app, the Power Saving GPU and the High Performance GPU are both set to the same GPU. Usually that's the Radeon Pro 575, but sometimes it will show up in the UI as the RTX, but running Unigen shows the 575 is still being used.

 

Any advice on how I can get the RTX to accelerate games on the internal iMac display?

This topic was modified 7 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
frenchbulldog
(@frenchbulldog)
Active Member
Joined: 2 months ago
 

In the same boat as you. Did you happen to find any luck?

📈 EGPU -- Razer Core X, MSI Radeon RX Vega 56, TB3 to TB1/2 Adapter // 💻 Computer 1 -- MacBookPro11,3 @ 10.15.4, 2.8ghz i7 4980HQ, 16gb ram, Iris Pro iGPU, GT750M 2gb dGPU, works in OSX & BootCamp! // 🖥 Computer 2 -- iMac13,2 @ 10.15.5, 3.4ghz i7 3770, 16gb ram, GTX675MX 1gb dGPU, works in OSX only 🙁


ReplyQuote