Unable to boot from thunderbolt drive (bootcamp) Help.
 
Notifications
Clear all

Unable to boot from thunderbolt drive (bootcamp) Help.  

  RSS

DeliciousAlbatross7
(@deliciousalbatross7)
Active Member
Joined: 3 months ago
 

Hi, I have been trying to boot windows from a thunderbolt drive on my MBP 16". However, I am facing some difficulty. It seems that when booting from an external drive, the thunderbolt 3 controller is being disabled. 

I have tried booting the same copy of windows from the same drive on my 2017 MBP 13" and it worked perfectly.

I also swapped the enclosure to a USB 3.2 one instead of thunderbolt using the same NVMe(with the same copy of windows), on the MBP 16", and it worked fine. 

Furthermore, after i successfully booted into windows using the USB 3.2 enclosure on the MBP 16", I looked at Device Manager and found that all the 4 Thunderbolt ports are missing in the Device Manager. 

I also have my eGPU setup working on bootcamp that is installed on the internal drive. So i cloned the working copy of bootcamp partition onto another USB 3.2 drive, and it successfully booted also. However when i connect my eGPU(Razer Core X Chroma), the eGPU didn't show up, but the mouse and keyboard that is connected to the eGPU did work perfectly, even the Ethernet port on the Razer Core is working as normal. 

I have already disabled T2 secure boot. So i don't know what's the issue that is preventing the MBP 16" to see/connect thunderbolt devices when booting from an external drive. 

Would be glad if anyone can enlighten me. Thanks

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.5 & Win10 1903 [build link]  

ReplyQuote