Windows 10 1903 w/ TB3 on a MacBook Pro = Glitches and annoyances?
 
Notifications
Clear all

Windows 10 1903 w/ TB3 on a MacBook Pro = Glitches and annoyances?  

  RSS

teltersat
(@teltersat)
Eminent Member
Joined: 2 years ago
 

Hey guys,

Just wanted to check if you guys had any experience with the new Windows 10 update. I'm having two "glitches" or so to say:

  • Windows requires a restart after a cold boot to use the eGPU. Previously I would be able to start using the eGPU straight away, but now I have to restart after the first boot to get the eGPU to work
  • If I switch display inputs in one of the monitors (I also have a desktop) Windows thinks the monitor disconnects for a second, and upon reconnecting, Night Shift would get lost in the "disconnected" panel. This was not the case with the previous release sadly.

Have you encountered these issues? Not sure if these are very specific to an MBP in Boot Camp, or if they are applicable to any TB3 eGPU solution.

MacBook Pro Touch Bar 2017 15" + Mantiz Venus MZ-02 + AMD Radeon Vega 64

 
2017 15" MacBook Pro (RP560) [7th,4C,H] + RX 580 @ 32Gbps-TB3 (Mantiz Venus) + Win10 [build link]  


ReplyQuote
McBanjo
(@mcbanjo)
Active Member
Joined: 2 years ago
 

I just started downloading the 1903 update and held off for now seeing as you're having some issues.

I've not been able to get my eGPU to work on cold boot with 1803 and I need a restart, so might not be a 1903 specific thing...

I'm on a MacBook Pro 13" 2018 + Akitio Node Pro + AMD Vega 64

I'm hoping that I can create a full restore point for my Windows before trialing 1903.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
chocomonsters
(@chocomonsters)
Eminent Member
Joined: 4 years ago
 

I was running Windows 10 on MacBook Pro 2018 15in with TB3 external drive (native install without BootCamp partition) and Akitio Node/Nvidia RTX 2080.  Initially, I had some difficulty updating to 1903.

I did a fresh Windows 10 1903 installation on my TB3 external drive (Akitio Node Lite with Samsung 970 EVO NVMe).  Direct installation performed from a Windows 10 USB drive without BootCamp partition.   No difficulty installing TB3 DCH driver, updated AMD driver, and Intel Network adapter drivers.  I have two external monitors attached to Nvidia RTX 2080.  

I am not experiencing any problem with eGPU (I boot with eGPU attached).

I am not experiencing any problem if I disconnect my external monitor from Nvidia RTX 2080 to MacBook Pro AMD Radeon 560X connection.

Windows 1903 has been a rock solid so far.

MacBook Pro 15" 2018
MSI Ge Force RTX 2080
Akitio Node
Windows 10 20H2 / Akitio Node Lite / Samsung SSD 970 EVO


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 4 years ago
 

Yesterday I reinstalled Bootcamp on my 2018 15’ i9, updated the Windows all the way, and connected the egpu flawlessly. The only issue I had is that the Nvidia drivers were not installing. It Said something about not being compatible. I have a 2080ti, I found the solution by installing the DCH version of the driver and it worked. I have no idea what that means, does anyone know? Ive been using the same setup for ever and I think Ive never installed a DCH nvidia driver before.

2017 15" MacBook Pro (RP555) [7th,4C,H] + GTX 1080 Ti @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.12.6 & Win10 [build link]  

ReplyQuote
Gareth Rees
(@gareth_rees)
Eminent Member
Joined: 2 years ago
 
Posted by: Rycco

Yesterday I reinstalled Bootcamp on my 2018 15’ i9, updated the Windows all the way, and connected the egpu flawlessly. The only issue I had is that the Nvidia drivers were not installing. It Said something about not being compatible. I have a 2080ti, I found the solution by installing the DCH version of the driver and it worked. I have no idea what that means, does anyone know? Ive been using the same setup for ever and I think Ive never installed a DCH nvidia driver before.

DCH drivers are a requirement for Windows 1903

Dell Latitude 5491 14" BIOS 1.12.1 + Active PCH cooling | Core i7 8850H + liquid metal - https://valid.x86.fr/z6xi8n | 32GB DDR4 2400 | Samsung 500GB 850 EVO | MX130 + liquid metal | Logitech Z-2300 | Razer Death Adder Elite | Corsair K70 Rapdifire | R43SG v1.2 + RX 570 4GB


ReplyQuote