late-2016 13" Macbook Pro TouchBar + [email protected] (ASUS ROG XG Station2) + macOS10.12.5&Win10 [mrtips]^  

  RSS

mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 24, 2017 12:38 am  

Hey, just want to say thanks!

Got my new set up today and have it running nicely on bootcamp and mac on my 13" 2016 Macbook Pro (TouchBar) because of you guys.

  • ASUS ROG XG Station 2
  • EVGA 1080Ti Founders edition
  • 13" 2016 Macbook Pro (TouchBar)
  • 10.12.5 and Windows 10 64bit

Followed this post to the letter but had an issue where the firmware update tool wouldn't see the ASUS to update it so I was stuck on v21 and would get the occasional BSOD.

I eventually found a link to the correct Intel thunderbolt software installer and everything is now working great.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 24, 2017 12:39 am  

No error 12 at first, for which I'm grateful but I do now have an issue where the internal display just stays on the windows boot logo and the iris graphics card is not recognised when the eGPU is connected (gets a generic windows display driver). It's broken hot-plugging too. The eGPU display works fine though.

I didn't make any changes so it must have been a windows auto update 🙁

Huh, so maybe it's now developed error 12, are these the symptoms?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 25, 2017 2:31 am  

To answer my own question, it seems so. Confirmed by the fact the apple_set_os.efi trick fixes the symptoms.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 25, 2017 2:32 am  

Cuda-Z output

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1815
June 25, 2017 7:41 am  

Would you mind posting CUDA-Z output from Windows to confirm performance of over 2000MiB/s host-to-device? The macOS version brings in lower numbers so cannot be used as a reliable measure there.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 25, 2017 8:52 pm  

It seems ~1680 is all it's going to give.  To satisfy my curiosity I tested Mac and Windows with both back left (closest to the screen) and front left Thunderbolt port (ignored the right as they are stated to be less performant by Apple) on the ASUS's v23p and v25 firmwares.

For bonus points I configured and tested my work 15" MacBook Pro for comparison.

Not much in it across the board. Here are the results:

23p : Mac 

Back

Front

25 : Mac

Back

Front

23p : Win

Back

Front

25 : Win

Back

Front

15" Late 2016 MacBook Pro (TouchBar)

25 : Mac : Back

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1815
June 25, 2017 8:57 pm  

@mrtips, are you using a certified 40Gbps TB3 cable? We've seen pared back performance like this when using a 20Gbps TB3 cable.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
rushvora
(@rushvora)
Trusted Member
Joined: 2 years ago
Posts: 72
June 25, 2017 9:54 pm  

Hmm. Mine's H2D maxes out at 1550 MiB/s. Device to Host is 2600 MiB/s. RP455 2016 15" MBP, Mantiz Venus, 1080Ti. Using the default TB3 cable that came with the Venus.

late-2016 15" MacBook Pro RP455 + [email protected] (Mantiz Venus) + Win10 // external SSD


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1815
June 25, 2017 10:04 pm  

@mrtips, @rushvoro, please switch your Windows power profile to 'high performance' and re-do CUDA-Z tests to exclude low power modes causing reduced performance.

If still getting less-than-1600MiB/s host-to-device performance then consider tunatoro got this when using a 20Gbps Tb3 cable. When he replaced the cable with a 40Gbps Tb3 one, performance jumped up to just under 2100MiB/s. Details in this link:

https://egpu.io/forums/builds/acer-aspire-v17-nitro-black-editionakitio-nodegtx1070-win-10/

Consider asking your eGPU enclosure vendor for a 40Gbps TB3 cable or partial refund (~US$60) if the supplied one isn't per advertised spec and requires replacement.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
rushvora
(@rushvora)
Trusted Member
Joined: 2 years ago
Posts: 72
June 25, 2017 11:09 pm  

Nope, still below 1600MiB/s. I was already in high performance mode though. 

Will get the Cable Matters 40GBPS cable and test. Should get it by Tuesday evening (USA PDT) If I get the same result, I can return the cable. If it does improve, we'll have to see if other Mantiz Venus owners are having similar CUDA-Z results!

late-2016 15" MacBook Pro RP455 + [email protected] (Mantiz Venus) + Win10 // external SSD


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 26, 2017 1:47 am  

I’ll test the performance setting when I get home. 

I’m using the included 50cm unbranded cable from ASUS so it’s unclear what rating it has. Unfortunately TB3 cables seem to be very thin on the ground in New Zealand but I’ve ordered a Belkin one from Apple to test with which should be here tomorrow. If it doesn’t positively affect the stats I’ll return it and try and get another one via the US.

will let you know.

 

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 26, 2017 7:56 am  

OK no dice with the performance setting unfortunately, it was already set to high.

I'll try the new cable tomorrow.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 2 years ago
Posts: 489
June 26, 2017 8:00 am  
Posted by: rushvora

Nope, still below 1600MiB/s. I was already in high performance mode though. 

Will get the Cable Matters 40GBPS cable and test. Should get it by Tuesday evening (USA PDT) If I get the same result, I can return the cable. If it does improve, we'll have to see if other Mantiz Venus owners are having similar CUDA-Z results!

Can you disconnect SSD and Test again? 

Mantiz: ShopFacebookTwitter


ReplyQuote
rushvora
(@rushvora)
Trusted Member
Joined: 2 years ago
Posts: 72
June 26, 2017 9:03 am  
Posted by: Mymantiz_John
Posted by: rushvora

Nope, still below 1600MiB/s. I was already in high performance mode though. 

Will get the Cable Matters 40GBPS cable and test. Should get it by Tuesday evening (USA PDT) If I get the same result, I can return the cable. If it does improve, we'll have to see if other Mantiz Venus owners are having similar CUDA-Z results!

Can you disconnect SSD and Test again? 

SSD is not through Mantiz Venus, it's by itself, in another USB-C port altogether. I don't have anything connected to the Venus, other than the GPU. 

late-2016 15" MacBook Pro RP455 + [email protected] (Mantiz Venus) + Win10 // external SSD


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 2 years ago
Posts: 489
June 27, 2017 3:42 am  
Posted by: rushvora
Posted by: Mymantiz_John
Posted by: rushvora

Nope, still below 1600MiB/s. I was already in high performance mode though. 

Will get the Cable Matters 40GBPS cable and test. Should get it by Tuesday evening (USA PDT) If I get the same result, I can return the cable. If it does improve, we'll have to see if other Mantiz Venus owners are having similar CUDA-Z results!

Can you disconnect SSD and Test again? 

SSD is not through Mantiz Venus, it's by itself, in another USB-C port altogether. I don't have anything connected to the Venus, other than the GPU. 

after tested, only MBP Bootcamp showed that result as you mentioned above. and for the windows laptop, the H2D is normal.

 

Mantiz: ShopFacebookTwitter


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 27, 2017 9:57 am  

 The Belkin cable performs worse than the included one at around 14ooMiB/s. That might not be too surprising as it's a 2m cable.

I'm going to return it and then I'll source another. Hopefully @rushvora has better luck with the cable matters one and i'll order one of those or this one from caldigit.  https://9to5mac.com/2017/03/01/caldigit-1-and-2-meter-thunderbolt-3-cable-40-gbps-10-watt-power-delivery/

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
rushvora
(@rushvora)
Trusted Member
Joined: 2 years ago
Posts: 72
June 28, 2017 12:19 am  

No luck, the Cable Matters 40gbps cable actually performs a bit worse, at roughly 1450-1480MiB/s. Something to do with Windows on the MBP I suppose?

I wonder how much of an impact this is having on gaming performance.

John from Mantiz says his testing showed similar results, full H2D performance on Windows laptops, but only 1500MiB/s on the MBP/Bootcamp.

Also, some of the guides mentions installing a Thunderbolt driver. I never did that with the Venus. Should I try installing an updated Thunderbolt driver? If so, which one? Not sure which of the TB drivers from Intel applies to my setup, or if any of them apply.

late-2016 15" MacBook Pro RP455 + [email protected] (Mantiz Venus) + Win10 // external SSD


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1815
June 28, 2017 3:16 am  

rushvora, what is your CUDA-Z host-to-device measure under Windows? If everything is working OK it should be near 2254MiB/s as shown at the bottom of https://egpu.io/external-gpu-implementations-table

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
rushvora
(@rushvora)
Trusted Member
Joined: 2 years ago
Posts: 72
June 28, 2017 4:41 am  
Posted by: nando4

rushvora, what is your CUDA-Z host-to-device measure under Windows? If everything is working OK it should be near 2254MiB/s as shown at the bottom of https://egpu.io/external-gpu-implementations-table

God damn, there's a MBP with 2200MiB/s. Which means mine should be capable of 2200MiB/s as well. With the default cable, it's 1550MiB/s. With the "cable matters 2m 40gbps" cable, it's 1450MiB/s. Dunno if I should try another cable or do something else? I don't think it's the cable since I doubt both Cable Matters and Mantiz have sent 20gbps cables. I have no idea how to fix this.

I wonder if other Mantiz Venus owners can chime in and share their CUDA-Z results in Windows on a TB3 MBP. I believe @theitsage has a Venus as well?

What doesn't worry me too much is the benchmark that @ddqp posted with the new and old firmware, it didn't make any difference in heaven benchmark.

late-2016 15" MacBook Pro RP455 + [email protected] (Mantiz Venus) + Win10 // external SSD


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 28, 2017 5:09 am  

I'm borrowing an intel skull canyon NUC tomorrow to rule out my laptop as the cause before I look at any more cables.

I have installed thunderbolt drivers and I'm getting similar performance to you so I doubt its that but here you just in case. I had to install these in order to do the firmware update on the ASUS.

https://downloadcenter.intel.com/download/26486/NUCs-Thunderbolt-Bus-Driver-for-Intel-NUC-Kit-NUC7i5BN-and-NUC7i7BN

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


rushvora liked
ReplyQuote
rushvora
(@rushvora)
Trusted Member
Joined: 2 years ago
Posts: 72
June 28, 2017 6:43 am  
Posted by: mrtips

I'm borrowing an intel skull canyon NUC tomorrow to rule out my laptop as the cause before I look at any more cables.

I have installed thunderbolt drivers and I'm getting similar performance to you so I doubt its that but here you just in case. I had to install these in order to do the firmware update on the ASUS.

https://downloadcenter.intel.com/download/26486/NUCs-Thunderbolt-Bus-Driver-for-Intel-NUC-Kit-NUC7i5BN-and-NUC7i7BN

What's puzzling is that there's a 13" 2016 MBP that got 2200MiB/s with the Akitio Node. So the 15" MBP should definitely be capable of 2200. 

late-2016 15" MacBook Pro RP455 + [email protected] (Mantiz Venus) + Win10 // external SSD


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 28, 2017 9:27 am  

Yeah I’m lucky enough to have access to a 13 and a 15 and got near identical H2D on both. 

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


rushvora liked
ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 30, 2017 10:26 am  

OK results from the Intel Skull Canyon NUC indicate the Mac is at fault here.

Everything remained the same except the host.

With the included ASUS 50cm cable:

and the Belkin 2m cable:

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


theitsage liked
ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
June 30, 2017 10:31 am  

 I suppose this is another implementation for the list too, let me know if you want a separate post for that?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3207
June 30, 2017 2:15 pm  
Posted by: mrtips

 I suppose this is another implementation for the list too, let me know if you want a separate post for that?

Please post a separate post. Thank you for getting to the bottom of it. There are so many variations in an complete eGPU setup that it's hard to know the actual performance until you put everything together.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
lukicharms
(@lukicharms)
Eminent Member
Joined: 1 year ago
Posts: 28
July 6, 2017 1:02 pm  
Posted by: mrtips

 I suppose this is another implementation for the list too, let me know if you want a separate post for that?

Did you make a separate post for this implementation?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mrtips
(@mrtips)
Active Member
Joined: 1 year ago
Posts: 15
July 11, 2017 11:09 am  

Sorry haven't got round to it, I've been a bit overloaded at work recently (and playing PUBG!). 

Will do so now.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote