2012 13" MacBook Pro [3rd, 2C,M] + RX 580 @ 10Gbps-TB1>TB3 (Mantiz Venus) + macO...
 
Notifications
Clear all

2012 13" MacBook Pro [3rd, 2C,M] + RX 580 @ 10Gbps-TB1>TB3 (Mantiz Venus) + macOS 10.14.6  

  RSS

applejuice
(@applejuice)
New Member
Joined: 2 months ago
 

System specs 

  1. 2012 13-inch Macbook Pro
  2. MacOS 10.14.6 Mojave
  3. Intel i7 2,9 GHz
  4. 16 GB RAM 1600MHz DDR3
  5. Intel Graphics HD 4000 1536MB

 

eGPU hardware

  1. Preowned Sapphire Pulse Radeon RX 580 8GB
  2. Mantiz Venus with stock Power Supply
  3. Apple Thunderbolt 2 Cable
  4. Apple Thunderbolt 3 to Thunderbolt 2 adapter

 

Hardware pictures (WIP)

 

 

Installation steps

Hello, I am new to this eGPU stuff, so every input and advice are appreciated. First of all, I get a Mantiz Venus from a friend of mine and think of reviving my old 13-inch mid 2012 Macbook Pro. After browsing some of the guide inside this forum, I decided to first work on single OS instead of dual OS. I considered my first attempt as a failure, as follows :

  1. I do a fresh install on my 1TB Samsung SSD, used the whole drive for this.
  2. Installed purge-wrangler
  3. I use an Apple TB2->TB3 connector and an Apple Thunderbolt cable to connect the enclosure to my Mac.
  4. At first it's not detecting the eGPU, and wonders if I should enable T82, but after few cable reconnecting and restarting with eGPU turned on and connected, it managed to detect my eGPU as Ellesmere Family RX 580 .
  5. Using Activity monitor to check the GPU, and 2 GPU detected, but :
    1. My GPU shows only single Intel Graphics HD 4000
    2. I tried to use set-eGPU to force all application to use eGPU, it works, shown from the Activity Monitor that when I play videos, resource used was from Radeon RX 580, but on System Information, it still only shows single Intel Graphics HD 4000.
    3. I tried to restart several times and it still the same
    4. Another issue is my Sapphire Pulse fan not working at all (is this normal?) Forgot to plug 8-pin PSU, Fan is okay

Temporary Conclusion

I think missed some step, and I wonder if it has anything to do with my preowned Sapphire Pulse RX580, so at this moment, I'm going to get a Windows 10 and trying bootcamp first to check if anything wrong with it's firmware / bios. Something to be noted for, my Macbook did not detect my Mantiz Venus as is, instead it was detected as TUL TBX 550CA. I wonder why.

Whilst waiting for Windows OS downloaded, I tried to check Mac eGPU troubleshooting and found out that my first attempt might not be a failure. Mantiz Venus shares the same chip as TUL TBX 550CA, so it was not an error (?).

 

My eGPU is constricted to 300MHz because I'm using Built-in monitor. So I tried using second monitor, connected using Display Port. It works fine. But, eGPU seems to still be constricted at 300MHz. Uploaded MAC.log, Thunderbolt.log, GPUs.log and eGPU.log here.

Still trying to find out why eGPU is restricted even though I set the secondary monitor as primary. Oh, FYI, when I tried to mirror the monitor, there are few of black lines on the Built in Display, it scares me, so I set it back to Dual Monitor. Another thing to note, I tried playing Steam's Counter Strike:GO, and my Mac is autorestart after few minutes inside CS:GO's main menu.

Any input/advice ? thanks in advance.

 

 

Benchmarks (WIP)

1st BM using LuxMark, eGPU constricted to 300MHz

 

Comments (WIP)

This topic was modified 1 month ago

2012 13-inch MacBook Pro + RX 580 4GB @ 10Gbps-TB3to1 (Mantiz Venus) + macOS 10.14.6 (Work in progress)

 
2012 13" MacBook Pro [3rd, 2C,M] + RX 580 @ 10Gbps-TB1>TB3 (Mantiz Venus) + macOS 10.14.6 [build link]  


ReplyQuote
applejuice
(@applejuice)
New Member
Joined: 2 months ago
 

Last update for today, I do several restart with eGPU ON and plugged, and tried CS:GO again, setting at high, seems to be working fine, playing one game against bot. I can feel the laptop is getting hot. iStats Screenshot here.

Just tried Geekbench 5, got 31429 OpenCL Score as shown here. Maximum memory clock is stuck at 300Mhz. As I checked here on Sapphire websites, memory clock should be around 8.000Mhz.

Are these things normal ? I'm getting confused now.

2012 13-inch MacBook Pro + RX 580 4GB @ 10Gbps-TB3to1 (Mantiz Venus) + macOS 10.14.6 (Work in progress)

 
2012 13" MacBook Pro [3rd, 2C,M] + RX 580 @ 10Gbps-TB1>TB3 (Mantiz Venus) + macOS 10.14.6 [build link]  


ReplyQuote
nu_ninja
(@nu_ninja)
Reputable Member
Joined: 3 years ago
 

That mostly looks normal to me except the memory clock.

One thing I would always check when buying a used GPU is to check the bios to see if a crypto mining bios has been flashed. These bioses usually change things like the memory timings and are not always stable, which could be the behavior you are seeing. I don't know a way to check this in macOS, but you can use gpu-z or amdflash to check it in windows.

Mid-2012 13" Macbook Pro (MacBookPro9,2) TB1 -> RX 460/560 (AKiTiO Node/Thunder2)
+ macOS 10.15+Win10 + Linux Mint 19.1

 
2012 13" MacBook Pro [3rd,2C,M] + RX 460 @ 10Gbps-TB1 (AKiTiO Thunder2) + macOS 10.14.4 [build link]  


ReplyQuote