2012 15" MacBook Pro Retina (GT650M) [3rd,4C,Q] + GTX 1080 @ 10Gbps-TB1>TB3 (AKi...
Clear all

2012 15" MacBook Pro Retina (GT650M) [3rd,4C,Q] + GTX 1080 @ 10Gbps-TB1>TB3 (AKiTiO Node) + Win10 [Aleitheia] // Hot-Plug BIOS mod  


New Member
Joined: 3 years ago

My setup:


I figured I put my mild success story here in case others like me were getting confused at random parts. Plus, I hadn't seen anyone with the 1080 yet with my combo. This whole eGPU thing really can be a headache. If you don't have persistence, you are gonna get beat down. Especially with the old discrete graphics models that don't support hot-plugging. 

Disclaimer, I'm really just a relatively tech-savvy Graphic Designer; so I may list steps that were completely unnecessary. I leave that to the pros to dissect. 

Mac OSX High Sierra Beta (Failed)

Ran the steps that Ozzy put forth here. They are really well written. The only issue is that I am running the 10.13 Beta (17A360a) and was not able to install the Pascal drivers. There are workarounds to this that I found online, but I thought they had low degrees of success. Either way, I decided to wait till HS gets a full release. Won't be long now.

That being said though, I did disable SIP (csrutil disable) and ran @goalque’s automate-eGPU.sh shell script

Windows 10

Here's where it got hairy. I had many weird failures and reinstalls/restores before I got to these steps. These are my working steps in order.

  • Created new Bootcamp partition and installed Windows 10 Anniversary
  • Ran all updates for Windows and Apple
  • Updated to Creators Update
  • Uninstalled GT650m drivers in device manager. At this point, the screen went black for me. I was like, whatever. I let it sit for a few minutes, and then just manually powered down the Mac.
  • Powered up with Option key to see the OS choices - With Akitio Node CONNECTED via thunderbolt to the Mac, but OFF (card also installed and the monitor connected to the card)
  • At the options screen, waited like 5 seconds, then start up the power on the Node, then clicked to start up in Windows.
  • Note: at this point, the startup was skipping the regular boot options screen (the little blinking dash in the top left corner)
  • Also, a weird blip of hope, the external monitor randomly flashed the Windows logo for like, 2 seconds, and then everything started up regular in the laptop screen.
  • went to device manager, I saw the GTX 1080 listed underneath the 650m, but with the Code 35 message when I double clicked it.
  • Switched gears, and downloaded the Game ready driver from Nvidia for the GTX 1080
  • Another hairy part, ran the installer for the driver. I guess it detected the card, because it started the install. A minute in, though, the screen went black except for my mouse (I could move it around, I just couldn't do anything). I left it overnight. Came back in the morning and it was the exact same. I powered down the mac with the power button.
  • Power OFF the Node; keep connected.
  • Power ON the Mac, hold Option Key. at OS screen, power ON the Node. wait a few seconds and select Windows. 
  • It did the weird flash of the Windows logo on the external screen again, and didn't give me the flashy dashy for boot options in Windows; but eventually booted into Windows on the laptop screen.
  • At this point, I was ready for Nando4s DIY Script (seems like a nice guy, btw). I bought it, and installed it as per the instructions he gives in his email. There are a couple EXTRA steps that you need to take if you have a Macbook pro that he will give you. It was all pretty clear so I didn't have any guesswork. 
  • After install, shut down the Mac.
  • Shut down the Node.
  • Powered on the Mac with the option key, then the node, and selected windows and all that jazz just like before
  • THIS TIME the External monitor woke up and showed Nando4's eGPU Setup 1.35 and Windows 10 as boot options. 
  • Select Setup 1.35
  • When I got to the next screen, I had to hit the "3" key in order to run the proper setup sequence. I accidentally tried to use arrow keys to move down to the number 3 in the options; but as he specifically lists, doing that freezes the system and you will have to restart again.
  • After I finished all Nando4's steps, I was able to boot into Windows 10, both screens working, all drivers installed.
  • I immediately installed Battlefield 1 and tested it. Worked really well in 1080p, had some lowish framerates in 1440p. All setting on Ultra.


I have successfully booted with my little Option key->Power on Node->select Windows each time except for once. The one time it fluked on me it actually restarted (heard the chime but it was too late to try to mess with power/hotplugging and whatever) and then went straight to the same two options (Setup 1.35 and Windows 10). So it still worked, just in a weird roundabout way.

Your results may vary, but basically the Akitio Node hates Macs+Bootcamp, and Apple firmware seems to hate it back. I never once got my windows side to "see" the Node (not that I could tell, at least). It did see the GTX though, so that's what counts Smile

I realized after some use that my GT650m card was still driving the main laptop display. I am sure there is a way to deal with that, but I haven't messed with that. I really thinks its worth trying to disable, because I figure that thats extra heat that you don't want. 

Haven't tried Clamshell. Pretty sure it won't work without a workaround. 

Hope this helps someone Smile

Thanks to the community here for all the resources.



2012 15" MacBook Pro Retina (GT650M) [3rd,4C,Q] + GTX 1080 @ 10Gbps-TB1>TB3 (AKiTiO Node) + Win10 [build link]  

mintroini liked
New Member
Joined: 3 years ago

So a Heaven 4.0 Benchmark gave me this:

FPS: 86.2
Score: 2172
Min FPS:23.5
Max FPS: 170.8

One thing I do notice is that BF1 will hit low FPS occasionally. I'm thinking its my RAM (8GB) and CPU that are bottle-necking it.

Also, I have found that I don't need to interrupt the boot process anymore. I'm not sure at what point I stopped needing to, but right now as long as everything is on and plugged in, it starts up perfectly on the eGPU.


2012 15" MacBook Pro Retina (GT650M) [3rd,4C,Q] + GTX 1080 @ 10Gbps-TB1>TB3 (AKiTiO Node) + Win10 [build link]  

New Member
Joined: 3 years ago

Which Thunderbolt 3 to Thunderbolt 2 adapter did you use?


2019 16-inch MacBook Pro i7 32GB 5300M, Core Pro X + RTX 2080 Super, Benq EW2780u

Prominent Member Moderator
Joined: 4 years ago
Posted by: MountandJew

Which Thunderbolt 3 to Thunderbolt 2 adapter did you use?


Not OP, but the proven answer for this direction is the Apple one.

Want to output [email protected] out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

2012 14" Lenovo Thinkpad T430s [3rd,2C,M] + RX 550 @ 10Gbps-TB1 (Atto Thunderlink) + Win10 [build link]  

Active Member
Joined: 3 years ago

I have early 2013 pro retina, also TB1. Using it with Aorus Gaming Box 1080

Did you try in OS X yet? I have tried pretty much everything but all I get is being stuck on booting screen on OS X, it wont finish the loading bar. 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.


Active Member
Joined: 2 years ago

@aleitheia I am using same macbook as you have, installed windows using bootcamp assistant, but whenever I try to boot it with the eGPU connected it flickers the external monitor and reboots. I don't get any output there.
Here are the steps I am doing maybe you can help.
1. connect akitio enclousure to power
2. connecting my gpu to additional power
3. boot with option key and showing my hdd
4. connect thunderbolt to pc
5. wait those 5 seconds (I've done quite more than 5 sec)
6. select windows.

Result: get some "input" on my monitor, nothing visible, macbook reboots. Any input?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.


Active Member
Joined: 2 years ago

@mintroini and could you please share more detailes about your bootcamp configuration? 
I would say - GPT  or MBR for Windows? And maybe screenshot of your Device manager list.

Macbook Pro 2017 (RP560) + Mantiz Venus + Vega64 Air

New Member
Joined: 3 years ago

Geez I am so sorry - was inactive for quite a while. Unfortunately I don't have that build anymore as I moved on to a 2017 MBP, so I can't troubleshoot actively.

As I try to remember though, here are some thoughts, since I don't know where you are in my process of craziness:

-You NEED Nando's script. I don't know if you are before or after this point. I could NEVER get the external Monitor to display anything beyond a second until I had it installed.
-Power on the Node AFTER you get to the boot options screen. You should be able to keep it connected, but just turned off until this point. 
-I feel like your "rebooting" issue is one that I had several times, but for the life of me I can't remember if I ever traced it to a specific cause.

Sorry I cant be more help :/
If it is any consolation, you are doing the hardest setup of all in my opinion. All this nonsense get MUCH easier in later MBPs. In my 2017 (the easiest thus far), it is literally plug and play because of a firmware update...no weird code hacking or anything.

2012 15" MacBook Pro Retina (GT650M) [3rd,4C,Q] + GTX 1080 @ 10Gbps-TB1>TB3 (AKiTiO Node) + Win10 [build link]