2012 15" ASUS K55VD (GT610M) [3rd,4C,Q] + RX 580 @ 4Gbps-mPCIe2 (EXP GDC 8.x) + ...
 
Notifications
Clear all

2012 15" ASUS K55VD (GT610M) [3rd,4C,Q] + RX 580 @ 4Gbps-mPCIe2 (EXP GDC 8.x) + Linux Ubuntu 20.04 & Win10 1909  

  RSS

Pierre Arowana
(@pierre_arowana)
New Member
Joined: 4 months ago
 

Hi all,

 

I finally jumped into the eGPU world. After some research it seemed like my laptop is a good candidate but mPCIe gen2 would potentially fairly bottleneck the setup but i had not much to lose and my laptop is still fully functional for everyday tasks so i had no reason to upgrade. I just thought that this would turn into an easy project and give me the opportunity to play games

 

System specs

Operating System: Windows 10 Pro 64-bit (10.0, Build 18363)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: K55VD
BIOS: BIOS Date: 06/13/12 10:38:13 Ver: 04.06.05 (type: BIOS)
Processor: Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz (8 CPUs), ~2.3GHz
Memory: 8192MB RAM

iGPU: Intel(R) HD Graphics 4000

dGPU: GeForce 610M

External Monitor: Philips 40" 4k 60Hz

 

eGPU hardware

EXP GDC 8.4d (Mini Pcie interface version)

ATX power supply Corsair V550 (given by a friend)

eGPU: ASRock Radeon RX 580 Phantom Gaming D OC 8GB Video Card

 

Cost of the build: 280 AUD (GPU) + 42 AUD (EXP GDC) = 322 AUD or about $224 USD

 

Hardware pictures

Installed in a cabinet i found in the street. Which provides a surface for the laptop, perfect to keep a clean desk. Not really compact though

 

Installation steps

Ubuntu 20.04: Nothing to do, the external display works out of the box. However, i had some kind of weird lags so i decided to give windows 10 a go before launching an investigation. Haven't been back yet to test the setup under ubuntu.

Windows 10: Install Radeon latest driver, reboot. All good ready to play.

Insane plug and play experience!

 

Bonus steps:

A week before receiving the eGPU connector, i did some investigation and realized that my laptop suffered from intense CPU throttling.
I disassembled the laptop and cleaned most parts, reapplied thermal paste (almost none was left), then i got back a PC that can go 100% CPU load.

This was essential for the whole setup to be meaningful

 

Benchmarks

Everything is done using external monitor, i have no interest in the internal monitor

 

dGPU

 

eGPU

Same poor resolution as with dGPU to compare apples to apples

 

Comments

Well, i could barely play any new title and i am now equipped with a setup that will let me play a lot of games in decent conditions.

I am not experiencing any kind of instability so far. I'll come back with some in game numbers soon.

The only crash i experienced was setting the unigine valley benchmark to 1440p and High quality, i had blue lines all over the screen. However, strangely when playing games it seems like 1440p can work

 

Games

The forest: High in 1080p + Vsync, mostly 60 fps

This topic was modified 3 months ago
2012 15" ASUS K55VD (GT610M) [3rd,4C,Q] + RX 580 @ 4Gbps-mPCIe2 (EXP GDC 8.x) + Linux Ubuntu 20.04 & Win10 1909 [build link]  

mr.ribeiro and EnQi liked
ReplyQuote
Pierre Arowana
(@pierre_arowana)
New Member
Joined: 4 months ago
 

I have tried 2 others games and the story is a whole lot different:

Deep rock galactic

Metro exodus

Both are crashing after a few minute in game, with a sound loop and a colored screen (green or black...). I played flawlessly the forest for 6-7h, 0 crash, weird.

I wonder if this isn't the GPU itself or the PSU...

 

I even bought a PCE164P-N03, so i tried that and no improvement except that i ran superimposition in 4k and it worked while it crashed with the EXP GDC, i also ran fine unigine valley in 1440p

This post was modified 4 months ago
2012 15" ASUS K55VD (GT610M) [3rd,4C,Q] + RX 580 @ 4Gbps-mPCIe2 (EXP GDC 8.x) + Linux Ubuntu 20.04 & Win10 1909 [build link]  

ReplyQuote
Pierre Arowana
(@pierre_arowana)
New Member
Joined: 4 months ago
 

Since then i tried a few more games, i changed PSU to rule out a potential PSU issue but it seems to crash exactly the same way:

Unigine valley using stock OC ~1420Hz 100% GPU, no crash at all

Metro exodus: Hasn't crashed since the initial crashes i had

Outer wilds: works fine, had a few crashes at the beginning and i thought it was caused by game settings but i have no proof, runs smooth now. I even gave it a test at 4k with the card OC and max settings, it just worked. Makes me believe there is no issue at all in the PSU space, GPU power reported was 195W

Deep rock galactic: Crashes once in a while, then i realized the game was in windowed fullscreen, so

AOE 2: Definitive edition: Alright, in 4k

 

I have a high suspicion that crashes occur when the game reaches high FPS, which could maybe "stress" the bandwidth and reveal signal integrity issues. I believe if i keep VSYNC (60Hz screen) maybe it will go alright.

 

Crash symptoms: Colored screen (sometimes black/white) with sound loop, reboot required

 

2012 15" ASUS K55VD (GT610M) [3rd,4C,Q] + RX 580 @ 4Gbps-mPCIe2 (EXP GDC 8.x) + Linux Ubuntu 20.04 & Win10 1909 [build link]  

ReplyQuote
Bug Hunter
(@bug_hunter)
Active Member
Joined: 7 months ago
 

A BIOS update may help, but investigate what problems that might cause.  Problems like the TOLUD (Top of Lower Usable DRAM) mess some vendors cause when they squeeze the space used for PCIE buffering.  There are workarounds if that happens, but maybe only upgrade to a version of BIOS which doesn't do that. 

2011 15" Lenovo W520 (quadro 1000M) (2nd,4C,Q) + Nvidia GTX970 @ {2Gbs-EC,mPCIe} (EXP GDC Beast 8.0 ) + Ubuntu 18.04 & 20.04 & Win10 1909

 
2011 15" Lenovo Thinkpad W520 (Q 1000M) [2nd,4C,Q] + GTX 970 @ 2Gbps-EC2 (EXP GDC 8.x ) + Win10 1909 & Linux Ubuntu 20.04B [build link]  


ReplyQuote
benzguy
(@benzguy)
New Member
Joined: 2 months ago
 

For Ubuntu,try to install the amdgpu driver to try to solve the problems

This post was modified 2 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote