2013 11" MacBook Air + AMD RX 580 (Sonnet Breakaway Box) + Win 10 and Mac OS 10.13  

 

MacsAre1
(@macsare1)
New Member
Joined:5 months  ago
Posts: 4
February 26, 2018 4:09 am  

 System specs

 11" MacBook Air 2013 i7
Intel HD Graphics 5000 on board
Dual booting Mac OS High Sierra and Windows 10

Windows 10/Boot Camp is running on a USB SSD, installed as Windows To Go using Hasleo WinToUSB. This MacBook is UEFI so no problems there. Performed a fresh install of the Fall Creator's edition because I messed it up when I started trying to get this to work.

eGPU hardware

 Enclosure: Sonnet Breakaway Box 350
AMD Radeon RX 580 8GB (PowerColor Red Dragon)
Apple TB3 to TB 1/2 adapter on the box and OWC TB2 cable to the computer 

Installation steps

For Mac OS High Sierra:

Step 1: Plug in TB cable.
Step 2: Mac prompted to logout for eGPU to start working, so I logged out and back in. eGPU working great! Had to manually select 4k resolution for my monitor.
Step 3: There is no step 3. That's it, plug and play! This is an officially supported card in High Sierra and the same hardware as Apple's eGPU Dev kit.

For Windows 10:
Before connecting eGPU I ran Windows Update a few times to make sure everything is on the latest version.
Cable for eGPU can be connected anytime afterwards once it's booted to the Mac but before booting to Windows.
Install rEFInd on the MacBook's INTERNAL drive. This required booting into Recovery mode with Cmd-R in order to bypass SIP. Ran install from Terminal in Recovery Mode.
Mount EFI partition (I installed Clover Configurator to have the easy "Mount EFI" button but there are other ways to mount the partition)
Edit the refind.conf file on the EFI partition in a text editor, just remove the # before the spoof_OSX_version line and save.
Reboot, connect the USB drive and select the Windows drive in rEFInd. eGPU cable should also be plugged in by now.

Windows boots, the MacBook Air screen stays on, and Device Manager shows "Error 12" for the eGPU.

I followed this guide to deal with Error 12:  https://egpu.io/forums/mac-setup/2016-macbook-pro-solving-egpu-error-12-in-windows-10/
What worked for me was to reallocate PCIe bridges (step 5 in that post):
"Go to Device Manager -> View Devices By Connection. Find your eGPU then disable the PCIe bridges above it one at a time like shown below including the (in this case) Root port #5. . Then re-enable them."

I then updated the AMD drivers by downloading the latest from the AMD website. Microsoft had detected the card in earlier boot/hotplug attempts so it had already installed a driver through Windows Update.

 

Comments

no pics yet, I don't have enough posts. But it took me so long to sort this out on Windows that I wanted to post for others to be able to set up their systems.
I haven't run benchmarks yet, those don't mean much to me as I'm not here to see whose is faster. I'm just happy that I can run a 4K monitor with my 2013 MacBook Air, something that would be impossible running off the internal GPU. I will be gaming as well as running AutoCAD and other CAD software. I also plan to use my rig for 360 video editing using Cyberlink's Action Director and Power Director.

On both Mac and Windows the internal screen is run off the internal GPU. Better performance this way since this system is Thunderbolt 1.

Edited: 4 months  ago

Sonnet Breakaway Box with AMD RX 580 running via TB1 on an 11" MacBook Air 2013


ReplyQuote
macunix
(@macunix)
New Member
Joined:3 months  ago
Posts: 3
May 25, 2018 5:35 pm  

I have a 2013 13" Macbook Air and the AMD RX 580 in a Akitio Node Pro that works fine with 10.13.4 (patched of course for TB1) and I was trying to get Windows 10 working.  I was able to overcome the error 12 using the disable-enable process under Root Port #5, but it only worked twice and never held after reboot.  Now, I cannot get it to work at all.  Any ideas why the driver changes never kept after reboot and why the error 12 keeps coming back?  Is Windows 10 really this bad?


ReplyQuote