2013 Mac Pro (FP D300 x2) [3rd,4C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X...
 
Notifications
Clear all

2013 Mac Pro (FP D300 x2) [3rd,4C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X Chroma) + macOS 10.15.4  

  RSS

Alex Jordan
(@alex_jordan)
New Member
Joined: 5 months ago
 

System specs 

2013 MacPro 6,1 ,OS 10.15.4,
3.7GHz Quad-Core Intel Xeon E5,
256GB SSD,
128GB RAM,
2x AMD FirePro D300 (2GB each)

 

 

eGPU Hardware 

Razer Core X Chroma
AMD XFX RX 5700 Xt Thicc III Ultra 8GB
Apple Thunderbolt 3 (USB-C) to Thunderbolt 2 Adapter
Apple Thunderbolt Cable (2 m)

 

 

Installation steps

Unboxed The Razer Core X Chroma, and slid out the docking bay.
Unboxed the RX 5700 Xt, (grounded myself beforehand just to be sure I wasn’t carrying any sort of a charge.) 
Removed the thumb screw from the docking bay of the enclosure, allowing me to remove the blank plate.
Slotted the RX 5700 Xt into place, went in effortlessly, and connected all cables.
Couldn’t have been simpler.

Patched Thunderbolt 2 cable into Apple Thunderbolt 2 to Thunderbolt 3 adapter, and plugged the Thunderbolt 3 end into the E-GPU.

 

 

Ran Purge-wrangler and it almost worked seamlessly.
Started easy, disabled SIP, then ran the Script for Purge Wrangler.
When it came to Step 4. Patching, when I plugged in my e-gpu it would crash my machine and it would end in a boot loop.

Solution:
I pressed Esc to skip plugging in the eGPU. As per guidance in the wiki. “
Just set up the eGPU without connecting it to the Mac. Once patching completes and system is rebooted, the eGPU should work as expected. “
Worked perfectly!

 

 

 

 

 

 

 

Current Issues

I have noticed that the eGPU seems to freeze my system a lot, cause the mouse to lag.
I went to export some 4k videos in Adobe Media Encoder.

 

 

I attached my MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
OS 10.15.4, 3.5 GHz Dual-Core Intel Core i7, 16GB RAM.
My laptop started to hang so bad once I plugged it in, it became unusable. Does anyone know a solution for this?

 

 

 

 

2013 Mac Pro (FP D300 x2) [3rd,4C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X Chroma) + macOS 10.15.4 [build link]  

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@alex_jordan, Welcome aboard and thank you for sharing this build! I'd recommend rearranging the Mac Pro so that the eGPU enclosure doesn't exhaust hot air into the intake space of the computer.

Regarding your 2017 13-in MacBook Pro, does the freezing issue occur after a while or immediately after connecting the eGPU? Which Thunderbolt 3 cable are you using? Which specific Thunderbolt 3 port on the MacBook Pro was connected?

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Alex Jordan
(@alex_jordan)
New Member
Joined: 5 months ago
 

Hi @itsage , thank you so much for the welcome. This site was such a great help to me when choosing my setup!

 

Thank you so much for the tip! I'm just waiting on a longer Thunderbolt 2 cable before I can move the MacPro.

 

Freezing occurs pretty much immediately on the 2017  13-in MacBook Pro . I connected it using the top right port (closest to the touch ID reader), and used the thunderbolt 3 cable that came with the Razer Core X Chroma.

 

On the MacPro, freezing only occurred when I started using Adobe Premiere Pro, or Adobe Media Encoder. Using Media Encoder, actually killed the machine.

This post was modified 5 months ago
2013 Mac Pro (FP D300 x2) [3rd,4C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X Chroma) + macOS 10.15.4 [build link]  

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@alex_jordan, If the freezing issues keep occurring on both Macs, I would suspect the graphics card itself. On the 2017 13-in MacBook Pro, use the left Thunderbolt 3 ports. The right sided ports don't have full speed because they are attached to a x2 PCIe connection.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Alex Jordan
(@alex_jordan)
New Member
Joined: 5 months ago
 

@itsage, Damn I hope not. 

I'll try that today thank you.

Would you recommend any tests I can run to see how the Graphics Card is performing?

 

2013 Mac Pro (FP D300 x2) [3rd,4C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X Chroma) + macOS 10.15.4 [build link]  

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@alex_jordan, Luxmark 3.1 and Unigine should be enough to see how the eGPU is running in macOS.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
Alex Jordan
(@alex_jordan)
New Member
Joined: 5 months ago
 

Benchmak Test Results

 

https://imgur.com/ikYajQc  

 

Using Unigine Valley Benchmark

2013 Mac Pro (FP D300 x2) [3rd,4C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X Chroma) + macOS 10.15.4 [build link]  

ReplyQuote
Matthew Farrell
(@matthew_farrell)
New Member
Joined: 5 months ago
 

Hi,

I have a similar set up and am also having problems with Adobe. Renders seem significantly faster with the eGPU, but playback stutters.  In After Effects, the video seems to playback smoothly but the audio drops out periodically.  

 

Late 2013 Mac Pro

3.5 Ghz 6-Core Intel Xeon E5

64 GB Ram 1866 MHZ DDR3

macOS Catalina 10.15.5

Razer Core X

Radeon Pro 5700 XT

 

UPDATE: After a lot of experimentation things seem to be running smoother after doing the following.  Running all displays through the GPU instead of Mac.  Also switched the audio output to my monitor and plugged headphones in there (had been running through a Scarlett box).  

This post was modified 5 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

overflood liked
ReplyQuote