2014 13" MacBook Pro [4th,2C,U] + RX Vega 64 @ 16Gbps-TB2>TB3 (Razer Core X) + m...
 
Notifications
Clear all

2014 13" MacBook Pro [4th,2C,U] + RX Vega 64 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.5 & Win10 1903 [Scensory]  

  RSS

Scensory
(@scensory)
Active Member
Joined: 1 month ago
 

System specs 

MacBook Pro (Retina, 13-inch, Mid 2014)
Processor 3 GHz Dual-Core Intel Core i7
Memory 16 GB 1600 MHz DDR3
Graphics Intel Iris 1536 MB
macOS Catalina version 10.15.5
bootcamp Windows 10 version 1903

 

eGPU hardware

Razer Core X
Asus ROG Strix Vega 64
Apple Thunderbolt 3 (USB-C) to Thunderbolt 2 adapter
Apple Thunderbolt 2 cable
Asus Designo MZ27AQ WQHD monitor

 

Hardware pictures 

Coming soon!

 

 

Installation steps

Followed instructions on the automate eGPU forum page.

https://egpu.io/forums/mac-setup/automate-egpu-efi-egpu-boot-manager-for-macos-and-windows/

 

 

Benchmarks

None so far.

 

 

Comments

Can run most games at max/ultra settings with no problem.

2014 13" MacBook Pro [4th,2C,U] + RX Vega 64 @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.5 & Win10 1903 [build link]  

nando4 liked
ReplyQuote
Matthew Henderson
(@matthew_henderson)
New Member
Joined: 2 weeks ago
 

@scensory, Can I ask how you are getting this to work?

 I have the same MacOS Catalina 10.15.5, thunderbolt 2 cable and thunderbolt 2/3 adaptor.  I also used the same link that you did and am since updating to Catalina 10.15.5 the efi boot doesn't work anymore.  

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote