2015 15" Dell XPS 9550 GTX960M + [email protected] (AORUS Gaming Box) + Win10 [theitsage]  

  RSS

theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
August 16, 2017 2:43 am  

I'm slowly working my way through the Thunderbolt 3 hosts I tested for the AORUS GTX 1070 Gaming Box review. The Dell XPS 15 9550 was plug and play (as long as BIOS and Thunderbolt firmware are up to date). One thing I was curious was power delivery from this eGPU enclosure to the XPS 15. It comes with a 130W wall charger and a 84Wh battery. The good news is the laptop is able to charge over Thunderbolt 3 cable. It's much slower though because the highest rate of charging I observed was around 37W.

I disabled the 960M dGPU so that I can run eGPU internal display acceleration. I also tested with an external 4k display. x2 PCIe issue on this laptop combines with H2D issue on the Gaming Box results in exactly half the CUDA-Z output we typically see in a proper TB3 eGPU implementation. I ran the it through Unigine and 3DMark to compare internal vs external performance at 1080p, 1440p, and 4k.

AORUS Gaming Box FHD Internal FHD External QHD Internal QHD External UHD Internal UHD External
             
Unigine Valley 59.5 FPS 71.9 FPS 37.4 FPS 49.4 FPS 19.1 FPS 23.9 FPS
Unigine Heaven 58.1 FPS 71.3 FPS 34.7 FPS 46.5 FPS 18.6 FPS 21.5 FPS
Unigine Superposition 65.2 FPS 82.8 FPS 40.8 FPS 55.5 FPS 24.2 FPS 29.2 FPS
3DMark Time Spy 31.3 FPS 49.3 FPS 25.2 FPS 33.2 FPS 15.2 FPS 16.6 FPS
3DMark Fire Strike 57.4 FPS 66.3 FPS 29.4 FPS 42.6 FPS 20.7 FPS 24.0 FPS

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


TrDA, Rastafabi and nando4 liked
ReplyQuote
 Jeff
(@jeff)
Active Member
Joined: 1 year ago
Posts: 5
August 18, 2017 6:31 pm  

How did you disable the dGPU?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1815
August 18, 2017 6:37 pm  

@Jeff, you can disable the dGPU in Device Manager->Display adapters->[right click on the dGPU]->disable.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
 Jeff
(@jeff)
Active Member
Joined: 1 year ago
Posts: 5
August 21, 2017 12:39 am  

@nando4, thanks.

@theitsage Do you experience any instabilities like disconnection of GPU? I experienced some, and almost all of them happened when I was also using some peripherals.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
XCVG
 XCVG
(@xcvg)
Trusted Member
Joined: 2 years ago
Posts: 65
August 21, 2017 4:48 am  
Posted by: 孙雨时(Jeff)

@nando4, thanks.

@theitsage Do you experience any instabilities like disconnection of GPU? I experienced some, and almost all of them happened when I was also using some peripherals.

What BIOS version are you on and what network card is in your laptop?

Late-2015 15" Dell XPS 9550 GTX960M + [email protected] (Mantiz Venus) + Win10


ReplyQuote
 Jeff
(@jeff)
Active Member
Joined: 1 year ago
Posts: 5
August 21, 2017 2:04 pm  

BIOS version is 1.2.29

The network card is a Broadcom Chip named "Dell Wireless 1830 802.11 ac"

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
August 21, 2017 2:22 pm  

@Jeff I did not use this eGPU with the XPS 9550 much. There was no disconnection with the eGPU however when I tried it. One issue I noticed is the detection of eGPU when using a longer Thunderbolt 3 cable with this XPS 9550. I could only get .5m TB3 cable to work. The AKiTiO 2m TB3 cable was detected as USB-C.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
 Jeff
(@jeff)
Active Member
Joined: 1 year ago
Posts: 5
August 21, 2017 3:32 pm  

@theitsage Thanks for the information. I bought a 1m belkin cable that says 20Gbps (9550 supports only 16Gbps anyway) and it connects fine. I'm still sticking with the original .5m cable though. I assume interference with peripherals. Purchased some conductive tape from amazon and plan to wrap the cable when it arrive.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
 Jeff
(@jeff)
Active Member
Joined: 1 year ago
Posts: 5
August 22, 2017 9:41 pm  
Posted by: XCVG
Posted by: 孙雨时(Jeff)

@nando4, thanks.

@theitsage Do you experience any instabilities like disconnection of GPU? I experienced some, and almost all of them happened when I was also using some peripherals.

What BIOS version are you on and what network card is in your laptop?

Your post inspired me into thinking maybe it's the wireless interference that caused the problem.

Here's some additional supportive information

  1. Disconnection seldom happens when I do not use any peripherals.
  2. If I only use the USB port on the right hand side of my XPS (while TB3 is on the left), disconnection happens less.
  3. Whenever I close the lid of my XPS when I am using 2.4 Ghz WiFi, the GPU disconnects.
  4. LG's first shipment of its 5K tb3 monitors experienced severe interference with WiFi signals.

So here's what I have done trying to mitigate it: First, I got a roll of 1-inch wide copper tape off of amazon and wrap the tb3 cable in it. Now it glitters (shiny). Second, I bought a roll of 15 meters Ethernet cable and a usb3 gigabit dongle and plugged it into the Aorus Gaming Box. Finally, I turned on airplane mode on my XPS15 and plug the glittering cable in.

Now I'm happy to see that can actually close the lid without breaking the setup. And so far I've been using it for like an hour and no more disconnections happened. I'll use it as my daily gaming gear and will report in this thread if anything happens again (hopefully never).

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
(@aindriu_mac_giolla_eoin)
New Member
Joined: 1 year ago
Posts: 2
September 14, 2017 11:04 am  

@nando4 I have a DELL XPS 15 9550. How did you attached the external graphics card ? Will it connect via thunderbolt or do you have to open the DELL up and disconnect a wireless card or something ?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 2 years ago
Posts: 1815
September 14, 2017 12:46 pm  

@Aindriú, @theitsage connected the Aorus Gaming Box to the XPS 9550 Thunderbolt 3 port with this enclosure's included 0.5m Thunderbolt 3 cable. The XPS 9550 Thunderbolt 3 can be seen below. It's the second port from the right marked with the Thunderbolt.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table    •    Several builds
2015 15" Dell Precision 7510 M1000M + macOS 10.14 & Win10


ReplyQuote
(@aindriu_mac_giolla_eoin)
New Member
Joined: 1 year ago
Posts: 2
September 14, 2017 3:42 pm  

oh cool ! I just saw it here:

https://www.amazon.co.uk/Gigabyte-GV-N1070IXEB-8GD-Nvidia-Aorus-Gaming/dp/B073PYMG3G/ref=sr_1_1?ie=UTF8&qid=1505403601&sr=8-1&keywords=Aorus+Gaming+Box

I have a 9550 and the only thing slowing it down is the graphics.  Does anything come in the Gigabyte GV-N1070IXEB-8GD - Nvidia Aorus GTX 1070 Gaming Box ?

 

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
September 15, 2017 8:18 pm  

@Aindriú Mac Giolla Eoin, the AORUS Gaming Box comes with a nice travel case. You can see my unboxing post for more photos.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
(@kawa_doski)
New Member
Joined: 1 year ago
Posts: 2
September 20, 2017 10:15 am  

Hi, 

Ive also got the Aorus gaming box with the exact same laptop, however im having trouble updating to gigabytes new firmware which has higher bandwidth, It's called F1.0 H2D.

did you have any trouble updating to the new firmware?

it came up with this error message when running the FwUpdateTool. 

title
"Thunderbolt(TM) Firmware Update Utility"
Body
"Exception has been thrown. closing application...
Exception type: System.Management.ManagementException
Exception message: Not found"

Would really appreciate it if you have done the update without any trouble or have gone through this error and found a way to fix it.

 

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
September 20, 2017 12:22 pm  

Hi @Kawa Doski, what is the version number of Intel Thunderbolt Software on your XPS 9550? I've found version 16.2.xx.xxx is most compatible with the FW Update Tool. Give this one a try and let us know whether it helps you flash the firmware on the AORUS Gaming Box.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
(@kawa_doski)
New Member
Joined: 1 year ago
Posts: 2
September 21, 2017 10:06 am  

Hi, thankyou for the quick reply, I just did as you suggested and it finally worked went into the FW update tool, but as it was about to finish this message popped up, "Your PC may need updates for the Thunderbolt 3 port to function properly. For more information go to:" so i do not know if the firmware update has gone through or not. is there a way for me to check? also should i update the thunderbolt 3 again?

 

Update: 

I had a double check if bios was updated and it wasnt which was odd because i was certain i did the update a few days ago. I did the UpdateFWtool again and It went through this time with the final message saying firmware is updated, and no more pop up messages to update the thunderbolt 3 port, Thank you very much dude, Helped alot more then gigabyte did! and much quicker may I add. Ill check later what sort of difference it has made on games later! thanks again!

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


theitsage liked
ReplyQuote
heli
 heli
(@heli)
New Member
Joined: 1 year ago
Posts: 3
November 19, 2017 10:03 am  

@theitsage @nando4,

having seen your post I got an Aurus Gaming Box, however I cannot figure out how to use the eGPU with the internal screen.

I disabled the dGPU in device manager and the game just straight went to use the iGPU (even when it was selected in Nvidia control panel to use the high performance Nvidia card).

The gaming box is being recognized just fine, in fact I have already run multiple rendering projects with it, however games on the other hand just dont want to see the card (tested with Nier: A, AC:O, PUBG, .

I have updated the firmware to H2D if that matters.

I uninstalled all Nvidia drivers with DDU and only installed the 1070 desktop drivers too.

Do you have any insight?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
4chip4
(@4chip4)
Estimable Member
Joined: 1 year ago
Posts: 194
November 19, 2017 5:08 pm  

I had this a couple of times, and what it boiled down to was that a lot of apps (or Windows?) don't necessarily like GPUs coming and going. I normally use the Omen Accelerator app which takes care of this (turns out it's not as simple as just on-off in device manager), barring that what corrects it for me tends to be a mix of

1. Restarts. For example the Unigine demos (Heaven etc) don't want to run on the internal screen, if I just disabled the dGPU. Restart (without reenabling the dGPU) and suddenly it reproducibly works OK

2. iGPU on/off cycle. For some games, as odd as it may sound, I need to disable the iGPU, and then re-enable it. I have no idea what this does (perhaps something on the driver level?) but after this those games see/use the eGPU correctly. Most things work with the iGPU off as well, but then I can't change the resolution from 4K so it's not ideal for games.

2017 HP Spectre x360 15 i7-8550U GTX150 + [email protected] (HP Omen Accelerator) + Oculus Rift + Win10 [no guide] HP Omen Accelerator Thunderbolt 3 enclosure legs stand removal walkthrough
Employed by HP, but my posts and opinions expressed on this forum are my own.


ReplyQuote
heli
 heli
(@heli)
New Member
Joined: 1 year ago
Posts: 3
November 22, 2017 10:53 pm  

@4chip4

I have tried as you suggested however it did not work, still have the same issue.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
SoulSlayerPT
(@soulslayerpt)
New Member
Joined: 12 months ago
Posts: 1
January 1, 2018 11:20 pm  

Thinking about buying this box for a dell 9560. Is the H2D problem solved? Tried to search the internet and people said for dell XPS it won't work the new firmware.

 

Thank you.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
January 2, 2018 3:58 am  

Due to the 2 PCI lanes in the Dell XPS 9560, the H2D firmware is a non-issue. Gigabyte published a firmware to resolve H2D [F1.0 H2D].

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
Kiddihj
(@kiddihj)
New Member
Joined: 12 months ago
Posts: 3
January 4, 2018 11:51 am  

Thank you for a great post.

I went ahead and bought the unit. After I updated the thunderbolt drivers and the Nvidea drivers the unit was practically plug and play.

However  it has not been performing as expected. I formatted my computer and reinstalled all the drivers. I just ran the Unigine Valley test on my external monitor where you get around 3000 performance score I get just under a third of that or around 800.

I have no idea what could be causing this as I think all drivers are up to date.

Any suggestions?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
January 4, 2018 2:48 pm  

@kiddihj what laptop and settings were you running?

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
Kiddihj
(@kiddihj)
New Member
Joined: 12 months ago
Posts: 3
January 4, 2018 3:20 pm  

Howdy,

I have the Aorus gaming box connected to my dell XPS 9550 running on Intel I7-6700HQ CPU @ 2.60 GHz and 8 gigs of ram and the gaming box connected to a Benq 1080p 60hz monitor.

I have narrowed the performance issue to the fact that the card is not producing at the highest it should be able. I see a performance gain from the inbuilt GTX960m however comparing to the performance parameters of others the card seems to be performing at around 30% to what it should be able to. For example pubg at the lowest settings is running at around 30-40fps with huge frame drops at certain points.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
January 4, 2018 3:53 pm  

@kiddihj I believe the GTX 960M dGPU may be interfering with the eGPU. Have you tried completely disabled the dGPU? Go into Device Manager and right-click to disable it. Make sure to set the external monitor as the primary screen as well.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
Kiddihj
(@kiddihj)
New Member
Joined: 12 months ago
Posts: 3
January 4, 2018 4:12 pm  

@theitsage It doesn't seem to be interfering. I tried disconnecting the 960m and tried running only on my external monitor (set as primary as well).
That does not seem to have any better effect. I've been researching forums and updating drivers left right and center however It seem no-one has had this exact same problem so I'm out of ideas at this point. 

As I said it's better than the 960 however Im a little dissapointed as I know the card has more potential. 

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
snowman82
(@snowman82)
New Member
Joined: 11 months ago
Posts: 1
January 6, 2018 8:23 pm  

hey , i have just the same Box With a dell xps9560 and i have exact same problem , all is Connected ok , and everything working , but very bad preformance 🙁 it should work much much better than this 🙁 my internal gtx1050 is faster , something is very wrong here , please if some one have any tips ,please say ? or i gonna Return it to the store ....... sorry bad English , i am from norway 🙂

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
(@daniel_zou)
New Member
Joined: 5 months ago
Posts: 2
July 18, 2018 7:22 pm  

Hi, I have the same laptop but just got an Aorus 1080 gaming box. However, when I connect it to my laptop, there is no response. I have tried unplugging the AGB from power sources ~10 minutes but nothing. How did you get the laptop to recognise the AGB? Unfortunately I don't know that much about egpus, please help!
TB3:
software package ver. 16.3.61.275
application ver. 16.3.61.14
service ver. 16.3.61.3
controller driver ver. 16.3.61.2

Bios ver 1.7.0

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3232
July 18, 2018 8:53 pm  

@daniel_zou I no longer have this XPS 9550 so I'm not sure what's the latest BIOS version. With no detection issue, I'd say to check Dell Support website and find Thunderbolt Firmware Update for your laptop. This link is an update from April 2018. Give it a try and let us know.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
(@daniel_zou)
New Member
Joined: 5 months ago
Posts: 2
July 18, 2018 10:33 pm  

Ah I see. No worries, any help would be appreciated. But when I try to update the firmware, it gets to about 10% then it says "Thunderbolt Firmware Update Failed."

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote