2015 15" Macbook Pro M370x + [email protected] (AKiTiO Node via TB3->TB2 adapter) + Win10 & macOS 10.12.2  

  RSS

mdr1a
(@mdr1a)
Active Member
Joined: 2 years ago
Posts: 15
January 20, 2017 6:08 pm  

I posted last week about using GTX 1060 with MacBook Pro 2015 in bootcamp windows 10. But there's no Nvidia pascal driver in macOS, so that I bought a GTX 970 these days, finally I make it works both in MacOS 10.12.2 &. Windows 10

Same setup just choose which system to boot up, it works well !

 

Hardware set-up

2015mid MacBook Pro retina 15' with AMD R9 M370x
Akitio Node
MSI Nvidia GTX 970
Apple Thunderbolt 3 <->Thunderbolt 2 adapt

 

Quick installation Guide

In bootcamp Windows 10 :

    Perform DSDT override
    Unplug thunderbolt
    Boot into windows
    Plug in eGPU
    Devices manager shows up a new graphic card
    Install Nvidia driver
    Done

 In macOS  Sierra 10.12.2 :

    Follow this automate-egpu.sh instructions
    Reboot
    Done

 

Installation Details

Installation process is kind of easy, just follow the instructions in the forum, but some problems show up unexpectedly:

In bootcamp windows GTX 970 can't imitate the way I use GTX 1060, I usually plug the eGPU thunderbolt before booting my computer, but with GTX 970 it failed. If I boot up windows 10 with eGPU plugged it will BSoD(blue screen of death). I have to "hot-plug" the thunderbolt and systems will detect GTX 970, install Nvidia driver. Now it works fine! As a result every time I want to boot into windows I need to unplug the thunderbolt or it will BSoD.

In MacOS follow this instructions, at first I can't boot into system and crash few times, after I run whole step couple of times it successfully boot up and MacOS detect the GPU.

2015 15" Macbook Pro M370x + [email protected] (AKiTiO Node via TB3->TB2 adapter) + Win10 & macOS 10.12.2


SaturnV, nando4 and theitsage liked
ReplyQuote
pleob
(@pleob)
New Member
Joined: 2 years ago
Posts: 1
January 21, 2017 1:15 am  

Hey, first of all, thanks for this. Just one question--I'm trying to build an eGPU for my computer, but I read on AKiTiO's website that the Node is not compatible with Mac or with Bootcamp. Did you have any problems? Also, my Mac is ~5 years old now, but it can still run OSX 10.12 (which is what I want the GPU for anyway). Would it still work? Thanks again!

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
kragiosplooch
(@kragiosplooch)
Active Member
Joined: 1 year ago
Posts: 8
July 8, 2017 1:58 pm  

Did you have to update the Akitio Node firmware?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote