2015 27" iMac 5K (R9 M390) [6th,4C] + GTX 1070 @ 16Gbps-TB2>TB3 (AORUS Gaming Bo...
 
Notifications
Clear all

2015 27" iMac 5K (R9 M390) [6th,4C] + GTX 1070 @ 16Gbps-TB2>TB3 (AORUS Gaming Box) + Win10 1909 [zeba]  

  RSS

zeba
 zeba
(@zeba)
Active Member
Joined: 8 months ago
 

First a big thanks to everyone active on this forum.

Without all the different 'hacks' found here I doubt I would have this wonderful setup working as well as it is today.

Use case: accelerate games using an eGPU and the internal 27" 5k retina screen.

 

System specs

27"  iMac  Late 2015 17,1 (Thunderbolt 2)

3.2 GHz Quad-Core Intel Core i5

8GB Ram

1 TB Fusion

AMD Radeon R9 M390 2GB

Windows 10 Pro - 1909 - OS build 18363.752 (Bootcamp)

(MacOS Catalina 10.15.3) Installed, but not currently used

 

eGPU hardware

Gigabyte AORUS GeForce GTX 1070 8GB Gaming Box

Apple TB3->TB2 adapter + Apple 2.0m TB2 -> TB2 cable

 

Issues summarized

I have to boot from the automate-eGPU USB with a custom DSDT file.

I have to hot-plug the eGPU exactly at the right moment during Windows loading screen.

After sleep, mouse/keyboard not functioning (maybe no ports, unsure), so for the moment I just shut down the computer when not using it. Hope I can solve this one somehow, as it's the most annoying issue.

USB hub not functioning on the AORUS Gaming box. This seems to be a known compatibility issue seen specifically with the setup of Windows + the Apple TB2 to TB3 adapter. As the USB hub doesn't get powered, it also affects the enclosure fans + LEDs (which gets powered by the USB hub). The PSU & GPU fans both function correctly. Different workarounds here to avoid overheating 1) run without enclosure to get more air exchange 2) manually adjust the GPU fan speed 3) use some external 120mm USB fans to push additional air inside.

 

Installation steps

Windows 10 installed ages ago and I've been doing the regular Win updates whenever they arrive.

I had been updated to 1909 when I started my eGPU journey..

My main goal was to be able to run CoD MW 2019 with higher display settings, using the internal screen.

0. If I boot the Mac with the eGPU powered up on connected, I don't get the Chime and screen remains black, I guess it has to do with some GPU conflicts. Not yet figured out if there is any workaround for this, but not a major issue for me to power on the eGPU during Win startup instead.

1. Ran DDU to uninstall the AMD Bootcamp drivers. eGPU still disconnected.

2. Connected eGPU, installed nVidia drivers, got Code 12. After much reading, I found the reasons could be a) too fresh Win version b) "Large Memory" allocation not available (believe this might be the case for any TB2 Mac, not sure..?)

There had been a recent discovery on the forums that replacing PCI.SYS in System32 with a version from the older Win versions could solve the issue. Tried it, as many had success, still no success for me. At this point I was pretty convinced it had to do with the Large Memory allocation not available. I tried disabling a bunch of devices on the PCI bus, but could not get rid of Code 12.

I was getting desperate and bit the bullet, I had hope this would have been easier. I created my own DSDT table. I understood that by using a custom one, Windows should finally be able to allocate the Large Memory addressing space.

Lo and behold, to my surprise, it worked! (although being honest I didn't really follow exactly what I was doing during the steps of the DSDT creation..).

3. I moved my DSDT to an automate-eGPU boot USB (and removed the apple_set_os.efi).

(side story, in between all my attempts, I also tried booting with the apple_set_os.efi) which seemed to have activated the iGPU which normally is locked in these Macs, at least the Intel HD Graphics 530 was visible in device manager. I wasn't however able to actually activate it for the internal screen, which still used the dGPU running on the Basic Win Graphics driver. I tried running the integrated.bat to activate the iGPU, but couldn't make it work.).

4. Boot the Mac from the automate-eGPU USB, select Windows, now "Large Memory" is available and Code 12 was gone, first success!

5. I was getting excited, but I still had one issue to overcome. The default Windows Graphics driver for the dGPU was locking the resolution to 4k in Windows, and all games inherited this lock, meaning I was not able to change resolution to say 1440p, and the FPS's I got on 4k were awful.

6. I was running out of ideas, and then thought I'd give it a shot.. I disconnected the eGPU, and re-installed the Bootcamp AMD drivers (just drivers, not all the extra software), now, I was able to change resolution again. All good so far.

7. Booted Windows, now with eGPU connected. For some reason I was expecting something catastrophic as I had both AMD and nVidia drivers installed.. All booted up, no issues.

Capture

8. Disabled automatic Win updates..

9. Select the eGPU to be used for my gaming .exe's

Capture2

10. PLAY!

Call of Duty   Modern Warfare  02 04 2020 10 43 21

Benchmarks

image

Let me know if there is a specific benchmark you would like me to run.

3DMark doesn't run for some reason, gets stuck at "Collecting System Info".

Comments

I don't think I was able to find a single successful build with the 2015 5k iMacs on Win10, using the internal screen, so I didn't know what to expect. Unfortunately you stumble upon a lot of outdated information as well. I really think the key to success in my case is the update MS has done for Windows where you are now able to manually select the GPU to be used for specific .exe's, what a great feature!

Once again a big thanks to everyone active here!

 

This topic was modified 7 months ago

27" iMac Retina 5k 2015 - AMD Radeon R9 M390

 
2015 27" iMac 5K (R9 M390) [6th,4C] + GTX 1070 @ 16Gbps-TB2>TB3 (AORUS Gaming Box) + Win10 1909 [build link]  


ReplyQuote
Raimondolorenzi
(@raimondolorenzi)
New Member
Joined: 7 months ago
 

My Congratulations!! I really hope to reach the success as you. I have your same IMac from the same year (but 4K) and I’m going crazy with that.

I tried my best following all the suggestions in this forum with the suggested Windows version (authomated egpu efi, dsdt override, all..) but my 5700 xt always gives error 12. 
You have gift me a bit of energy to try again.

I’m going to upgrade the windows version and modify this system 32 guide. Can you do me a little guide with the process? I haven’t understood how to modify that.

excuse me for my English but I’m Italian.

thanks and congrats again.

Lorenzo.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
zeba
 zeba
(@zeba)
Active Member
Joined: 8 months ago
 

Hi @raimondolorenzi

Hope we can get it to work for you as well!

Which Windows 10 version do you have installed?

Also, as you are trying to get an AMD card to function, I believe you need the drivers from: https://www.bootcampdrivers.com/

Did you try those?

Regarding pci.sys, all I did was boot my computer in Safe Mode and replaced the pci.sys file in System32, with the file posted on this thread, seems to be the version from a Windows release earlier than 1909 (which I'm on today).

https://egpu.io/forums/pc-setup/egpu-fail-after-update-to-windows-19-03/paged/11/#post-71374

Seb

27" iMac Retina 5k 2015 - AMD Radeon R9 M390

 
2015 27" iMac 5K (R9 M390) [6th,4C] + GTX 1070 @ 16Gbps-TB2>TB3 (AORUS Gaming Box) + Win10 1909 [build link]  


ReplyQuote
Raimondolorenzi
(@raimondolorenzi)
New Member
Joined: 7 months ago
 

 Hey @zeba, thanks for your reply.

I’m running the best windows  version at the moment (.295).

I know about drivers, I tried all (official and unofficial). Nothing to do.I’m locked on error 12 between the amd graphic card and his audio (that’s crazy)

I’ve finally opened a discussion because I can’t come out alone from this situation I think. I need the pro here 😂

Waiting for the mod to approve my post (I can immagine they have a lot of work to do here)

thanks again and I will keep you updated 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Huge
 Huge
(@huge)
New Member
Joined: 5 months ago
 

Hi @zeba,

Could you share your DSDT-file?

I have issues to create my own custom DSDT file and currently there aren't any iMac 5k 2015 late files available.

EDIT: I  can't send pm yet. Thanks Zeba! I did get it working before you send your file. I just deleted the part of the code that gave me an error and hoped it was not anything important. 

iMac 27 5k 2015 late + core x chroma + Powercolor 5700xt


ReplyQuote