2015 27" iMac 5K (R9 390) [6th,4C] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X) ...
 
Notifications
Clear all

2015 27" iMac 5K (R9 390) [6th,4C] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.7 & Win10  

  RSS

nirvanich
(@nirvanich)
Active Member
Joined: 7 months ago
 

System specs: iMAC 27" - late 2015, i7 4.0, dGPU - Radeon M390 2Gb, iOS Catalina 10.15.7 + Windows 10 1903 - build 18362

eGPU hardware: Razer Core X, Asus Radeon 5700XT 8Gb, original Apple T2-T2 cable 2m + Apple TB3 to TB2 adapter, didn't use Razer Core X cable 

Installation steps 

1. Old iMac from 2015 requires purge-wrangler to "see" eGPU, updated iOS to Catalina because Apple supports Radeon 5700XT only in Catalina, SIP deactivated

2. Tried to play a couple of games with eGPU in 4-5K resolution in iOS - everything is working

3. Installed Bootcamp Windows 10 - build 18362

4. Created    automate-eGPU EFI boot USB under iOS - easier

5. Turned off eGPU. Boot into Windows with EFI USB. DSDT overrun, large memory in device manager appeared

6. DDU + Installed video drivers - cumulative 2019 from bootcampdrivers.com

7. Turned off the computer. Turned on eGPU

8. Started Windows with dGPU and eGPU together - a couple of reboots as AMD X Connect asked me to do it

9. Disable Windows updates. Open Windows graphics preferences and put the apps/games you want with the best performance

 

Benchmarks - to be continued

AIDA64
2
1

 

 The results are not great with an internal monitor.

3DMark said it will be low with such indirect connection.

I connected directly with HDMI cable to my TV - 65" LG, not ideal, but I don't have a 2nd monitor to check it out.

The results on external TV are a bit better.

 

Comments - all games are installed on external Seagate HDD 4Tb (low speed, yes, I know)

RDR2 game is not happy with 2019 drivers, FPS~20-30 on Ultra settings with 3200x1800 resolution

GTA5 - FPS~50-60

Cyberpunk 2077 - ok

I need to upgrade either my internal iMac SDD or find external SDD

Also, I want to try to install new drivers from Dec 2020 - see what is going to happen

This topic was modified 7 months ago

iMac 27" 5K (late 2015) + Razer Core X + Asus Radeon 5700XT

 
2015 27" iMac 5K (R9 390) [6th,4C] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 10.15.7 & Win10 [build link]  


ReplyQuote