2016 17" Sager NP98...
 
Share:

2016 17" Sager NP9870-S 2 x GTX 980M+ Titan X [email protected] Gbps-TB3 + Win10 1803 + [basecase01]  

  RSS

basecase01
(@basecase01)
Active Member
Joined: 3 months ago
Posts: 13
April 26, 2019 5:20 am  

System Specs:

  • i7-6700K.
  • 2 x GTX 980M in SLI.
  • 17" GSync @ 75Hz.
  • 256 Gb M.2. (Win10 1803 Partition).
  • NVIDIA Driver: 419.67 DESKTOP.
  • Thunderbolt 3 Driver: 17.4.77.400.
  • Thunderbolt 3 Firmware: 18.05
  • BIOS: V.1.05.11 LS2. (Oct 2018? release)

eGPU Hardware:

Hardware Pictures:

Installation Steps:

Started off testing the setup with PNY XLR8 GTX 1060 6 Gb, later on moved to Titan X Pascal. Technically plug-and-play with Win10 1803, TB3 driver 16.3.61.275, TB3 firmware 18.05. eGPU showed up as Basic Display Adapter, but after DDU/419.35 Mobile install, fan speed hit 100% RPM whenever the driver was loaded. eGPU was not responsive to MSI Afterburner or any of the fan curve control software. Had a friend double-checked that both cards were fully functional in a desktop motherboard. Could still use the card to power an external display, but performance was crippled. Posted a thread asking for help about 1 month ago, obviously tried recommendations there but nothing worked. Since then until yesterday, the following were tried without success:

  • Rolled back to 419.17, 418.91, 399.24, 399.07, 398.36, 398.11, DDU each time, installed only base driver + PhysX. Ensured that Windows did not interfere. Used 419.35 Desktop for remainder of testing. Also tried uninstalling/disabling dGPU after DDU before installing the Nvidia driver, but this either didn't work or resulted in very buggy GPU behaviors like fans not spinning under load.
  • Updated TB3 driver 16.3.61.275 > 17.2.71.2 >  17.4.77.400. Reinstalled TB3 firmware.
  • Updated BIOS from 1.05.06R LS1 > 1.05.08 LS3 > 1.05.11 LS2.
  • Updated Windows 10, have KB4480730, KB4023057, KB4489868, KB4100347 installed (cumulative updates).
  • Cleaned out Razer Core X power connectors, swap things around, inspected for damage and whatnot, measured rail voltages. All were fine.
  • Ran eGPU with BPlus PE4C v4.1 with NGFF M.2. extender. Max fan spin and some weird Error 43 issue. Probably due to the extender/incorrect delays. 
  • Tried forcing dGPU to run Basic Display Adapter driver using this method. Did not realize at the time that the end result was exactly what was needed.
    Also tried messing around with removing oem#.inf and .PNF under %systemroot%/inf + uninstalling the dGPU through Device Manager. 
  • Used Group Policy to force dGPU to not go back to using Nvidia driver after uninstalling them through Device Manager.

The issue was identified to be NVIDIA driver spazzing out over having Maxwell (dGPU 980M) and Pascal (1060/Titan X Pascal) card running simultaneously, as originally suggested by @itsage. The solution was not DDU - you have to disable the dGPU, enable the eGPU, and restart the NVIDIA Control Panel. Only this was needed for the setup to work properly, and nothing else done during the month long troubleshooting process affected anything.

1. Disable Windows automatic driver install/update, DDU ,re-installing NVIDIA *desktop* driver with the eGPU connected. Endure max RPM for now. (Also blower style cooler fan can hit up to 5400 RPM, or professionally called as "****ing loud").

2. Open Device Manager>Display Adapters>Disable the dGPU. Go back to Desktop and confirm that the NVIDIA Control Panel no longer show up when right click on empty space. Keep Device Manager open.

3. Plug in the Razer Core X, wait for the eGPU to show up, and enable it in Device Manager.

4. Open Control Panel>(Change view to Small Icons) Run NVIDIA Control Panel. Only the eGPU should show up.

At this point on my system, the internal display is running as if it's using the Basic Display Adapter driver for the dGPU, and it does not show up in the NVIDIA Control Panel at all. Brightness control is completely lost. Disabled GPUs do still trigger fan spin whenever they get hot (they don't). eGPU can be controlled/overclocked via MSI Afterburner.

To revert back to dGPU, Device Manager>Display Adapters>Enable dGPU and disable the eGPU. NVIDIA Control Panel shouldn’t crash since there’s still a card that’s running the driver. For driver update, the driver re-enable disabled cards anyway, so no need to worry about that. SLI settings and whatnot are also retained for dGPU when switching. In any case where the eGPU fan spin reverted to max RPM, disable the eGPU, unplug the eGPU adapter, and repeat from step 1.

Benchmarks:

Comments:

My 1st eGPU setup is done, and hopefully it's the last that I have to invest this much time and efforts into troubleshooting. Bitterness aside, I learnt a lot about how the whole eGPU shebang works, and that the upgrade is definitely cheaper than a 1070 mobile, which is the best card I can upgrade 980M in SLI to. I was hoping to get eGPU to work with my laptop so that when the internal 980M breaks, I will still have a decent system to do whatever. Now that the system is working as expected, I guess I can hold off on upgrading to desktop for another couple of years. 

This topic was modified 4 weeks ago

Sager NP9870S PE4C v4.1 Pending dGPU failure.


Quote