2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AORUS Gaming Box) + macO...
Clear all

2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AORUS Gaming Box) + macOS 10.13 & Win10 [iSilver]  


New Member
Joined: 2 years ago

System Specs

  • 2017 13" MacBook Pro TouchBar (Model 14,2)
  • 3.1 GHz Intel Core i5
  • 8 GB RAM
  • 256 GB SSD
  • macOS High Sierra 10.13.2
  • Windows 10


eGPU Hardware


Hardware Pictures

IMG 2359
IMG 2360

(It's a dorm room, in case you're wondering)


Installation Steps



  • I bought the Gaming Box enclosure used without the normally-included GTX 1070
  • Open up the enclosure, insert the graphics card (it's board powered, so the power connectors in the box are unused), close it up
  • Plug the monitor into the graphics card's HDMI port
  • Plug the thunderbolt 3 cable into the top-left port on the Macbook (the one closest to the screen)
    • Note: the other port on the left side seems to work just as well in my experience



  • Install Goalque's automate-eGPU (instead of disabling SIP completely, I just allowed kernel extensions with "csrutil enable --without kext")
  • Done!



  • Install Windows 10 via the bootcamp assistant
  • Use Display Driver Uninstaller to remove all included AMD Radeon drivers
  • Create a bootable USB with Goalque's apple_set_os.efi
  • Shut down the laptop, plug in the thunderbolt cable to connect it to the enclosure, boot into Windows using apple_set_os.efi
  • Install Radeon drivers from the AMD website
  • Reboot
  • Done!




I haven't run any benchmarks, but here's my experience with a few games (all run on the external 1080p monitor at native resolution):

  • Rocket League (max settings): ~75 fps
  • Assassin's Creed 4 Black Flag (high settings): ~40 fps
  • Tribes Ascend (max settings): ~60 fps
  • Counter Strike (max settings): ~70 fps




Windows Setup

  • Since setting this up I've switched to booting via rEFInd so that I don't need the bootable USB for apple_set_os.efi, but it doesn't make any functional difference
  • Booting into Windows without apple_set_os.efi results in a crash on startup
  • I tried various hotplugging methods and none of them worked for me
  • Occasionally, even with apple_set_os.efi, Windows won't properly recognize the eGPU when booting up, and crash on startup. Power-cycling the eGPU (plug out, wait a few seconds, plug back in) seems to fix the issue
  • Use with the internal display also works via AMD XConnect. Ejecting the external graphics and disconnecting the eGPU afterwards works without any problems in that case. However, connecting the eGPU while the laptop is on hasn't worked for me


Gaming Box



  • Thanks to Goalque for providing his tools (without which neither Windows nor macOS would work for me!)
  • Thanks to Nando4, theITsage, and various other folks on this forum for all the helpful posts
  • Thanks to mzeb for his implementation guide for a similar 2017 Macbook pro touchbar + AMD card setup

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts

nando4 liked
New Member
Joined: 2 years ago

Hey, can I just confirm that it is alright to not use an external monitor and just use the internal display with this setup?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts

Noble Member
Joined: 3 years ago

Great little set up this... have you tried any other games? Would be interested to hear how PUBG fairs. I'd love a mini AMD eGPU set up but have never managed to beat error 12, no matter what instructions I follow.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10


LG 5K Ultrafine flickering issue fix

New Member
Joined: 1 year ago

Thanks for your sharing!

I bought a Aorus gtx1080 gaming box and replaced the gpu to MSI rx560(used - bought from ebay) just like yours. But when I connected it to my 2016 MBP13(10.14.2 Mojave), it didn't work(rx560's fan didn't run and the light of gaming box didn't open). The power seems work great cause the little fan of it was running. I did a test with the original 1080 card, card's fan running good and the light was on - even I didn't set the workground of Nvida.
I thought it's the rx560's problem maybe. What do you think? Did the fan run when you first connected?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts