2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS...
 
Notifications
Clear all

2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS 10.15.4 & Win10 [Eightarmedpet] // Win10 Insider Preview  

  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Haven't used my eGPU for a bit due to building my SFFPC hack, but there is something about them that still appeals to me, I expect to set one up perm again pretty soon.

In the meantime thought i'd have a play with the latest W10 Fast insider preview and set up was SO easy.

It has felt things have been a bit static for a bit, or even going backwards with less enclosures available and Windows being a PIA, but this insider preview (combined with automate-eGPU EFI bootloader) really shows how far we have come in the last couple of years.

My SFFPC is already being a bit of a dick, having USB issues in W10 (macOS is totally fine) which reminds me why I despise windows machines - I don't care if its a simple fix, I dont want to have ot work out simple fixes to use an expensive tool everytime I use it, I want i to just work so I can get on with my day job earning money.

 

 

System specs 

2017 13" Macbook Pro. i5, 16GB 512SSD. macOS and W10 (Insider Fast Preview - important).

 

eGPU hardware (eGPU enclosure, video card, any third-party TB3 cable, any custom mods)

RX 560. Akitio Node lite.

 

Hardware pictures 

Not going to bother this time as it was just on my sofa and living room floor.

 

Installation steps (what did you do to get it all going?)

 

edit: Pretty sure I've disabled SIP and enabled boot from external, I often forget to mention that

 

  1. Instal W10 via Bootcamp helper.
  2. Update update update.
  3. Sign up to fast insider build.
  4. All the updates.
  5. Plug in eGPU (RX 560 in Node Lite) and let Windows instal all the drivers, lots of beeps and bops and pop ups but resulting in detected RX 560 but error 12.
  6. Build automate-eGPU EFI Bootloader USB in macOS with auto build script, selecting Nvidia.
  7. Boot holding down option.
  8. Select USB.
  9. Select Boot options in menu.
  10. Select W10.
  11. W10 Boots.
  12. Notification that there have been hardware changes and I need to reboot (U WOT M8!?!).
  13. Green screen crash.
  14. Reboot and go back to steps 7-11.
  15. All boots fine.
  16. Profit.

 

Comments 

Just did this to test W10 insider preview and, oh boy things have changed since I last tried to set things up... as per usual massive thanks to the mods here and all their work, without you guys this would not have been possible.

While I love the all in one solution that is my Mantiz I will also always have a soft spot for mini eGPU's like this, I wonder if RDNA2 will bring a sub 75W GPU that's powerful enough for 1440 gaming.

This topic was modified 1 month ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS 10.15.4 & Win10 [build link]  


nando4 and itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@eightarmedpet, I fully agree with you on the appeal of tiny eGPU. I wish more vendors would buy into the TUL mini eGFX so that it can get improved. The current form doesn't look great due to the needs for ventilation. Functionality-wise it has been working really well. I would think if you were to modify an AKiTiO Thunder3/Node Lite for ITX eGPU, it's as easy to use the main board from TUL mini eGFX and create your own enclosure. Or use it exposed without any enclosure to showcase the graphics card [RTX 2060 Super build].

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 5700 @ 32Gbps-TB3 (Prototype eGPU Enclosure) + macOS 10.15.4 & Win10 1903 [build link]  


ReplyQuote
keat320
(@keat320)
New Member
Joined: 1 month ago
 

Thanks for the write-up, it sounds very promising!  I gave it a try on my 2017 13" MBP + Razer Core X + Radeon VII, but unfortunately after step 13, I'm now stuck in a boot loop, never getting past the spinning circles under the windows logo.  Same thing whether I unplug the eGPU and boot with or without the EFI.  Any thoughts?  It's pretty frustrating because I have restore points, etc., but I can't even find a way to restore them now, and have to start over again with a new bootcamp install.  BTW did you do any of this with an external screen attached to the eGPU?  Any idea if that makes a difference?  I've been trying without.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

@keat320 , oh rats, just seen your comment here after linking you to this thread, sorry about that...

The problem I have found with Windows is its not stable or predictable in any sense, I am currently running a dual boot Hackintosh and I have less issues in macOS than I do in Windows, and its an AMD build!

itsage had some pretty painless set ups with various versions of windows I couldnt even get to a stable instal with, it feels like total pot luck at times. One thing I have learned is to not rush things, let windows sit there for a bit, installing secret updates and rearranging things in the background, if you can get it to boot a couple of times feeling the same you should be good, if not time to try an older version. Before this insider preview I only managed to get 1607 and 1803 to work, so could be worth trying them?

Defo try this whole process without the display to start with, less peripherals the better.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Little update, tried with my Vega 56, Mantiz and the older EFI Bootloader, no issues... I really need to clean my Macbook.

Temp set up to test:

IMG 2885
IMG 2886

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS 10.15.4 & Win10 [build link]  


itsage liked
ReplyQuote