2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS...
 
Notifications
Clear all

2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.3 & Win10 [Eightarmedpet]  

 of  3
  RSS

mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@itsage

apple_set_os.efi issue was reported here:  https://github.com/0xbb/apple_set_os.efi/issues/20

Please try the EFI file there posted by ah-.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 
Posted by: @mac_editor

@itsage

apple_set_os.efi issue was reported here:  https://github.com/0xbb/apple_set_os.efi/issues/20

Please try the EFI file there posted by ah-.

I tried the latest EFI file linked. The internal display on my 2019 13" MacBook Pro didn't get stuck at Windows logo during boot with eGPU connected. However it stayed black instead of loading to the Windows Desktop.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2013 Mac Pro (FP D500 x2) [3rd,12C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Mantiz Saturn Pro) + macOS 11 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@itsage

Interesting. Not sure what to make of that. One possibility is to try this with working eGPU connected display and check if iGPU is visible in device manager.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@itsage forgot to mention that there were no software updates between it working and not working... unless something happened in the background that I didnt notice but thats very unlike Windows which for some reason feels the need to interrupt whatever I am doing anytime the smallest thing happens...

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

Updated to Catalina and yep, EFI and rEFInd are broke... struggling to get my Ultrafine recognised as well.

Have tried the updated apple_set_os in EFI bootloader but it only half worked (Vega was fine, igpu was error 43 and black Ultrafine).

Hot plugging doesn't work (at spinning circles) and results in error 12.

@itsage what version of W10 are you running on your 2017. because 2017's and 2019's behave differently...

Edit: Just tried my rEFInd instal again, even though all reports said it would have the same issue (unless I mis read/mis assumed) and all in fine. Thank bloody god. Having a few detection issues with the Ultrafine still but I dont think thats eGPU related.

 

God I love you rEFInd, don't ever leave me, please...

This post was modified 11 months ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@eightarmedpet My recommendation is to update your Windows 10 to 1903 18362.418 which is the latest version on my 2017 13" MacBook Pro. I recall we both had issues (endless boot loop) with earlier Win10 1903 versions. Basically do a clean install from Win10 1903 V2 (OS Build 18382.356) off Microsoft website then perform Windows Update to .418. Install/reinstall rEFInd in macOS. Boot into Windows with RX 5700 XT eGPU attached through rEFInd then install latest Radeon drivers. The current issue with rEFInd and apple_set_os.efi only effects 2018 and newer Macs with Apple T2 chip.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2013 Mac Pro (FP D500 x2) [3rd,12C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Mantiz Saturn Pro) + macOS 11 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@itsage... hmmm.. that's a risk as my set up is working with my Vega, just, atm, you think the W10 instal is somehow responsible for the error 43?

I didn't have a boot loop with earlier versions of Windows but endless issues with TB3 and instal corrupting when connecting leading to reinstall. I may just send the 5700XT back and stick with the loud Vega.

This post was modified 11 months ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@eightarmedpet I found the post for the 2017 13" MacBook Pro + RX 580 eGPU in 18392.356. I disabled all the unused PCIe components to be safe. PCI Express Root Port #9 [right-sided TB3 controller] and Port #12 [Wireless card] were re-enabled since and there's no error 12. It's not been tested with the RX 5700/XT eGPU however. I will try it later this week and report back.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2013 Mac Pro (FP D500 x2) [3rd,12C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Mantiz Saturn Pro) + macOS 11 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@itsage cheers! Look forward to seeing the results... although my problems are compounded by my bloody screen again as I need the right side ports to run it...

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
Jendrik Reiß
(@jendrik_reis)
Active Member
Joined: 11 months ago
 

@eightarmedpet

have u solved the code 43 error?

Macbook Pro 2019 13Inch 2,4GHZ / WIN 10 1809 / MacOS 10.15.1
Razer Core X Chroma
Asus ROG Strix Rx 5700 XT


ReplyQuote
 of  3