2017 13" MacBook Pro [7th,2C,U] + RX Vega 56 @ 32Gbps-TB3 (Razer Core) + macOS ...
 
Notifications
Clear all

2017 13" MacBook Pro [7th,2C,U] + RX Vega 56 @ 32Gbps-TB3 (Razer Core) + macOS 10.14.2 & Win10 1803 [Eightarmedpet]  

 of  3
  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

Going to be adding to this, but basics for now...

System specs: 

2017 MacBook Pro 13inch. i5, 16gb ram.
LG Ultrafine 5K display (a beautiful bane of my life)

eGPU hardware 
Razer Core V1
Sapphire Vega 56 Ref model

Hardware pictures

pic

Installation steps 

macOS: Run @maceditors purge wrangler script to enable the older Ti82 chip then I'm golden. Hot plug whenever I fancy. Still get crap FPS in games mind with prefer eGPU option selected.

Windows: So I had a one or two problems with AMD cards, not sure if I have ever mentioned them here, but yeah, Error 12 on 3 different cards no matter what I tried. For me the LG 5K compounded the problem as certain work arounds caused bandwidth limitations (my guess - not solid fact so please don't take as gospel) which caused my TB3 (not USB-C) monitor to stay black despite being detected and connected peripherals being active.

The EFI Bootloader is the ONLY work around that's worked for me, but even then its not quite perfect. When tested with my Nvidia card I could leave things plugged in and it was great booting too and from Windows and macOS (despite the 1070 not working with macOS).

First time set ups are usually really easy, infact Windows tends to do it all itself but subsequent boots are back to error 12.

With my Vega the trick was hot plug after selecting Windows in EFI boot loader. The timing window is very narrow so it sometimes takes a few attempts, it has to be plugged after I hit enter but before Windows begins to boot otherwise its back to error 12.

Benchmarks

The Division
Pleasant surprise... runs better since I last tested it with my 1070. Previously around 35 now around 55+ on high settings.

365590 screenshots 20190120110924 1

DayZ
The whole reason I began to learn about GPU's and got into PC gaming, latest build running in the 70's-80's with my previous mix of setting, turned near everything to max and still managed 50-60fps. Oh, and managed to get killed within seconds of spawning.

221100 screenshots 20190105143101 1

Fallout 4
This has pretty much been 50-60fps since I had a 1060... no change here.

377160 screenshots 20190108171054 1

Comments
I've been after a decent GPU in both macOS and W10 for years now, from my hackintosh days I found Nvidia drivers were always pretty poor with cards under performing compared to Windows (it might not be the drivers) so keen to get AMD working. Also didn't want to hack macOS.

My only gripe is everything is pretty loud when gaming. The Core is notably loud, the Ref blower card sounds like a hairdryer and my MacBooks fans are maxed. It's not too bad as I game with headphones but I've bought a maxed out Mac mini (ok not £5k maxed out) which will hopefully both improve performance in games and reduce noise. Once Navi cards are out I may replace the Vega too.

Notes:
Tried setting up using both apple_set_os and rEFInd, both worked first time but subsequent attempts failed - back to either error 12 or no eGPU detection. Quite frustrating as I spent the time updating my rEFInd theme to work @4/5K.

Update:
So after a few months use and various differnt boot techniques I think, think I have finally found a consistent boot method.
EFI Bootloader required hotplugging which was super temperamental.
rEFInd didnt detect.
TB3 Monitors are a bitch.
Solution...
I rarely turn my laptop off, its closed and connected to the screen via the right hand TB3 ports and the eGPU via the left TB3 ports. macOS is all fine and dandy, to get W10 to work I reboot and select W10 using the rEFInd Boot manager without unplugging a thing. Boots to desktop but the eGPU isn't detected. Unplug replug adn I've got error 12. Reboot without touching anything > rEFInd and select W10 and after a slightly prolonged boot process (time wise) I'm in and its working! Been doing it this way for a few weeks now and feels solid. 

Fingers crossed. 

This topic was modified 2 years ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

I'm glad to see this build. fATX power supplies are loud with their tiny fans. A fun mod would be to relocate the PSU outside and free the inside room for cooling. You can also use the empty space for Thunderbolt 3 monitor output components.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2013 Mac Pro (FP D500 x2) [3rd,12C,E] + RX 5700 XT @ 16Gbps-TB2>TB3 (Mantiz Saturn Pro) + macOS 11 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@itsage are you glad because you may have finally heard the end of me banging on about error 12?  😉 

Those links are super interesting, until the recent $2900 price hike of those spare Akitio boards I was tempted to grab one of them and build a fully custom solution inspired by this classic...  https://theultralinx.com/2012/09/beautiful-computer-piece-furniture/

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


itsage liked
ReplyQuote
jerry Kansai
(@joi_kansai)
Estimable Member
Joined: 3 years ago
 
Posted by: Eightarmedpet

Going to be adding to this, but basics for now...

System specs: 

2017 MacBook Pro 13inch. i5, 16gb ram.
LG Ultrafine 5K display (a beautiful bane on my life)

eGPU hardware 
Razer Core V1
Sapphire Vega 56 Ref model

Hardware pictures

Installation steps 

macOS: Run @maceditors purge wrangler script to enable the older Ti82 chip then I'm golden. Hot plug whenever I fancy. Still get crap FPS in games mind with prefer eGPU option selected.

Windows: So I had a one or two problems with AMD cards, not sure if I have ever mentioned them here, but yeah, Error 12 on 3 different cards no matter what I tried. For me the LG 5K compounded the problem as certain work arounds caused bandwidth limitations (my guess - not solid fact so please don't take as gospel) which caused my TB3 (not USB-C) monitor to stay black despite being detected and connected peripherals being active.

The EFI Bootloader is the ONLY work around that's worked for me, but even then its not quite perfect. When tested with my Nvidia card I could leave things plugged in and it was great booting too and from Windows and macOS (despite the 1070 not working with macOS).

First time set ups are usually really easy, intact Windows tends to do it all itself but subsequent boots are back to error 12.

With my Vega the trick was sort hot plug after selecting Windows in EFI boot loader. The timing window is very narrow so it sometimes takes a few attempts, it has to be plugged after I hit enter but before Windows begins to boot otherwise its back to error 12.

Benchmarks
Soon...

Comments
I've been after a decent GPU in both macOS and W10 for years now, from my hackintosh days I found Nvidia drivers were always pretty poor with cards under performing compared to Windows (it might not be the drivers) so keen to get AMD working. Also didn't want to hack macOS.

My only gripe is everything is pretty loud when gaming. The Core is notably loud, the Ref blower card sounds like a hairdryer and my MacBooks fans are maxed. It's not too bad as I game with headphones but I've bought a maxed out Mac mini (ok not £5k maxed out) which will hopefully both improve performance in games and reduce noise. Once Navi cards are out I may replace the Vega too.

Clean setting, Black, space grey, white...What is that black line? LoL
Blower cards is kryptonite for the core Mr. Green  It’ll scream louder using it from my Tests, Asus Turbo, MSI Aero, and pascal Fe. Wait for benchmarks, i just got my Evga Black 2070 back from Factory, it was another DOA RTX Twisted . Though great CS, giving me BFV for free even bought it before campaign, sold it since already have it right away that made the price under €500  😉 . Doing some benchmarks and OC scans now quite promising. Still capable card in 4K Area on FFXV benchmark, feels better (less laggy) compared to 1080 FTW2 that i had that cost €550 on Amazon last year. I planned  to upload it to user build as well.

Razer Blade 15 2018, i7 8750H 16gb ddr4 2666mhz 1tb 970Evo
Razer Blade Stealth 12,5 2016 i7 7500U 8gb ddr3 1866mhz 500gb 970Evo
MacBook Pro 13 mid 2012 i5 3210M 12gb ddr3 1600mhz 500GB HDD
Razer Core V2 rtx 2070 Black 2040mhz Boost clock
Previous setting: rtx 2080ti Asus Turbo, rtx 2080 xc gaming, rtx 2080 Fe, Zotac Mini 1080ti, Evga 1080 FTW2 gaming.
Dual Monitor Predator XB241YU 165Hz 1440p, LG l24UD58 60Hz 4K
Portable Monitor Magedok 1440p HDR 60Hz usbA/C monitor

 
2016 12" Razer Blade Stealth [7th,2C,U] + RTX 2080 Ti @ 32Gbps-TB3 (Razer Core V2) + Win10 1803 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@joi_kansai thanks! Not sure what that black line was, some sort of upload error? Have replaced img...
RTX sounds like a shit show! I'm going to see what Navi turns out like before changing card again although I do want more power than current, and a quieter set up, lets see what the coming year brings egpu world wise...
My Mac mini wasn't great so already returned it, TB3 detection was way too flakey, and I only noticed about 10-15fps increase in games.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

Update: I am an idiot.

In all my previous attempts I don't think I ever tried the eGPU and TB3 monitor on separate sides... I made a bootable USB in about 5 seconds and rebooted to test and it worked perfectly. I think I never tried because I was under the impression you had to disable the right side ports to get past error 12, but nope... set up as per original pic.

I have both iSight cameras disabled but nothing else - not sure if that has made the difference?

This post was modified 2 years ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 
Posted by: Eightarmedpet

... I think I never tried because I was under the impression you had to disable the right side ports to get past error 12, but nope... set up as per original pic.

This is what I am talking about and my only critic: People got scared of Error 12 and do things that are absolut not necessary. It's handled the wrong way.
Really, "disable the right side"? This can't be a real solution, I paid 4000 bucks on a MacBooPro and can't use one side of the TB3 ports? No frakking way 😉

EDIT:@eightarmedpetCongratulations, you finally got the 5k Ultrafine working. This is well deserved!

This post was modified 2 years ago

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

@oliverb ha, I didn't want disable the right side ports either, even if I hadn't of ended them. Not every user needs every step in each guide sure, but IMO they are best practice and most likely to work for most people.

Might be time to try rEFInd again too, I like the look of the custom egpu boot manager theme...

Spoke to soon, second boot the ogpu wasn't detected... 

This post was modified 2 years ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago
 

Can't remember who I was talking to on here reg Vega tweaks so bumping my own thread...
Followed the instructions on and took my FPS in PUBG from 35-45 to 60+

This post was modified 2 years ago

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


itsage liked
ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 4 years ago

ReplyQuote
 of  3