2017 13" MacBook Pro + RX Vega [email protected] (Razer Core V1) + macOS 10.4.2 & W10 1803 [eightarmedpet]  

  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1223
December 13, 2018 1:36 pm  

Going to be adding to this, but basics for now...

System specs: 

2017 MacBook Pro 13inch. i5, 16gb ram.
LG Ultrafine 5K display (a beautiful bane of my life)

eGPU hardware 
Razer Core V1
Sapphire Vega 56 Ref model

Hardware pictures

Installation steps 

macOS: Run @maceditors purge wrangler script to enable the older Ti82 chip then I'm golden. Hot plug whenever I fancy. Still get crap FPS in games mind with prefer eGPU option selected.

Windows: So I had a one or two problems with AMD cards, not sure if I have ever mentioned them here, but yeah, Error 12 on 3 different cards no matter what I tried. For me the LG 5K compounded the problem as certain work arounds caused bandwidth limitations (my guess - not solid fact so please don't take as gospel) which caused my TB3 (not USB-C) monitor to stay black despite being detected and connected peripherals being active.

The EFI Bootloader is the ONLY work around that's worked for me, but even then its not quite perfect. When tested with my Nvidia card I could leave things plugged in and it was great booting too and from Windows and macOS (despite the 1070 not working with macOS).

First time set ups are usually really easy, intact Windows tends to do it all itself but subsequent boots are back to error 12.

With my Vega the trick was sort hot plug after selecting Windows in EFI boot loader. The timing window is very narrow so it sometimes takes a few attempts, it has to be plugged after I hit enter but before Windows begins to boot otherwise its back to error 12.

Benchmarks
Soon...

Comments
I've been after a decent GPU in both macOS and W10 for years now, from my hackintosh days I found Nvidia drivers were always pretty poor with cards under performing compared to Windows (it might not be the drivers) so keen to get AMD working. Also didn't want to hack macOS.

My only gripe is everything is pretty loud when gaming. The Core is notably loud, the Ref blower card sounds like a hairdryer and my MacBooks fans are maxed. It's not too bad as I game with headphones but I've bought a maxed out Mac mini (ok not £5k maxed out) which will hopefully both improve performance in games and reduce noise. Once Navi cards are out I may replace the Vega too.

2017 13" MacBook Pro Touchbar + [email protected] (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + [email protected] (Sonnet Breakaway Box) + Win10

2017 13" MacBook Pro Touch Bar + GTX1070 (debating 2070 upgrade) @32Gbps-TB3 (Razer Core V1) + Win10

2017 13" MacBook Pro Touch Bar + Vega 56 @32Gbps-TB3 (Razer Core V1) + Win10 & macOS 10.14+

---
LG 5K Ultrafine flickering issue fix


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3401
December 13, 2018 2:33 pm  

I'm glad to see this build. fATX power supplies are loud with their tiny fans. A fun mod would be to relocate the PSU outside and free the inside room for cooling. You can also use the empty space for Thunderbolt 3 monitor output components.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

94 external GPU build guides


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1223
December 13, 2018 3:23 pm  

@itsage are you glad because you may have finally heard the end of me banging on about error 12?  😉 

Those links are super interesting, until the recent $2900 price hike of those spare Akitio boards I was tempted to grab one of them and build a fully custom solution inspired by this classic...  https://theultralinx.com/2012/09/beautiful-computer-piece-furniture/

2017 13" MacBook Pro Touchbar + [email protected] (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + [email protected] (Sonnet Breakaway Box) + Win10

2017 13" MacBook Pro Touch Bar + GTX1070 (debating 2070 upgrade) @32Gbps-TB3 (Razer Core V1) + Win10

2017 13" MacBook Pro Touch Bar + Vega 56 @32Gbps-TB3 (Razer Core V1) + Win10 & macOS 10.14+

---
LG 5K Ultrafine flickering issue fix


theitsage liked
ReplyQuote
Joikansai
(@joi_kansai)
Estimable Member
Joined: 11 months ago
Posts: 120
December 14, 2018 3:01 pm  
Posted by: Eightarmedpet

Going to be adding to this, but basics for now...

System specs: 

2017 MacBook Pro 13inch. i5, 16gb ram.
LG Ultrafine 5K display (a beautiful bane on my life)

eGPU hardware 
Razer Core V1
Sapphire Vega 56 Ref model

Hardware pictures

Installation steps 

macOS: Run @maceditors purge wrangler script to enable the older Ti82 chip then I'm golden. Hot plug whenever I fancy. Still get crap FPS in games mind with prefer eGPU option selected.

Windows: So I had a one or two problems with AMD cards, not sure if I have ever mentioned them here, but yeah, Error 12 on 3 different cards no matter what I tried. For me the LG 5K compounded the problem as certain work arounds caused bandwidth limitations (my guess - not solid fact so please don't take as gospel) which caused my TB3 (not USB-C) monitor to stay black despite being detected and connected peripherals being active.

The EFI Bootloader is the ONLY work around that's worked for me, but even then its not quite perfect. When tested with my Nvidia card I could leave things plugged in and it was great booting too and from Windows and macOS (despite the 1070 not working with macOS).

First time set ups are usually really easy, intact Windows tends to do it all itself but subsequent boots are back to error 12.

With my Vega the trick was sort hot plug after selecting Windows in EFI boot loader. The timing window is very narrow so it sometimes takes a few attempts, it has to be plugged after I hit enter but before Windows begins to boot otherwise its back to error 12.

Benchmarks
Soon...

Comments
I've been after a decent GPU in both macOS and W10 for years now, from my hackintosh days I found Nvidia drivers were always pretty poor with cards under performing compared to Windows (it might not be the drivers) so keen to get AMD working. Also didn't want to hack macOS.

My only gripe is everything is pretty loud when gaming. The Core is notably loud, the Ref blower card sounds like a hairdryer and my MacBooks fans are maxed. It's not too bad as I game with headphones but I've bought a maxed out Mac mini (ok not £5k maxed out) which will hopefully both improve performance in games and reduce noise. Once Navi cards are out I may replace the Vega too.

Clean setting, Black, space grey, white...What is that black line? 😆 
Blower cards is kryptonite for the core :mrgreen:  It’ll scream louder using it from my Tests, Asus Turbo, MSI Aero, and pascal Fe. Wait for benchmarks, i just got my Evga Black 2070 back from Factory, it was another DOA RTX 😈 . Though great CS, giving me BFV for free even bought it before campaign, sold it since already have it right away that made the price under €500  😉 . Doing some benchmarks and OC scans now quite promising. Still capable card in 4K Area on FFXV benchmark, feels better (less laggy) compared to 1080 FTW2 that i had that cost €550 on Amazon last year. I planned  to upload it to user build as well.

Razer Blade 15 2018, i7 8750H 16gb ddr4 2666mhz 1tb 970Evo
Razer Blade Stealth 12,5 2016 i7 7500U 8gb ddr3 1866mhz 500gb 970Evo
MacBook Pro 13 mid 2012 i5 3210M 12gb ddr3 1600mhz 500GB HDD
Razer Core V2 rtx 2070 Black 2040mhz Boost clock
Previous setting: rtx 2080ti Asus Turbo, rtx 2080 xc gaming, rtx 2080 Fe, Zotac Mini 1080ti, Evga 1080 FTW2 gaming.
Dual Monitor Predator XB241YU 165Hz 1440p, LG l24UD58 60Hz 4K
Portable Monitor Magedok 1440p HDR 60Hz usbA/C monitor


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1223
December 20, 2018 2:07 pm  

@joi_kansai thanks! Not sure what that black line was, some sort of upload error? Have replaced img...
RTX sounds like a shit show! I'm going to see what Navi turns out like before changing card again although I do want more power than current, and a quieter set up, lets see what the coming year brings egpu world wise...
My Mac mini wasn't great so already returned it, TB3 detection was way too flakey, and I only noticed about 10-15fps increase in games.

2017 13" MacBook Pro Touchbar + [email protected] (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + [email protected] (Sonnet Breakaway Box) + Win10

2017 13" MacBook Pro Touch Bar + GTX1070 (debating 2070 upgrade) @32Gbps-TB3 (Razer Core V1) + Win10

2017 13" MacBook Pro Touch Bar + Vega 56 @32Gbps-TB3 (Razer Core V1) + Win10 & macOS 10.14+

---
LG 5K Ultrafine flickering issue fix


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1223
January 7, 2019 9:59 pm  

Update: I am an idiot.

In all my previous attempts I don't think I ever tried the eGPU and TB3 monitor on separate sides... I made a bootable USB in about 5 seconds and rebooted to test and it worked perfectly. I think I never tried because I was under the impression you had to disable the right side ports to get past error 12, but nope... set up as per original pic.

I have both iSight cameras disabled but nothing else - not sure if that has made the difference?

This post was modified 2 weeks ago

2017 13" MacBook Pro Touchbar + [email protected] (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + [email protected] (Sonnet Breakaway Box) + Win10

2017 13" MacBook Pro Touch Bar + GTX1070 (debating 2070 upgrade) @32Gbps-TB3 (Razer Core V1) + Win10

2017 13" MacBook Pro Touch Bar + Vega 56 @32Gbps-TB3 (Razer Core V1) + Win10 & macOS 10.14+

---
LG 5K Ultrafine flickering issue fix


ReplyQuote
OliverB
(@oliverb)
Reputable Member
Joined: 3 months ago
Posts: 342
January 7, 2019 10:28 pm  
Posted by: Eightarmedpet

... I think I never tried because I was under the impression you had to disable the right side ports to get past error 12, but nope... set up as per original pic.

This is what I am talking about and my only critic: People got scared of Error 12 and do things that are absolut not necessary. It's handled the wrong way.
Really, "disable the right side"? This can't be a real solution, I paid 4000 bucks on a MacBooPro and can't use one side of the TB3 ports? No frakking way 😉

EDIT:@eightarmedpetCongratulations, you finally got the 5k Ultrafine working. This is well deserved!

This post was modified 2 weeks ago

2018 15" MBP & 2013 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1223
January 8, 2019 7:50 am  

@oliverb ha, I didn't want disable the right side ports either, even if I hadn't of ended them. Not every user needs every step in each guide sure, but IMO they are best practice and most likely to work for most people.

Might be time to try rEFInd again too, I like the look of the custom egpu boot manager theme...

Spoke to soon, second boot the ogpu wasn't detected... 

This post was modified 2 weeks ago

2017 13" MacBook Pro Touchbar + [email protected] (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + [email protected] (Sonnet Breakaway Box) + Win10

2017 13" MacBook Pro Touch Bar + GTX1070 (debating 2070 upgrade) @32Gbps-TB3 (Razer Core V1) + Win10

2017 13" MacBook Pro Touch Bar + Vega 56 @32Gbps-TB3 (Razer Core V1) + Win10 & macOS 10.14+

---
LG 5K Ultrafine flickering issue fix


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1223

theitsage liked
ReplyQuote