2017 13" TouchBar MacBook Pro + GTX [email protected] (AORUS Gaming Box) + macOS 10.13.3 [theitsage]  

  RSS

theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3208
March 28, 2018 3:25 am  

System specs:

2017 13" TouchBar MacBook Pro - i5-7267/Iris HD Graphics 650 iGPU/8GB RAM/256GB SSD

 

eGPU hardware:

Gigabyte AORUS 1080 Gaming Box + .5m Thunderbolt 3 cable

 

Hardware pictures:

 

Installation steps:

I tried @fr34k's new script tonight and was amazed at how simple this process has gotten. Copy-and-paste was all it took. My hope is that Apple will eventually incorporate Nvidia to its external GPU functionality. For the time being, this workaround is a very good compromise.

I could connect the AORUS 1080 Gaming Box to an external monitor. However the monitor didn't come on every time. Therefore, I referred to the internal display eGPU acceleration guide and force-fed the eGPU to power the MacBook Pro's internal display.

 

Benchmarks:

All benchmarks were ran with the internal display. The results on the left are higher because the eGPU was connected to a left Thunderbolt 3 port. The right Thunderbolt 3 ports in the 13" MacBook Pro attach to a x2 PCIe root port and they perform worse as shown.

 

Comments:

Apple will eventually enable internal display mode in macOS. Until then the performance hit when using a headless display adapter is rather significant. The 13" display in this MBP scaled to 1400 x 900, matched very well with this AORUS 1080 Gaming Box to provide 60 FPS.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


comfycat and nando4 liked
ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 2 years ago
Posts: 1099

ReplyQuote
precision01
(@precision01)
Eminent Member
Joined: 1 year ago
Posts: 28
April 2, 2018 9:36 pm  

I'm running Aorus Gaming Box on macbook Pro 15" Late 2016 (external display) for quite some time.
But I still can't make AORUS GRAPHICS ENGINE work. It does not launch.
Did anyone had any success making it work?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3208
April 2, 2018 9:40 pm  

@precision01 The latest version on Gigabyte Support website is 1.32. It threw errors when I ran it. I was able to locate version 1.28 [download link] and the software worked well changing RGB light and GPU performance modes. You can change the v1.28 in the url to a different number if 1.28 doesn't work.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
precision01
(@precision01)
Eminent Member
Joined: 1 year ago
Posts: 28
April 3, 2018 2:30 pm  

Thanks a lot @itsage. I will try that this night.
By the way, thanks for you, @nando, @goalque and @richard for the great initiative that become reality with egpu.io . 😉

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


theitsage liked
ReplyQuote
jjjoseph100
(@jjjoseph100)
New Member
Joined: 9 months ago
Posts: 1
May 9, 2018 4:31 am  

Followed directions at top of forum, everything seemed to be working. I tested it in Blackmagic Resolve, CUDA, rendering seemed fine.  Was very exited, then I went behind my computer and touched the Aorus to see if I had a hard drive connected via USB3.  I barely touched the thing, but I did touch the TB3 cable. I didn’t disconnect the TB3, just touched.. Screen Flashed Black then kernal panic on reboot. Disconnected unit, on reboot unit not recognized. After hours of testing, it seems the unit is hosed.  Will have to return Aorus for refund. 

The build quality seems fine, but the TB3 connection seems a little wonky and cheap. Possibly why it committed suicide or shorted. 

Anyway. Hopefully it was a defective unit..  if anyone has similar stories would love to hear about them.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
DeNachtwacht
(@denachtwacht)
Eminent Member
Joined: 5 months ago
Posts: 23
July 24, 2018 7:48 pm  

I am quite interested in this setup. I am doubting between a gaming box 1080 or 1070 to connect with my 2018 macbook pro 13.3" 16GB i5. I am aiming to play 4K games (using Boot Camp) smoothly through an external monitor; will the gaming box 1080 be able to do that? Second question: will the i5 throttle the GPU? If so, it might be smarter for me to cancel the order and go for an i7.

i do see videos of the gaming box 1070 being able to play pubg @ 1440p with 50-70FPS, so I assume that the 2018 MBP with 1080 should be able to achieve this with 4K resolution.. or am I being too positive?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3208
July 24, 2018 8:39 pm  

If you want to do 4K, get the 1080 Gaming Box. Given the thermal envelope of the current MacBook Pro design, more powerful CPU may not be a good thing. Even the i5 MBP is struggling to run cool and stable.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
DeNachtwacht
(@denachtwacht)
Eminent Member
Joined: 5 months ago
Posts: 23
July 27, 2018 4:38 pm  

I bought the Gaming Box 1080 combined with my Macbook Pro 2018, 13,3" but still run into some problems getting it to work under Boot Camp windows 10. I hope you can help me out here. These are the steps I followed, and the errors I receive:

- Freshly installed and updated the Macbook Pro with macOS 10.13.6 including the recent Macbook Pro patch to fix the Throttling issues.
- Installed a fresh copy of Windows 10 version 1803, build 17134.191
- Successfully connected the Gaming Box 1080 to Windows 10 in Boot Camp (hotplugged), it was only detected when I added my external screen to it. It detected 2 GPU's, the Iris 655 and GTX 1080
- Tried to connect my USB C mouse to the macbook pro (not to the gaming box hub!) and this is where the problems started. Crash! After a few other experiments it works again, but now I can't see my Iris 655 in device manager anymore. When I tried to connect a USB c external SSD to the macbook (again: not to the gaming box) the result was again that the Gaming Box shuts down and I loose vision.

My questions:
- I tried to update the firmware from Gigabyte's site to 1.1, but I have no idea if it works successfull and also don't know if I need this firmware, there is also a second version of the 1.0 firmware, is this better?
- I updated the Nvidia 1080 driver to the most recent version in Windows Update, is that the best version?
- Can I hotplug the Gaming Box and hot unlug it in Windows 10 under Boot Camp safely, or should i shut down the device?
- So it does seem to work somehow but as soon as I plug in some USB device it crashes. Is there any way to fix this?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote